Grokbase Groups R r-help March 2002
FAQ
Hi, Guys
I run one simple R script like this

library(e1071)
data(iris)
attach(iris)
model <- svm (Species~., data=iris)

The R version is 1.4.1. The OS is standard redhat 7.2.
Then I got a segmentation fault like this (run through
R CMD BATCH scriptName)
/usr/local/R/lib/R/bin/BATCH: line 54: 28513 Done
(
echo "invisible(options(echo = TRUE))"; cat ${in};
echo "proc.time()" )
28514 Segmentation fault | ${R_HOME}/bin/R
${opts} >${out} 2>&1

There is no problem if the R-binary is running redhat
6.2.

Does anyone see this problem? Is there a workaround
for this?

Help is appreciated.

Jason

__________________________________________________



-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._

Search Discussions

  • Uwe Ligges at Mar 11, 2002 at 9:20 pm

    jason zhao wrote:
    Hi, Guys
    I run one simple R script like this

    library(e1071)
    data(iris)
    attach(iris)
    model <- svm (Species~., data=iris)

    The R version is 1.4.1. The OS is standard redhat 7.2.
    Then I got a segmentation fault like this (run through
    R CMD BATCH scriptName)
    /usr/local/R/lib/R/bin/BATCH: line 54: 28513 Done
    (
    echo "invisible(options(echo = TRUE))"; cat ${in};
    echo "proc.time()" )
    28514 Segmentation fault | ${R_HOME}/bin/R
    ${opts} >${out} 2>&1

    There is no problem if the R-binary is running redhat
    6.2.

    Does anyone see this problem? Is there a workaround
    for this?
    Haven't got RedHat 7.2 available, but your example works perfectly on
    SuSE 7.3, Solaris 5.7 and WinXP.
    So I guess you didn't compile R (or e1071) on your system.
    Maybe there is a small incompatibility with the precompiled version.
    I'd suggest to compile R yourself and install e1071 from the sources.

    Uwe Ligges
    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
  • Jason zhao at Mar 11, 2002 at 10:38 pm

    --- Uwe Ligges wrote:
    jason zhao wrote:
    Hi, Guys
    I run one simple R script like this

    library(e1071)
    data(iris)
    attach(iris)
    model <- svm (Species~., data=iris)

    The R version is 1.4.1. The OS is standard redhat 7.2.
    Then I got a segmentation fault like this (run through
    R CMD BATCH scriptName)
    /usr/local/R/lib/R/bin/BATCH: line 54: 28513 Done
    (
    echo "invisible(options(echo = TRUE))"; cat ${in};
    echo "proc.time()" )
    28514 Segmentation fault |
    ${R_HOME}/bin/R
    ${opts} >${out} 2>&1

    There is no problem if the R-binary is running redhat
    6.2.

    Does anyone see this problem? Is there a
    workaround
    for this?
    Haven't got RedHat 7.2 available, but your example
    works perfectly on
    SuSE 7.3, Solaris 5.7 and WinXP.
    So I guess you didn't compile R (or e1071) on your
    system.
    Maybe there is a small incompatibility with the
    precompiled version.
    I'd suggest to compile R yourself and install e1071
    from the sources.

    Uwe Ligges
    I installed everyting (the R basic, R-recommended
    package and e1071 ) from source. My test example
    worked fine with redhat 6.2, but not redhat 7.2. I
    think maybe it is problem in gcc library or something
    in e1071 package.
    Any suggestion
    Thanks





    __________________________________________________



    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
  • David Meyer at Mar 12, 2002 at 9:35 am

    There is no problem if the R-binary is running redhat
    6.2.

    Does anyone see this problem? Is there a
    workaround
    for this?
    It's almost shurely the broken red-hat gcc (guess you have version 2.96?). Try a
    newer release (but they may buggy also, beware).

    g.
    -d

    Haven't got RedHat 7.2 available, but your example
    works perfectly on
    SuSE 7.3, Solaris 5.7 and WinXP.
    So I guess you didn't compile R (or e1071) on your
    system.
    Maybe there is a small incompatibility with the
    precompiled version.
    I'd suggest to compile R yourself and install e1071
    from the sources.

    Uwe Ligges
    I installed everyting (the R basic, R-recommended
    package and e1071 ) from source. My test example
    worked fine with redhat 6.2, but not redhat 7.2. I
    think maybe it is problem in gcc library or something
    in e1071 package.
    Any suggestion
    Thanks

    __________________________________________________

    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
  • Martyn Plummer at Mar 12, 2002 at 10:44 am
    I can replicate this bug on Red Hat 7.2. It seems to be a compiler
    problem. Here is the relevant output from gdb

    (gdb) frame 2
    #2 0x403a2ab6 in SVC_Q::get_Q (this=0xbfffdae0, iA, len0) at svm.cpp:1131
    1131 if((start = cache->get_data(i,&data,len)) < len)
    (gdb) p cache
    $10 = (Cache *) 0x8b083a8
    (gdb) p i
    $11 = 41
    (gdb) p &data
    $12 = (Qfloat **) 0xbfffd984
    (gdb) p len
    $13 = 100
    (gdb) frame 1
    #1 0x4039d90e in Cache::get_data (this=0x8b083a8, index6466881,
    data=0xbfffd984, len0) at svm.cpp:109
    109 if(h->len) lru_delete(h);

    The index argument to Cache::get_data is corrupted (should be 41
    not 14646881).

    I see that Red Hat have released a package for gcc3. You can
    download this from

    ftp://updates.redhat.com/7.2/en/os/i386/

    or a mirror near you. I recommend that you try this.

    Martyn
    On 11-Mar-2002 jason zhao wrote:
    Hi, Guys
    I run one simple R script like this

    library(e1071)
    data(iris)
    attach(iris)
    model <- svm (Species~., data=iris)

    The R version is 1.4.1. The OS is standard redhat 7.2.
    Then I got a segmentation fault like this (run through
    R CMD BATCH scriptName)
    /usr/local/R/lib/R/bin/BATCH: line 54: 28513 Done
    (
    echo "invisible(options(echo = TRUE))"; cat ${in};
    echo "proc.time()" )
    28514 Segmentation fault | ${R_HOME}/bin/R
    ${opts} >${out} 2>&1

    There is no problem if the R-binary is running redhat
    6.2.

    Does anyone see this problem? Is there a workaround
    for this?

    Help is appreciated.

    Jason
    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
  • Jason zhao at Mar 13, 2002 at 2:36 pm
    I installed gcc3. Both gcc(2.96) and 3.0.4 are in my
    system right now. How can you configure R compiler
    with gcc3 instead of gcc(2.96)?
    Thanks

    jason

    --- Prof Brian D Ripley wrote:
    It works for me under RH7.2, using gcc 3.0.4.

    Did you use a released version of gcc? (Hint `2.96'
    is a figment of
    RedHat's imagination.) Linux distros love putting
    out snapshot software
    (often ancient snapshots).

    On Mon, 11 Mar 2002, jason zhao wrote:


    --- Uwe Ligges <ligges@statistik.uni-dortmund.de>
    wrote:
    jason zhao wrote:
    Hi, Guys
    I run one simple R script like this

    library(e1071)
    data(iris)
    attach(iris)
    model <- svm (Species~., data=iris)

    The R version is 1.4.1. The OS is standard
    redhat
    7.2.
    Then I got a segmentation fault like this (run through
    R CMD BATCH scriptName)
    /usr/local/R/lib/R/bin/BATCH: line 54: 28513
    Done
    (
    echo "invisible(options(echo = TRUE))"; cat
    ${in};
    echo "proc.time()" )
    28514 Segmentation fault |
    ${R_HOME}/bin/R
    ${opts} >${out} 2>&1

    There is no problem if the R-binary is running redhat
    6.2.

    Does anyone see this problem? Is there a
    workaround
    for this?
    Haven't got RedHat 7.2 available, but your
    example
    works perfectly on
    SuSE 7.3, Solaris 5.7 and WinXP.
    So I guess you didn't compile R (or e1071) on
    your
    system.
    Maybe there is a small incompatibility with the
    precompiled version.
    I'd suggest to compile R yourself and install
    e1071
    from the sources.

    Uwe Ligges
    I installed everyting (the R basic, R-recommended
    package and e1071 ) from source. My test example
    worked fine with redhat 6.2, but not redhat 7.2. I
    think maybe it is problem in gcc library or something
    in e1071 package.
    Any suggestion
    Thanks





    __________________________________________________


    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read
    http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To:
    r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
    --
    Brian D. Ripley,
    ripley at stats.ox.ac.uk
    Professor of Applied Statistics,
    http://www.stats.ox.ac.uk/~ripley/
    University of Oxford, Tel: +44 1865
    272861 (self)
    1 South Parks Road, +44 1865
    272860 (secr)
    Oxford OX1 3TG, UK Fax: +44 1865
    272595

    __________________________________________________



    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._
  • Ripley at Mar 13, 2002 at 3:02 pm

    On Wed, 13 Mar 2002, jason zhao wrote:

    I installed gcc3. Both gcc(2.96) and 3.0.4 are in my
    system right now. How can you configure R compiler
    with gcc3 instead of gcc(2.96)?
    This is all in the R-admin manual.

    Just put gcc3 first in your path, if it is called gcc, or set CC=gcc3
    (and FC and CXX, I guess) in config.site.

    --
    Brian D. Ripley, ripley at stats.ox.ac.uk
    Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
    University of Oxford, Tel: +44 1865 272861 (self)
    1 South Parks Road, +44 1865 272860 (secr)
    Oxford OX1 3TG, UK Fax: +44 1865 272595

    -.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
    r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
    Send "info", "help", or "[un]subscribe"
    (in the "body", not the subject !) To: r-help-request at stat.math.ethz.ch
    _._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupr-help @
categoriesr
postedMar 11, '02 at 7:55p
activeMar 13, '02 at 3:02p
posts7
users5
websiter-project.org
irc#r

People

Translate

site design / logo © 2017 Grokbase