FAQ

[PostgreSQL-ES] Ayuda en cuanto a postgres

Kervin licett
Dec 22, 2008 at 11:07 pm
Que Tipo de codificacion en postgres me permite almacenar los acentos de las
palabras como por ejemplo Canciòn.......
reply

Search Discussions

17 responses

  • Jaime Casanova at Dec 23, 2008 at 2:19 am

    On Mon, Dec 22, 2008 at 6:07 PM, kervin licett wrote:
    Que Tipo de codificacion en postgres me permite almacenar los acentos de las
    palabras como por ejemplo Canciòn.......
    Latin1 o UTF8

    --
    Atentamente,
    Jaime Casanova
    Soporte y capacitación de PostgreSQL
    Asesoría y desarrollo de sistemas
    Guayaquil - Ecuador
    Cel. +59387171157
  • Alvaro Herrera at Dec 23, 2008 at 11:34 am

    kervin licett escribió:
    Que Tipo de codificacion en postgres me permite almacenar los acentos de las
    palabras como por ejemplo Canciòn.......
    Ya respondieron tu pregunta, pero si hubieras puesto "codificación" en
    el asunto habría sido mejor. Acá todos los mensajes son respecto a
    Postgres, así que lo que pusiste no ayuda en nada para saber de qué se
    trata tu mensaje.

    --
    Alvaro Herrera http://www.amazon.com/gp/registry/5ZYLFMCVHXC
    "Prefiero omelette con amigos que caviar con tontos"
    (Alain Nonnet)
  • Edwin Quijada at Dec 23, 2008 at 4:35 pm
    Latin,Latin9, Utf-8



    *-------------------------------------------------------*
    *-Edwin Quijada
    *-Developer DataBase
    *-JQ Microsistemas
    *-809-849-8087

    * " Si deseas lograr cosas excepcionales debes de hacer cosas fuera de lo comun"
    *-------------------------------------------------------*






    ________________________________
    Date: Mon, 22 Dec 2008 18:07:36 -0500
    From: kerljose@gmail.com
    To: pgsql-es-ayuda@postgresql.org
    Subject: [pgsql-es-ayuda] Ayuda en cuanto a postgres

    Que Tipo de codificacion en postgres me permite almacenar los acentos de las palabras como por ejemplo Canciòn.......
    _________________________________________________________________
    Color coding for safety: Windows Live Hotmail alerts you to suspicious email.
    http://windowslive.com/Explore/Hotmail?ocid=TXT_TAGLM_WL_hotmail_acq_safety_112008
  • Maseguri5 at Dec 24, 2008 at 12:31 pm
    Instale el postgresql 8.3 en windowsxp SP3.
    Tengo el inconveniente de que cuando inicia el servicio como que queda colgado el pg_ctl.exe y el servicio queda en el panel de "servicios de windows" como no inicializado, pero el postgresql funciona correctamente.
    Busque bastante pero no encontre ninguna solucion; tambien lo probe en otras pc y en algunas me paso lo mismo.
    Alguien sabe que puede ser ?

    Saludos
  • Jenaro Centeno Gómez at Dec 24, 2008 at 4:39 pm
    Hace poco he tenido un error parecido en la misma plataforma, revisa el
    log para ver que te dice, otra cosa, revisa tus adaptadores de red, los
    protocolos y el firewall, en el firewall el puerto 5432 debe estar libre
    para aceptar conexiones.

    Saludos.

    El mié, 24-12-2008 a las 10:26 +0100, Maseguri5 escribió:
    Instale el postgresql 8.3 en windowsxp SP3.
    Tengo el inconveniente de que cuando inicia el servicio como que queda
    colgado el pg_ctl.exe y el servicio queda en el panel de "servicios de
    windows" como no inicializado, pero el postgresql funciona
    correctamente.
    Busque bastante pero no encontre ninguna solucion; tambien lo probe en
    otras pc y en algunas me paso lo mismo.
    Alguien sabe que puede ser ?

    Saludos
  • Juan Ramirez at Dec 24, 2008 at 4:42 pm

    From: maseguri5@yahoo.com.ar
    Instale el postgresql 8.3 en windowsxp SP3.
    Tengo el inconveniente de que cuando inicia el servicio como que queda colgado el pg_ctl.exe y el servicio queda en el panel de
    "servicios de windows" como no inicializado, pero el postgresql
    funciona correctamente.
    Busque bastante pero no encontre ninguna solucion; tambien lo probe en otras pc y en algunas me paso lo mismo.
    Alguien sabe que puede ser ?

    Revisa el Visor de sucesos talvéz encontres más datos, porque así como lo has planteado dar una respuesta es muy difícil...

    Otro sería revisar que los privilegios del usuario PostGres no sean de Administrador porque eso no es correcto incluso, de esa manera puede ser que no te inicie el servicio.

    Juan Ramírez.

    _________________________________________________________________
    News, entertainment and everything you care about at Live.com. Get it now!
    http://www.live.com/getstarted.aspx
  • Maseguri5 at Dec 24, 2008 at 5:53 pm
    Cuando inicio el servicio de postgresql, espera y me da el siguiente error
    "El servicio Postgresql database server 8.3 se inicio en equipo local y
    despues se detuvo. Algunos servicios se detienen automaticamente..."
    Pero como les decia el postgresql queda corriendo, puedo entrar desde el
    pgadmin sin problemas.

    El viso de sucesos de window me dice esto:
    "Se agotó el tiempo de espera al inicio del servidor"

    El log de postgresql me da un error muchas veces que es este
    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    El usuario postgre777 es el que me creo el instalador automaticamnete.

    Parace como que se empieza a correr el servicio pero no logra completar
    alguna cosas sobre el final.


    ----- Original Message -----
    From: "Juan Ramirez" <juanrmiranda@hotmail.com>
    To: <maseguri5@yahoo.com.ar>
    Cc: "PostGreSQL Lista de Ayuda" <pgsql-es-ayuda@postgresql.org>
    Sent: Wednesday, December 24, 2008 5:42 PM
    Subject: RE: [pgsql-es-ayuda] Error en servicio



    From: maseguri5@yahoo.com.ar
    Instale el postgresql 8.3 en windowsxp SP3.
    Tengo el inconveniente de que cuando inicia el servicio como que queda
    colgado el pg_ctl.exe y el servicio queda en el panel de
    "servicios de windows" como no inicializado, pero el postgresql
    funciona correctamente.
    Busque bastante pero no encontre ninguna solucion; tambien lo probe en
    otras pc y en algunas me paso lo mismo.
    Alguien sabe que puede ser ?

    Revisa el Visor de sucesos talvéz encontres más datos, porque así como lo
    has planteado dar una respuesta es muy difícil...

    Otro sería revisar que los privilegios del usuario PostGres no sean de
    Administrador porque eso no es correcto incluso, de esa manera puede ser que
    no te inicie el servicio.

    Juan Ramírez.

    _________________________________________________________________
    News, entertainment and everything you care about at Live.com. Get it now!
    http://www.live.com/getstarted.aspx--
    TIP 10: no uses HTML en tu pregunta, seguro que quien responda no podrá
    leerlo

    __________________________________________________
    Correo Yahoo!
    Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
    ¡Abrí tu cuenta ya! - http://correo.yahoo.com.ar
  • Juan Ramirez at Dec 24, 2008 at 6:07 pm

    From: maseguri5@yahoo.com.ar

    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    que has echo pa solucionarlo? digo porque el msj esta claro -al menos para mi-


    pregunta ¿el usuario postgre777 tiene la misma contraseña que el super usuario de la base de datos?


    al parecer lo que falla es la contraseña para el usuario postgre777, usuario de la maquina no en la base de datos...



    vuelvo y repito, revisa que el usuario postgre777 no tenga privilegios de Administrador, en la pc, porque eso a mi me dió el mismo problema que a tí, y con quitarle los privilegios de administrador al usuario trabajo normalmente....

    _________________________________________________________________
    News, entertainment and everything you care about at Live.com. Get it now!
    http://www.live.com/getstarted.aspx
  • Mariano Reingart at Dec 24, 2008 at 6:39 pm

    Juan Ramirez wrote:
    From: maseguri5@yahoo.com.ar

    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    que has echo pa solucionarlo? digo porque el msj esta claro -al menos
    para mi-


    pregunta ¿el usuario postgre777 tiene la misma contraseña que el
    super usuario de la base de datos?


    al parecer lo que falla es la contraseña para el usuario postgre777,
    usuario de la maquina no en la base de datos...



    vuelvo y repito, revisa que el usuario postgre777 no tenga
    privilegios de Administrador, en la pc, porque eso a mi me dió el
    mismo problema que a tí, y con quitarle los privilegios de
    administrador al usuario trabajo normalmente....
    Otra cosa que podes hacer es desinstalar postgres, borrar el usuario de
    windows y volver a instalarlo (sin inicializar la base de datos)
    Para borrar el usuario (por linea de comando):
    net user postgre777 /delete

    Despues, si sigue sin andar, fijate los permisos de la carpeta C:\archivos
    de programa\postgresql\8.3\data (propiedades, seguridad, que el usuario
    postgre777 tenga habilitado control total, y en avanzado, que los permisos
    se hereden a los objetos hijos)
    Si no vez el tema de seguridad en el menu del explorador de la carpeta, ir a
    herramientas, opciones, deshabilitar seguridad simple o algo asi, reseteas y
    te tiene que aparecer la solapa de seguridad.

    Sds
    Mariano
  • Maseguri5 at Dec 24, 2008 at 7:44 pm
    Desintale y volvi a instalar todo, funciona todo ok hasta que al final
    levanta el servio y queda ahi el instalador como colgado.
    Ya no se que probar!



    ----- Original Message -----
    From: "Mariano Reingart" <mariano@nsis.com.ar>
    To: "Juan Ramirez" <juanrmiranda@hotmail.com>; <maseguri5@yahoo.com.ar>
    Cc: "PostGreSQL Lista de Ayuda" <pgsql-es-ayuda@postgresql.org>
    Sent: Wednesday, December 24, 2008 7:39 PM
    Subject: Re: [pgsql-es-ayuda] Error en serviciojavascript:;

    Juan Ramirez wrote:
    From: maseguri5@yahoo.com.ar

    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    que has echo pa solucionarlo? digo porque el msj esta claro -al menos
    para mi-


    pregunta ¿el usuario postgre777 tiene la misma contraseña que el
    super usuario de la base de datos?


    al parecer lo que falla es la contraseña para el usuario postgre777,
    usuario de la maquina no en la base de datos...



    vuelvo y repito, revisa que el usuario postgre777 no tenga
    privilegios de Administrador, en la pc, porque eso a mi me dió el
    mismo problema que a tí, y con quitarle los privilegios de
    administrador al usuario trabajo normalmente....
    Otra cosa que podes hacer es desinstalar postgres, borrar el usuario de
    windows y volver a instalarlo (sin inicializar la base de datos)
    Para borrar el usuario (por linea de comando):
    net user postgre777 /delete

    Despues, si sigue sin andar, fijate los permisos de la carpeta C:\archivos
    de programa\postgresql\8.3\data (propiedades, seguridad, que el usuario
    postgre777 tenga habilitado control total, y en avanzado, que los permisos
    se hereden a los objetos hijos)
    Si no vez el tema de seguridad en el menu del explorador de la carpeta, ir
    a herramientas, opciones, deshabilitar seguridad simple o algo asi,
    reseteas y te tiene que aparecer la solapa de seguridad.

    Sds
    Mariano
    --
    TIP 6: ¿Has buscado en los archivos de nuestra lista de correo?
    http://archives.postgresql.org/pgsql-es-ayuda
    __________________________________________________
    Correo Yahoo!
    Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
    ¡Abrí tu cuenta ya! - http://correo.yahoo.com.ar
  • Mariano Reingart at Dec 24, 2008 at 7:53 pm
    Si instalas postgres sin iniciar el servicio tambien se cuelga?
    Podes probar con pg_ctl.exe para ver que error sale, si levanta podes hace
    un backup y borrar todo
    Sds
    Mariano

    ----- Mensaje original -----
    De: "Maseguri5" <maseguri5@yahoo.com.ar>
    Para: "PostGreSQL Lista de Ayuda" <pgsql-es-ayuda@postgresql.org>
    Enviado: Miércoles, 24 de Diciembre de 2008 14:44
    Asunto: Re: [pgsql-es-ayuda] Error en serviciojavascript:;

    Desintale y volvi a instalar todo, funciona todo ok hasta que al final
    levanta el servio y queda ahi el instalador como colgado.
    Ya no se que probar!



    ----- Original Message -----
    From: "Mariano Reingart" <mariano@nsis.com.ar>
    To: "Juan Ramirez" <juanrmiranda@hotmail.com>; <maseguri5@yahoo.com.ar>
    Cc: "PostGreSQL Lista de Ayuda" <pgsql-es-ayuda@postgresql.org>
    Sent: Wednesday, December 24, 2008 7:39 PM
    Subject: Re: [pgsql-es-ayuda] Error en serviciojavascript:;

    Juan Ramirez wrote:
    From: maseguri5@yahoo.com.ar

    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    que has echo pa solucionarlo? digo porque el msj esta claro -al menos
    para mi-


    pregunta ¿el usuario postgre777 tiene la misma contraseña que el
    super usuario de la base de datos?


    al parecer lo que falla es la contraseña para el usuario postgre777,
    usuario de la maquina no en la base de datos...



    vuelvo y repito, revisa que el usuario postgre777 no tenga
    privilegios de Administrador, en la pc, porque eso a mi me dió el
    mismo problema que a tí, y con quitarle los privilegios de
    administrador al usuario trabajo normalmente....
    Otra cosa que podes hacer es desinstalar postgres, borrar el usuario de
    windows y volver a instalarlo (sin inicializar la base de datos)
    Para borrar el usuario (por linea de comando):
    net user postgre777 /delete

    Despues, si sigue sin andar, fijate los permisos de la carpeta
    C:\archivos de programa\postgresql\8.3\data (propiedades, seguridad, que
    el usuario postgre777 tenga habilitado control total, y en avanzado, que
    los permisos se hereden a los objetos hijos)
    Si no vez el tema de seguridad en el menu del explorador de la carpeta,
    ir a herramientas, opciones, deshabilitar seguridad simple o algo asi,
    reseteas y te tiene que aparecer la solapa de seguridad.

    Sds
    Mariano
    --
    TIP 6: ¿Has buscado en los archivos de nuestra lista de correo?
    http://archives.postgresql.org/pgsql-es-ayuda
    __________________________________________________
    Correo Yahoo!
    Espacio para todos tus mensajes, antivirus y antispam ¡gratis! ¡Abrí tu
    cuenta ya! - http://correo.yahoo.com.ar

    --
    TIP 5: ¿Has leído nuestro extenso FAQ?
    http://www.postgresql.org/docs/faqs.FAQ.html
  • Maseguri5 at Dec 24, 2008 at 6:48 pm
    El usuario postgres777 lo creo el instalador de posgresql, no tiene permisos
    de administrador.
    El usuario postgres777 no tiene el mismo password que el superusuario de la
    base. Ni es el mismo nombre.

    Osea la cuestion es que cuando inicio el servicio da un error al final, pero
    el postgresql se inicia; pero no se por que no termina de iniciarse
    completamente. esa es la cuestion!

    From: maseguri5@yahoo.com.ar

    "CET FATAL: la autentificación password falló para el usuario
    «postgres777»"
    que has echo pa solucionarlo? digo porque el msj esta claro -al menos para
    mi-


    pregunta ¿el usuario postgre777 tiene la misma contraseña que el super
    usuario de la base de datos?


    al parecer lo que falla es la contraseña para el usuario postgre777, usuario
    de la maquina no en la base de datos...



    vuelvo y repito, revisa que el usuario postgre777 no tenga privilegios de
    Administrador, en la pc, porque eso a mi me dió el mismo problema que a tí,
    y con quitarle los privilegios de administrador al usuario trabajo
    normalmente....

    _________________________________________________________________
    News, entertainment and everything you care about at Live.com. Get it now!
    http://www.live.com/getstarted.aspx=

    __________________________________________________
    Correo Yahoo!
    Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
    ¡Abrí tu cuenta ya! - http://correo.yahoo.com.ar
  • Hugo César at Jan 2, 2009 at 4:12 pm
    El día 24 de diciembre de 2008 9:48, Maseguri5
    <maseguri5@yahoo.com.ar> escribió:
    El usuario postgres777 lo creo el instalador de posgresql, no tiene permisos
    de administrador.
    El usuario postgres777 no tiene el mismo password que el superusuario de la
    base. Ni es el mismo nombre.

    Osea la cuestion es que cuando inicio el servicio da un error al final, pero
    el postgresql se inicia; pero no se por que no termina de iniciarse
    completamente. esa es la cuestion!
    Maseguri5:

    Dirijete al apartado de USUARIOS LOCALES Y GRUPOS, localiza el
    usuario POSTGRES777, cambiale el password y asegurate que no pertenezca
    al grupo ADMINISTRADORES, posteriormente dirijete a los servicios de windows,
    localiza el servicio correspondiente a postgre y en la pestaña que dice INICIAR
    SESION, localiza de nueva cuenta al usuario POSTGRES777 y coloca la
    nueva contraseña, guarda los cambios, inicia el servicio y comenta a
    la lista los
    resultados que obtuviste ok?

    Finalmente, no entiendo como inicia correctamente el PGADMIN, se supone que el
    servicio no arranco por lo tanto el servidor de base de datos tampoco
    cierto ?? Entonces
    si nada de esto funciono como es que entraste correctamente con el PGADMIN ???
    Esto me causa algo de confusion....


    Saludos.-
  • Daniel Egea at Jan 2, 2009 at 5:10 pm

    Hugo César escribió:
    El día 24 de diciembre de 2008 9:48, Maseguri5
    <maseguri5@yahoo.com.ar> escribió:
    El usuario postgres777 lo creo el instalador de posgresql, no tiene permisos
    de administrador.
    El usuario postgres777 no tiene el mismo password que el superusuario de la
    base. Ni es el mismo nombre.

    Osea la cuestion es que cuando inicio el servicio da un error al final, pero
    el postgresql se inicia; pero no se por que no termina de iniciarse
    completamente. esa es la cuestion!

    Maseguri5:

    Dirijete al apartado de USUARIOS LOCALES Y GRUPOS, localiza el
    usuario POSTGRES777, cambiale el password y asegurate que no pertenezca
    al grupo ADMINISTRADORES, posteriormente dirijete a los servicios de windows,
    localiza el servicio correspondiente a postgre y en la pestaña que dice INICIAR
    SESION, localiza de nueva cuenta al usuario POSTGRES777 y coloca la
    nueva contraseña, guarda los cambios, inicia el servicio y comenta a
    la lista los
    resultados que obtuviste ok?

    Finalmente, no entiendo como inicia correctamente el PGADMIN, se supone que el
    servicio no arranco por lo tanto el servidor de base de datos tampoco
    cierto ?? Entonces
    si nada de esto funciono como es que entraste correctamente con el PGADMIN ???
    Esto me causa algo de confusion....


    Saludos.-
    --
    TIP 5: ¿Has leído nuestro extenso FAQ?
    http://www.postgresql.org/docs/faqs.FAQ.html
    Una cosa tonta...

    Por lo que he leído parece como si el servidor estuviese iniciado con
    anterioridad... entonces se intenta arrancar el servicio y no puede pq
    el puerto está ocupado. Sin embargo el PGAdmin puede acceder a la base
    de datos.....

    Asegúrate de parar el servicio e intenta acceder con PGAdmin... mira los
    procesos que están corriendo en tu máquina, no sea que se inicie el
    servidor aparte del servicio

    Saludos
  • Alvaro Herrera at Jan 2, 2009 at 5:15 pm

    Daniel Egea escribió:

    Por lo que he leído parece como si el servidor estuviese iniciado con
    anterioridad... entonces se intenta arrancar el servicio y no puede pq
    el puerto está ocupado.
    Yo no creo que sea ese el problema. Más bien me parece que pg_ctl
    intenta iniciar el servicio, y lo inicia, pero después intenta verificar
    si el servicio está arriba, y no puede, y como no puede verificar, dice
    que falló sin saber realmente lo que pasó.

    Esta hipótesis explica por qué funciona al quitar el -w (lo que hace es
    saltarse la verificación)

    --
    Alvaro Herrera http://www.PlanetPostgreSQL.org/
    "It takes less than 2 seconds to get to 78% complete; that's a good sign.
    A few seconds later it's at 90%, but it seems to have stuck there. Did
    somebody make percentages logarithmic while I wasn't looking?"
    http://smylers.hates-software.com/2005/09/08/1995c749.html
  • Maseguri5 at Jan 2, 2009 at 4:45 pm
    Ya hice eso de crear otro usuario y sigue igual.
    La cuestion es que cuando inicio el servicio se carga el motor de
    postgresql, osea si voy al administrador de tareas veo los procesos
    correindo.
    El problema es que el servicio no termina correctamente. El archivo
    pg_ctl.exe como que nuna termina y da error el servicio; pero postgresql
    queda corriendo.

    Si desintalo todo y vuelvo a instalar, instala todo ok hasta que llega el
    momento de levantar el servicio y se queda esperando intentando arrancar el
    servicio. Y sucede lo mismo porque si voy al administrador de tareas esta el
    postgres corriendo. Osea no termina de ejecutar el servicio al parecer el
    archivo pg_ctl.exe.
    Por eso le saque al servicio el parametro -w y funciono ahi.




    ----- Original Message -----
    From: "Hugo César" <hugocesar49@gmail.com>
    To: "Maseguri5" <maseguri5@yahoo.com.ar>
    Sent: Friday, January 02, 2009 5:11 PM
    Subject: Re: [pgsql-es-ayuda] Error en servicio


    El día 24 de diciembre de 2008 9:48, Maseguri5
    <maseguri5@yahoo.com.ar> escribió:
    El usuario postgres777 lo creo el instalador de posgresql, no tiene
    permisos
    de administrador.
    El usuario postgres777 no tiene el mismo password que el superusuario de
    la
    base. Ni es el mismo nombre.

    Osea la cuestion es que cuando inicio el servicio da un error al final,
    pero
    el postgresql se inicia; pero no se por que no termina de iniciarse
    completamente. esa es la cuestion!
    Maseguri5:

    Dirijete al apartado de USUARIOS LOCALES Y GRUPOS, localiza el
    usuario POSTGRES777, cambiale
    el password y asegurate que no pertenezca al grupo ADMINISTRADORES,
    posteriormente dirijete a los
    servicios de windows, localiza el servicio correspondiente a postgre y
    en la pestaña que dice INICIAR
    SESION, localiza de nueva cuenta al usuario POSTGRES777 y coloca la
    nueva contraseña, guarda
    los cambios, inicia el servicio y comenta a la lista los resultados
    que obtuviste ok?

    Finalmente, no entiendo como inicia correctamente el PGADMIN, se
    supone que el servicio no arranco
    por lo tanto el servidor de base de datos tampoco cierto ?? Entonces
    si nada de esto funciono como es que
    entraste correctamente con el PGADMIN ??? Esto me causa algo de
    confusion....


    Saludos.-

    __________________________________________________
    Correo Yahoo!
    Espacio para todos tus mensajes, antivirus y antispam ¡gratis!
    ¡Abrí tu cuenta ya! - http://correo.yahoo.com.ar
  • Alvaro Herrera at Jan 2, 2009 at 4:54 pm

    Maseguri5 escribió:

    Si desintalo todo y vuelvo a instalar, instala todo ok hasta que llega el
    momento de levantar el servicio y se queda esperando intentando arrancar
    el servicio. Y sucede lo mismo porque si voy al administrador de tareas
    esta el postgres corriendo. Osea no termina de ejecutar el servicio al
    parecer el archivo pg_ctl.exe.
    Por eso le saque al servicio el parametro -w y funciono ahi.
    El manejo de la opción -w de pg_ctl no es muy robusto: no tiene cómo
    obtener la información de si postgres se inició correctamente cuando no
    tiene los datos de autentificación (se ha conversado varias veces
    reescribirlo para que no sea tan frágil, pero no se ha materializado
    aún).

    Esto no es un problema que sólo ocurra en Windows.

    --
    Alvaro Herrera http://www.PlanetPostgreSQL.org/
    "You knock on that door or the sun will be shining on places inside you
    that the sun doesn't usually shine" (en Death: "The High Cost of Living")

Related Discussions