FAQ

[PostgreSQL-ES] Conectar PHP con PostgreSQL

Javier Estévez CIFA Córdoba
Jun 2, 2006 at 12:29 pm
He instalado PHP y al intentar conectar con mi BD en PostgreSQL me da el siguiente error:

unable function "pg_connect"

Es decir, que no tengo esa función, el explorador no la reconoce. Alguien sabe si hay que instalar algunas librerías extras para conectar PHP con PosgreSQL.

Thanks.

PD: A sabiendas que esta consulta podría o debería hacerla en una lista de PHP. Sorry.
reply

Search Discussions

3 responses

  • David Prieto at Jun 2, 2006 at 12:44 pm
    Al instalar PHP no has instalado o no has habilitado las extensiones de
    Postgresql.

    Si lo has instalado como RPM, habrá algún paquete php-pgsql que no has
    instalado.

    Revisa también en /etc/php.d/ si está bien configurado el correspondiente
    archivo de configuración relativo a postgresql (será pgsql.ini o algo así,
    si es que está ahí). Por último, si efectivamente /etc/php.d tienes un
    archivo que habilita el soporte de postgresql, comprueba que NO lo tengas
    TAMBIEN habilitado en el /etc/php.ini (si lo tienes en los dos sitios, no
    funciona).

    Un saludo,
    David Prieto

    -----Mensaje original-----
    De: pgsql-es-ayuda-owner@postgresql.org
    En nombre de Javier Estévez
    CIFA Córdoba
    Enviado el: viernes, 02 de junio de 2006 14:28
    Para: pgsql-es-ayuda@postgresql.org
    Asunto: [pgsql-es-ayuda] Conectar PHP con PostgreSQL


    He instalado PHP y al intentar conectar con mi BD en PostgreSQL me da el
    siguiente error:

    unable function "pg_connect"

    Es decir, que no tengo esa función, el explorador no la reconoce.
    Alguien sabe si hay que instalar algunas librerías extras para conectar PHP
    con PosgreSQL.

    Thanks.

    PD: A sabiendas que esta consulta podría o debería hacerla en una lista de
    PHP. Sorry.
  • Leonel Nunez at Jun 2, 2006 at 2:20 pm

    Javier Estévez CIFA Córdoba wrote:
    He instalado PHP y al intentar conectar con mi BD en PostgreSQL me
    da el siguiente error:

    unable function "pg_connect"

    Es decir, que no tengo esa función, el explorador no la reconoce.
    Alguien sabe si hay que instalar algunas librerías extras para
    conectar PHP con PosgreSQL.
    como instalaste el php y postgresql ???
    si fue de los paquete de tu distro busca el php-pgsql o algo
    asi depende de tu distro como lo llame
    Thanks.

    PD: A sabiendas que esta consulta podría o debería hacerla en una
    lista de PHP. Sorry.

    me imagino que puedes pero no mandes con copia a varias listas esto
    es mandar este mensaje con cc listadephp , otralista



    leonel
  • Brian Colman at Jun 5, 2006 at 1:18 pm
    Aca hay un hilo que habla de esto.

    http://archives.postgresql.org/pgsql-es-ayuda/2006-05/msg00339.php

    Saludos

    Brian

    El día 2/06/06, Javier Estévez CIFA Córdoba <
    javier.estevez.ext@juntadeandalucia.es> escribió:
    He instalado PHP y al intentar conectar con mi BD en PostgreSQL me da
    el siguiente error:

    unable function "pg_connect"

    Es decir, que no tengo esa función, el explorador no la reconoce.
    Alguien sabe si hay que instalar algunas librerías extras para conectar PHP
    con PosgreSQL.

    Thanks.

    PD: A sabiendas que esta consulta podría o debería hacerla en una lista de
    PHP. Sorry.


    --
    Saludos

    Brian Colmán Miers

Related Discussions