FAQ
nlopess Tue Feb 15 13:29:05 2005 EDT

Modified files:
/phpdoc/en/reference/sqlite reference.xml
Log:
fix #30955: TMP windows envar. based on patch by danielc at analysisandsolutions dot com

http://cvs.php.net/diff.php/phpdoc/en/reference/sqlite/reference.xml?r1=1.14&r2=1.15&ty=u
Index: phpdoc/en/reference/sqlite/reference.xml
diff -u phpdoc/en/reference/sqlite/reference.xml:1.14 phpdoc/en/reference/sqlite/reference.xml:1.15
--- phpdoc/en/reference/sqlite/reference.xml:1.14 Sun Feb 13 23:13:16 2005
+++ phpdoc/en/reference/sqlite/reference.xml Tue Feb 15 13:29:02 2005
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="iso-8859-1"?>
-<!-- $Revision: 1.14 $ -->
+<!-- $Revision: 1.15 $ -->
<reference id="ref.sqlite">
<title>SQLite Functions</title>
<titleabbrev>SQLite</titleabbrev>
@@ -42,6 +42,43 @@
In PHP 5, the SQLite extension and the engine itself are bundled and
compiled by default.
</para>
+ <note>
+ <title>Windows installation for unprivilged accounts</title>
+ <para>
+ On Windows operating systems, unprivilged accounts doesn't have the
+ <varname>TMP</varname> environment variable set by default. This will
+ make sqlite create temporary files in the windows directory, which isn't
+ good. So, you should set the <varname>TMP</varname> environment variable
+ for the web server or the user account the web server is running under.
+ If Apache is your web server, you can accomplish this via a
+ <command>SetEnv</command> directive in your &httpd.conf; file. For
+ example:
+ <informalexample>
+ <programlisting role="apache-conf">
+<![CDATA[
+SetEnv TMP c:/temp
+]]>
+ </programlisting>
+ </informalexample>
+ If you are unable to establish this setting at the server
+ level, you can implement the setting in your script:
+ <informalexample>
+ <programlisting role="php">
+<![CDATA[
+putenv('TMP=C:/temp');
+]]>
+ </programlisting>
+ </informalexample>
+ The setting must refer to a directory that the web server
+ has permission to create files in and subsequently write
+ to and delete the files it created.
+ Otherwise, you may receive the following error message:
+ <computeroutput>
+ malformed database schema -
+ unable to open a temporary database file for storing temporary tables
+ </computeroutput>
+ </para>
+ </note>
</section>
<section id="sqlite.requirements">
&reftitle.required;

Search Discussions

  • M. Sokolewicz at Feb 16, 2005 at 4:14 pm
    I don't think this was meant, so I'll just point out the obvious (and
    leave it there, because I can't access CVS from here):
    + On Windows operating systems, unprivilged accounts doesn't have the
    + <varname>TMP</varname> environment variable set by default. This will
    + make sqlite create temporary files in the windows directory,
    which isn't
    + good. So, you should set the <varname>TMP</varname>
    environment variable
    + for the web server or the user account the web server is
    running under.

    3 things about that, first of all "unprivilged accounts" has a typo ;)
    secondly, that sentence isn't correct, I'd change "doesn't" to "don't"

    Then there's also the third and final comment on this from me; I think
    the wording of that piece of info sounds... well... wrong... it's mainly
    the "which isn't good" part that ticks me off...

    hope others agree,
    - tul

    Nuno Lopes wrote:
    nlopess Tue Feb 15 13:29:05 2005 EDT

    Modified files:
    /phpdoc/en/reference/sqlite reference.xml
    Log:
    fix #30955: TMP windows envar. based on patch by danielc at analysisandsolutions dot com

    http://cvs.php.net/diff.php/phpdoc/en/reference/sqlite/reference.xml?r1=1.14&r2=1.15&ty=u
    Index: phpdoc/en/reference/sqlite/reference.xml
    diff -u phpdoc/en/reference/sqlite/reference.xml:1.14 phpdoc/en/reference/sqlite/reference.xml:1.15
    --- phpdoc/en/reference/sqlite/reference.xml:1.14 Sun Feb 13 23:13:16 2005
    +++ phpdoc/en/reference/sqlite/reference.xml Tue Feb 15 13:29:02 2005
    @@ -1,5 +1,5 @@
    <?xml version="1.0" encoding="iso-8859-1"?>
    -<!-- $Revision: 1.14 $ -->
    +<!-- $Revision: 1.15 $ -->
    <reference id="ref.sqlite">
    <title>SQLite Functions</title>
    <titleabbrev>SQLite</titleabbrev>
    @@ -42,6 +42,43 @@
    In PHP 5, the SQLite extension and the engine itself are bundled and
    compiled by default.
    </para>
    + <note>
    + <title>Windows installation for unprivilged accounts</title>
    + <para>
    + On Windows operating systems, unprivilged accounts doesn't have the
    + <varname>TMP</varname> environment variable set by default. This will
    + make sqlite create temporary files in the windows directory, which isn't
    + good. So, you should set the <varname>TMP</varname> environment variable
    + for the web server or the user account the web server is running under.
    + If Apache is your web server, you can accomplish this via a
    + <command>SetEnv</command> directive in your &httpd.conf; file. For
    + example:
    + <informalexample>
    + <programlisting role="apache-conf">
    +<![CDATA[
    +SetEnv TMP c:/temp
    +]]>
    + </programlisting>
    + </informalexample>
    + If you are unable to establish this setting at the server
    + level, you can implement the setting in your script:
    + <informalexample>
    + <programlisting role="php">
    +<![CDATA[
    +putenv('TMP=C:/temp');
    +]]>
    + </programlisting>
    + </informalexample>
    + The setting must refer to a directory that the web server
    + has permission to create files in and subsequently write
    + to and delete the files it created.
    + Otherwise, you may receive the following error message:
    + <computeroutput>
    + malformed database schema -
    + unable to open a temporary database file for storing temporary tables
    + </computeroutput>
    + </para>
    + </note>
    </section>
    <section id="sqlite.requirements">
    &reftitle.required;
  • Nuno Lopes at Feb 16, 2005 at 8:02 pm

    I don't think this was meant, so I'll just point out the obvious (and
    leave it there, because I can't access CVS from here):
    + On Windows operating systems, unprivilged accounts doesn't have the
    + <varname>TMP</varname> environment variable set by default. This will
    + make sqlite create temporary files in the windows directory,
    which isn't
    + good. So, you should set the <varname>TMP</varname>
    environment variable
    + for the web server or the user account the web server is
    running under.

    3 things about that, first of all "unprivilged accounts" has a typo ;)
    secondly, that sentence isn't correct, I'd change "doesn't" to "don't"

    Then there's also the third and final comment on this from me; I think
    the wording of that piece of info sounds... well... wrong... it's mainly
    the "which isn't good" part that ticks me off...

    hope others agree,
    - tul
    Thanks for your review!

    So, how would you reword the third point? It seems fine to me...

    Nuno
  • Dan Scott at Feb 16, 2005 at 8:59 pm

    On Wed, 16 Feb 2005 19:55:23 -0000, Nuno Lopes wrote:
    I don't think this was meant, so I'll just point out the obvious (and
    leave it there, because I can't access CVS from here):
    + On Windows operating systems, unprivilged accounts doesn't have the
    + <varname>TMP</varname> environment variable set by default. This will
    + make sqlite create temporary files in the windows directory,
    which isn't
    + good. So, you should set the <varname>TMP</varname>
    environment variable
    + for the web server or the user account the web server is
    running under.

    3 things about that, first of all "unprivilged accounts" has a typo ;)
    secondly, that sentence isn't correct, I'd change "doesn't" to "don't"

    Then there's also the third and final comment on this from me; I think
    the wording of that piece of info sounds... well... wrong... it's mainly
    the "which isn't good" part that ticks me off...

    hope others agree,
    - tul
    Thanks for your review!

    So, how would you reword the third point? It seems fine to me...
    For a more formal version, how about "which is not desirable." ? Or
    "which is not desirable from a perspective that values an aesthetic
    separation of operating system libraries and application data." if you
    really want to explain _why_ it's not good to those who don't get it.
    Although I bet there are shorter versions than mine :)

    Dan
  • Nuno Lopes at Feb 16, 2005 at 8:04 pm
    nlopess Wed Feb 16 14:57:58 2005 EDT

    Modified files:
    /phpdoc/en/reference/sqlite reference.xml
    Log:
    fix typos found by tularis. Thanks :)

    http://cvs.php.net/diff.php/phpdoc/en/reference/sqlite/reference.xml?r1=1.15&r2=1.16&ty=u
    Index: phpdoc/en/reference/sqlite/reference.xml
    diff -u phpdoc/en/reference/sqlite/reference.xml:1.15 phpdoc/en/reference/sqlite/reference.xml:1.16
    --- phpdoc/en/reference/sqlite/reference.xml:1.15 Tue Feb 15 13:29:02 2005
    +++ phpdoc/en/reference/sqlite/reference.xml Wed Feb 16 14:57:56 2005
    @@ -1,5 +1,5 @@
    <?xml version="1.0" encoding="iso-8859-1"?>
    -<!-- $Revision: 1.15 $ -->
    +<!-- $Revision: 1.16 $ -->
    <reference id="ref.sqlite">
    <title>SQLite Functions</title>
    <titleabbrev>SQLite</titleabbrev>
    @@ -43,9 +43,9 @@
    compiled by default.
    </para>
    <note>
    - <title>Windows installation for unprivilged accounts</title>
    + <title>Windows installation for unprivileged accounts</title>
    <para>
    - On Windows operating systems, unprivilged accounts doesn't have the
    + On Windows operating systems, unprivileged accounts don't have the
    <varname>TMP</varname> environment variable set by default. This will
    make sqlite create temporary files in the windows directory, which isn't
    good. So, you should set the <varname>TMP</varname> environment variable
  • Nuno Lopes at Feb 18, 2005 at 11:31 am
    nlopess Fri Feb 18 06:31:32 2005 EDT

    Modified files:
    /phpdoc/en/reference/sqlite reference.xml
    Log:
    use Dan Scott's suggestion for a more formal wording

    http://cvs.php.net/diff.php/phpdoc/en/reference/sqlite/reference.xml?r1=1.16&r2=1.17&ty=u
    Index: phpdoc/en/reference/sqlite/reference.xml
    diff -u phpdoc/en/reference/sqlite/reference.xml:1.16 phpdoc/en/reference/sqlite/reference.xml:1.17
    --- phpdoc/en/reference/sqlite/reference.xml:1.16 Wed Feb 16 14:57:56 2005
    +++ phpdoc/en/reference/sqlite/reference.xml Fri Feb 18 06:31:30 2005
    @@ -1,5 +1,5 @@
    <?xml version="1.0" encoding="iso-8859-1"?>
    -<!-- $Revision: 1.16 $ -->
    +<!-- $Revision: 1.17 $ -->
    <reference id="ref.sqlite">
    <title>SQLite Functions</title>
    <titleabbrev>SQLite</titleabbrev>
    @@ -47,11 +47,11 @@
    <para>
    On Windows operating systems, unprivileged accounts don't have the
    <varname>TMP</varname> environment variable set by default. This will
    - make sqlite create temporary files in the windows directory, which isn't
    - good. So, you should set the <varname>TMP</varname> environment variable
    - for the web server or the user account the web server is running under.
    - If Apache is your web server, you can accomplish this via a
    - <command>SetEnv</command> directive in your &httpd.conf; file. For
    + make sqlite create temporary files in the windows directory, which is
    + not desirable. So, you should set the <varname>TMP</varname> environment
    + variable for the web server or the user account the web server is
    + running under. If Apache is your web server, you can accomplish this via
    + a <command>SetEnv</command> directive in your &httpd.conf; file. For
    example:
    <informalexample>
    <programlisting role="apache-conf">

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-doc @
categoriesphp
postedFeb 15, '05 at 6:29p
activeFeb 18, '05 at 11:31a
posts6
users3
websitedoc.php.net

People

Translate

site design / logo © 2018 Grokbase