FAQ
Hi,
I'm using Roundcube plugin composer which needs crypt_gpg. When running
the composer,
I get the following error message: "The requested package
pear-pear.php.net/crypt_gpg could not be found in any version, there may
be a typo in the package name."
eventough it is installed (version 1.4.0). I tried several old versions
with the same result.
Hope you can help me.
Lukas

Search Discussions

  • A.L.E.C at Mar 16, 2016 at 8:11 pm

    On 03/15/2016 11:08 PM, luggie wrote:
    Hi,
    I'm using Roundcube plugin composer which needs crypt_gpg. When running
    the composer,
    I get the following error message: "The requested package
    pear-pear.php.net/crypt_gpg could not be found in any version, there may
    be a typo in the package name."
    eventough it is installed (version 1.4.0). I tried several old versions
    with the same result.
    Problem is with the recent composer.

    It looks like it selects https://de.pear.php.net mirror, this host
    however uses expired ssl certificate.

    Can anyone remove this from mirrors list or update the server with new cert?

    Initializing PEAR repository https://pear.php.net
    PEAR repository from https://pear.php.net could not be loaded. The
    "https://de.pear.php.net/rest/c/categories.xml" file could not be
    downloaded: SSL operation failed with code 1. OpenSSL Error messages:
    error:14090086:SSL routines:ssl3_get_server_certificate:certificate
    verify failed
    Failed to enable crypto
    failed to open stream: operation failed


    --
    Aleksander 'A.L.E.C' Machniak
    Kolab Groupware Developer [http://kolab.org]
    Roundcube Webmail Developer [http://roundcube.net]
    ---------------------------------------------------
    PGP: 19359DC1 @@ GG: 2275252 @@ WWW: http://alec.pl
  • A.L.E.C at Mar 16, 2016 at 8:22 pm

    On 03/16/2016 09:11 PM, A.L.E.C wrote:
    It looks like it selects https://de.pear.php.net mirror, this host
    however uses expired ssl certificate.

    Can anyone remove this from mirrors list or update the server with new cert?
    Oh. As this is the only mirror which provides https, removing it from
    the list will not solve the issue. We need at least one with https.

    --
    Aleksander 'A.L.E.C' Machniak
    Kolab Groupware Developer [http://kolab.org]
    Roundcube Webmail Developer [http://roundcube.net]
    ---------------------------------------------------
    PGP: 19359DC1 @@ GG: 2275252 @@ WWW: http://alec.pl

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-webmaster @
categoriesphp
postedMar 15, '16 at 10:30p
activeMar 16, '16 at 8:22p
posts3
users2
websitepear.php.net

2 users in discussion

A.L.E.C: 2 posts Luggie: 1 post

People

Translate

site design / logo © 2017 Grokbase