FAQ

[wxPerl-users] wxWidgets 2.9.4

Mark Dootson
Dec 30, 2012 at 8:14 am
Hi,

It has been noted on a couple of other threads but I though it worth
posting again. There are problems with the plain wxWidgets 2.9.4 release
and wxPerl. The Plugin handling in wxWidgets 2.9.4 is broken. It is
fixed in wxWidgets trunk (2.9.5 to be). wxPerl uses the wxWidgets plugin
features.

The current Alien::wxWidgets 0.62 contains the back-ported patch to fix
2.9.4. Therefore if you build wxWidgets using Alien::wxWidgets all works OK.

However, if you build wxWidgets 2.9.4 yourself or use some other
pre-built binaries (MacPorts etc) then your wxPerl build will fail. If
you wish to build wxWidgets yourself, apply wxWidgets-2.9.4-plugin.patch
from the Alien::wxWidgets 0.62 source.

Regards

Mark
reply

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post

1 user in discussion

Mark Dootson: 1 post