FAQ

Re: Smoke [5.11.0] 34379 PASS linux 2.6.22.18-0.2-default [SuSE] (x86_64/4 cpu)

H.Merijn Brand
Sep 20, 2008 at 7:07 am

On Sat, 20 Sep 2008 00:09 +0200, "H.Merijn Brand" wrote:

Automated smoke report for 5.11.0 patch 34379
pc09: Intel(R) Xeon(R) CPU E5320 @ 1.86GHz (GenuineIntel 1596MHz) (x86_64/4 cpu)
on linux - 2.6.22.18-0.2-default [SuSE]
using ccache gcc version 4.2.1 (SUSE Linux)
smoketime 1 hour 48 minutes (average 13 minutes 34 seconds)

Summary: PASS
Note that this is a parallel smoke. Thanks Nicholas for making this
work!

The last none-parallel smoke on this box was:

Automated smoke report for 5.11.0 patch 32785
pc09: Intel(R) Xeon(R) CPU E5320 @ 1.86GHz (GenuineIntel 1596MHz) (x86_64/4 cpu)
on linux - 2.6.18.8-0.7-default [SuSE]
using ccache gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)
smoketime 3 hours 51 minutes (average 28 minutes 56 seconds)

To switch to parallel smokes, you will need a recent Test::Smoke

Report by Test::Smoke v1.35 build 1203 running on perl 5.8.8
(Reporter v0.033 / Smoker v0.041)

these lines in your smoke_config (up 3 to whatever you like)

"makeopt" => "-j3",
"harnessonly" => 1,
"hasharness3" => 1,
"harness3opts" => "j3",
"testmake" => "make",

and

export TEST_JOBS=3

before you start smoking

Happy speedup!
O = OK F = Failure(s), extended report at the bottom
X = Failure(s) under TEST but not under harness
? = still running or test results not (yet) available
Build failures during: - = unknown or N/A
c = Configure, m = make, M = make (after miniperl), t = make test-prep

34379 Configuration (common) none
----------- ---------------------------------------------------------
O O O O O O -Duselongdouble
O O O O O O -Duse64bitall
O O O O O O -Duseithreads -Duselongdouble
O O O O O O -Duseithreads -Duse64bitall
+- LC_ALL = en_US.utf8 -DDEBUGGING
+--- PERLIO = perlio -DDEBUGGING
+----- PERLIO = stdio -DDEBUGGING
+------- LC_ALL = en_US.utf8
+--------- PERLIO = perlio
+----------- PERLIO = stdio

Locally applied patches:
DEVEL
SMOKE34379

Testsuite was run only with 'harness' and HARNESS_OPTIONS=j3

MANIFEST did not declare 'merijn/Configure'
MANIFEST did not declare 'merijn/Glossary'
MANIFEST did not declare 'merijn/config.sh'
MANIFEST did not declare 'merijn/config_h.SH'

--
H.Merijn Brand Amsterdam Perl Mongers http://amsterdam.pm.org/
using & porting perl 5.6.2, 5.8.x, 5.10.x, 5.11.x on HP-UX 10.20, 11.00,
11.11, 11.23, and 11.31, SuSE 10.1, 10.2, and 10.3, AIX 5.2, and Cygwin.
http://mirrors.develooper.com/hpux/ http://www.test-smoke.org/
http://qa.perl.org http://www.goldmark.org/jeff/stupid-disclaimers/
reply

Search Discussions

2 responses

  • Steve Hay at Sep 22, 2008 at 8:09 am

    H.Merijn Brand wrote:
    To switch to parallel smokes, you will need a recent Test::Smoke

    Report by Test::Smoke v1.35 build 1203 running on perl 5.8.8
    (Reporter v0.033 / Smoker v0.041)

    these lines in your smoke_config (up 3 to whatever you like)

    "makeopt" => "-j3",
    "harnessonly" => 1,
    "hasharness3" => 1,
    "harness3opts" => "j3",
    "testmake" => "make",

    and

    export TEST_JOBS=3

    before you start smoking
    and (currently, at least) you'll also need to not be running on Win32
    :-(
  • H.Merijn Brand at Sep 22, 2008 at 8:41 am

    On Mon, 22 Sep 2008 09:09:11 +0100, "Steve Hay" wrote:

    H.Merijn Brand wrote:
    To switch to parallel smokes, you will need a recent Test::Smoke

    Report by Test::Smoke v1.35 build 1203 running on perl 5.8.8
    (Reporter v0.033 / Smoker v0.041)

    these lines in your smoke_config (up 3 to whatever you like)

    "makeopt" => "-j3",
    "harnessonly" => 1,
    "hasharness3" => 1,
    "harness3opts" => "j3",
    harness3opts can be skipped if you have TEST_JOBS=3
    "testmake" => "make",

    and

    export TEST_JOBS=3

    before you start smoking
    and (currently, at least) you'll also need to not be running on Win32
    :-(
    I cannot fix that.
    At home I just upgraded from Win2k to OpenSUSE 11.00, so one more
    smoking machine has entered the arena. Currently just smokes 5.10.x, as
    that was not yet well-covered, but I plan to add either blead or 5.8.x

    --
    H.Merijn Brand Amsterdam Perl Mongers http://amsterdam.pm.org/
    using & porting perl 5.6.2, 5.8.x, 5.10.x, 5.11.x on HP-UX 10.20, 11.00,
    11.11, 11.23, and 11.31, SuSE 10.1, 10.2, and 10.3, AIX 5.2, and Cygwin.
    http://mirrors.develooper.com/hpux/ http://www.test-smoke.org/
    http://qa.perl.org http://www.goldmark.org/jeff/stupid-disclaimers/

Related Discussions

Discussion Navigation
viewthread | post

2 users in discussion

H.Merijn Brand: 2 posts Steve Hay: 1 post