FAQ
Dear List

For whatever reason I wanted (and also would have a certain need) to build
mod_perl
to work with Apache 2.4 on Windows. ;-)

I've tried building 2.0.9-dev (master r1624218) with XAMPP 1.8.3 's (httpd
2.4.10) with several Strawberry Perl (portable) version and always fail
with the same errors. maybe I'm just doing it wrong but I haven't yet
figured out where to go from here. apxs doesn't seem to be part of XAMPP
but it seems to recognize the httpd folder.

Below is the output (Straberry Perl 5.16 32-bit)

Best regards
Mathieu

OUTPUT:

perl Makefile.PL
no conflicting prior mod_perl version found - good.

Next we need to know where the 'apxs' script is located. This script
provides a lot of information about the Apache installation, and makes
it easier to find things on your system. Normally it's located in the
same directory as the 'httpd' executable.

If you don't yet have Apache installed you can build Apache against
the Apache source code, but you won't be able to run the test suite (a
very important step). Therefore you may want to install Apache before
proceeding.

Please provide a full path to 'apxs' executable
(press Enter if you don't have it installed):

Configure mod_perl with c:\xampp\apache? [y]
Configuring Apache/2.4.10 mod_perl/2.0.9dev Perl/v5.16.3
Use of uninitialized value $httpd_version in string lt at
lib/ModPerl/MapUtil.pm
  line 51.
Warning (mostly harmless): No library found for
<path-to>l/mod_perl-dev/src/module
s/perl/mod_perl.lib
ERROR from evaluation of M:\devel\mod_perl-dev\Apache-Reload/Makefile.PL:
Use of
  uninitialized value $v in substitution (s///) at
Apache-Test/lib/Apache/TestRun
.pm line 1100.

Search Discussions

  • Steve Hay at Oct 2, 2014 at 8:17 am

    On 2 October 2014 08:26, Mathieu Simon wrote:
    Dear List

    For whatever reason I wanted (and also would have a certain need) to build
    mod_perl
    to work with Apache 2.4 on Windows. ;-)

    I've tried building 2.0.9-dev (master r1624218) with XAMPP 1.8.3 's (httpd
    2.4.10) with several Strawberry Perl (portable) version and always fail with
    the same errors. maybe I'm just doing it wrong but I haven't yet figured out
    where to go from here. apxs doesn't seem to be part of XAMPP but it seems to
    recognize the httpd folder.
    I'm not familiar with XAMPP, but I don't believe you can currently
    build mod_perl with Strawberry Perl because mod_perl doesn't support
    building with dmake.
  • Mathieu Simon at Oct 2, 2014 at 8:27 am
    Hey Steve and list

    Thanks

    2014-10-02 10:16 GMT+02:00 Steve Hay <steve.m.hay@googlemail.com>:
    I'm not familiar with XAMPP, but I don't believe you can currently
    build mod_perl with Strawberry Perl because mod_perl doesn't support
    building with dmake.
    Aha, so I guess a Visual Studio is required then?
    Let me give it a whirl then. :-)

    -- Mathieu

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmodperl @
categoriesmodperl, perl
postedOct 2, '14 at 7:27a
activeOct 2, '14 at 8:27a
posts3
users2
websiteperl.apache.org

2 users in discussion

Mathieu Simon: 2 posts Steve Hay: 1 post

People

Translate

site design / logo © 2018 Grokbase