FAQ
Hello,

Can someone indicate a version of the following that work

Apache 2.2.x
perl 5.x
mod_perl 2.0.x

all under FreeBSD 10.0-RELEASE #0


I have tried various combinations with

Apache 2.2.29
perl 5.16
mod_perl 2.0.8, 2.07, 2.0.6

and none work... :(

TIA
Bernard Higonnet

Search Discussions

  • Jbiskofski at Sep 18, 2014 at 9:23 pm
    I tried all the possible combinations and was unable to get it to work. I
    ended up reverting to freebsd 9.

    I tried perl 5.12 thru 5.20.
    Apache 2.0* 2.2* 2.4*
    The last ten mod_perl releases.

    This was a year ago. So I dont remember the specifics but I do remember
    certain combinations just would not compile, other combinations would
    compile after much suffering, only to segfault when I tried starting apache.

    - Jose

    On Thu, Sep 18, 2014 at 2:16 PM, Bernard T. Higonnet wrote:

    Hello,

    Can someone indicate a version of the following that work

    Apache 2.2.x
    perl 5.x
    mod_perl 2.0.x

    all under FreeBSD 10.0-RELEASE #0


    I have tried various combinations with

    Apache 2.2.29
    perl 5.16
    mod_perl 2.0.8, 2.07, 2.0.6

    and none work... :(

    TIA
    Bernard Higonnet
  • John D Groenveld at Sep 19, 2014 at 2:42 pm

    In message <541b4ba4.6060005@higonnet.net>, "Bernard T. Higonnet" writes:
    Can someone indicate a version of the following that work

    Apache 2.2.x
    perl 5.x
    mod_perl 2.0.x

    all under FreeBSD 10.0-RELEASE #0
    Install gcc47 and build them each from source.
    $ cd http-2.2.29
    $ env CC=gcc47 ./configure --enable-ssl --enable-proxy \
    --enable-rewrite --enable-modules=all --enable-mods-shared=all \
    --with-included-apr --prefix=/opt/apache2
    $ cd perl-5.20.1
    $ ./Configure -Dprefix=/opt/apache2/perl-5.20.1 -Dcc=gcc47 -Duseshrplib \
    -Uusemymalc -Duselargefiles -Ubincompat5005 -Duse64bitall
    $ cd mod_perl-2.0.8
    $ env PATH=/opt/apache2/perl-5.20.1/bin:/opt/apache2/bin:${PATH} \
    perl Makefile.PL MP_APXS=/opt/apache2/bin/apxs

    John
    groenveld@acm.org
  • Bernard T. Higonnet at Sep 21, 2014 at 3:25 pm
    server-info:

    Server Version: Apache/2.2.29 (Unix) PHP/5.6.0 mod_perl/2.0.8 Perl/v5.20.1

    Many thanks!
    Bernard Higonnet
    On 09/19/14 16:42, John D Groenveld wrote:
    In message <541b4ba4.6060005@higonnet.net>, "Bernard T. Higonnet" writes:
    Can someone indicate a version of the following that work

    Apache 2.2.x
    perl 5.x
    mod_perl 2.0.x

    all under FreeBSD 10.0-RELEASE #0
    Install gcc47 and build them each from source.
    $ cd http-2.2.29
    $ env CC=gcc47 ./configure --enable-ssl --enable-proxy \
    --enable-rewrite --enable-modules=all --enable-mods-shared=all \
    --with-included-apr --prefix=/opt/apache2
    $ cd perl-5.20.1
    $ ./Configure -Dprefix=/opt/apache2/perl-5.20.1 -Dcc=gcc47 -Duseshrplib \
    -Uusemymalc -Duselargefiles -Ubincompat5005 -Duse64bitall
    $ cd mod_perl-2.0.8
    $ env PATH=/opt/apache2/perl-5.20.1/bin:/opt/apache2/bin:${PATH} \
    perl Makefile.PL MP_APXS=/opt/apache2/bin/apxs

    John
    groenveld@acm.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmodperl @
categoriesmodperl, perl
postedSep 18, '14 at 9:16p
activeSep 21, '14 at 3:25p
posts4
users3
websiteperl.apache.org

People

Translate

site design / logo © 2018 Grokbase