FAQ
I'm attempting to use Apache2-AuthenRadius-0.6, with Apache 2.0.59, which
requires mod_perl. I installed both and it's working to a point, but
Apache is generating Segmentation faults (on Solaris 10 SPARC). It seems
I can successfully authenticate, but when Apache attempts to displayed my
index page (index.cgi - a perl CGI script) I get the segmentation fault:

child pid 4967 exit signal Segmentation fault (11)

where pid 4967 is the apache process handling the request. The index page
never displays. If I manually enter url.../index.cgi, it runs fine.

I suspect mod_perl might be the cause. The documentation for AuthenRadius
states ...you need to enable the appropriate call-back hook when making
mod_perl:

perl Makefile.PL PERL_AUTHEN=1

But when I run that, it says:

Configuring Apache/2.0.59 mod_perl/2.0.4 Perl/v5.8.4
'PERL_AUTHEN' is not a known MakeMaker parameter name.

and..

WARNING: PERL_AUTHEN is not a known parameter.
Note (probably harmless): No library found for -liconv

Otherwise, configure runs and I'm able to run make. Any thoughts as to
what the problem might be? I'm stumped. I don't really need or want
mod_perl otherwise, but mod_auth_xradius won't compile on Solaris, and
mod_auth_radius-2.0 doesn't support failover!

-Mike

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmodperl @
categoriesmodperl, perl
postedApr 19, '09 at 2:20a
activeApr 19, '09 at 2:20a
posts1
users1
websiteperl.apache.org

1 user in discussion

Mike Diggins: 1 post

People

Translate

site design / logo © 2018 Grokbase