FAQ

Christopher H. Laco wrote:
Randy Kobes
Sat, 04 Dec 2004 20:09:18 -0800
On Fri, 3 Dec 2004, Christopher H. Laco wrote:

Christopher H. Laco wrote:
I'll take a look at this, as I suppose it should
have inferred that C:\Development\Apache2 was the top-level
Apache2 directory, but in the meantime, does
perl Makefile.PL MP_AP_PREFIX=C:\Development\Apache2
work?
That did the trick. Thanks.
-=Chris
OF course now Apache2 is crashing just before 1/api/show. Time to
disable threading somewhere I guess.
Are you still having problems with this test? With the
current mod_perl-2.0 svn sources, perl-5.8.4 (ActivePerl
810), and Apache/2.0.52, all the api tests pass for me.
I'm not sure. I just got back in town. My last build attempt was early
Saturday morning with a fresh SVN. It's not really the test that fails,
it more that Apache2 crashes and burns somewhere in mod_perl.so during
the first tests before t/api/show.t. I think the tests would pass if
Apache would just stay up and running.

I did have a thought about this this morning though. I'm running 2
different versions of perl on my lappy; a loaded 5.6.1, and a stock
5.8.4. Both are ActiveState installations without any of the environment
variables or paths set during the install.

I have a batch file for each version that I run that set the PATH and
PERLIB, PERL5LIB paths so I can flip back and forth during testing and
development.

Maybe something about the modperl test suite setup doesn't like that
setup. I'm going to reinstall 5.8.4 this evening letting it setup the
path and lib variables and see if Apache2 still crashes within mod_perl.so.

-=Chris

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmodperl @
categoriesmodperl, perl
postedDec 6, '04 at 3:16p
activeDec 6, '04 at 3:16p
posts1
users1
websiteperl.apache.org

1 user in discussion

Christopher H. Laco: 1 post

People

Translate

site design / logo © 2018 Grokbase