FAQ
Hi,

I just recompiled latest embperl 2.5.0_1, setup everything (?) but I get :

Undefined subroutine &Embperl::__1::Execute

* I added "use Embperl;" in startup.pl
* Copied zembperl.load and zembperl.conf from a running project,
replacing the path to :
LoadModule embperl_module /usr/local/lib/perl/5.14.2/auto/Embperl/Embperl.so

Apache starts fine but throws this error as soon as I try to get to an
embperl page.

What am I missing ?

This is on a fresh Debian Wheezy. Google's not my friend on this.

Thanks for your help.

--
Jean-Christophe Boggio -o)
embperl@thefreecat.org /\\
Independant Consultant and Developer _\_V

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org

Search Discussions

  • Gerald Richter at Sep 3, 2012 at 9:44 am
    Are there any errors in the Apache error log?

    Gerald

    -----Original Message-----
    From: Jean-Christophe Boggio
    Sent: Monday, September 03, 2012 11:13 AM
    To: embperl@perl.apache.org
    Subject: Error running embperl

    Hi,

    I just recompiled latest embperl 2.5.0_1, setup everything (?) but I get :

    Undefined subroutine &Embperl::__1::Execute

    * I added "use Embperl;" in startup.pl
    * Copied zembperl.load and zembperl.conf from a running project, replacing
    the path to :
    LoadModule embperl_module
    /usr/local/lib/perl/5.14.2/auto/Embperl/Embperl.so

    Apache starts fine but throws this error as soon as I try to get to an embperl
    page.

    What am I missing ?

    This is on a fresh Debian Wheezy. Google's not my friend on this.

    Thanks for your help.

    --
    Jean-Christophe Boggio -o)
    embperl@thefreecat.org /\\
    Independant Consultant and Developer _\_V

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org


    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Jean-Christophe Boggio at Sep 3, 2012 at 10:02 am

    Le 03/09/2012 11:44, richter@ecos.de a écrit :
    Are there any errors in the Apache error log?
    No, nothing else.

    I think I've found the problem : apache2-mpm-worker installed instead of
    apache2-mpm-prefork (default apt-get install apache2 done by the admin).
    How many times will I be bitten by this ? Could you add a word on this
    in the INSTALL.pod for Debian users ?

    Thanks a lot for your quick answer, sorry for the trouble.

    --
    Jean-Christophe Boggio -o)
    embperl@thefreecat.org /\\
    Independant Consultant and Developer _\_V

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupembperl @
categoriesmodperl, perl
postedSep 3, '12 at 9:13a
activeSep 3, '12 at 10:02a
posts3
users2
websiteperl.apache.org

People

Translate

site design / logo © 2018 Grokbase