FAQ
Hi,

I have to integrate my Automation tool to support Safari browser on
Mac OS.
I have my selenium 2.0 code running on windows for Firefox and
Internet Explorer.

Can you please suggest what changes are required for safari mac
integration ?

--
You received this message because you are subscribed to the Google Groups "webdriver" group.
To post to this group, send email to webdriver@googlegroups.com.
To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.

Search Discussions

  • Luke Inman-Semerau at May 1, 2012 at 2:11 pm
    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke
    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Payal Gupta at May 1, 2012 at 4:01 pm
    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.
    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.
    It just launches the browser, but doesn't perform any further execution.

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau
    wrote:
    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke
    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Richard Lavoie at May 1, 2012 at 5:52 pm
    Well according to the SafariDriver page, the driver only supports Safari 5+

    If you are willing to make it compatible with Safari 4-, go ahead ;)

    Richard


    On 2012-05-01, at 12:01, Payal Gupta wrote:

    Is there a way to support Safari browser execution in Windows and Mac OS without using extensions.
    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.
    It just launches the browser, but doesn't perform any further execution.

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau wrote:
    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke
    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.


    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Payal Gupta at May 2, 2012 at 9:26 am
    can you please guide me through the steps required to integrate selenium
    driver with Safari extension.
    I have installed the certificate, but am not sure on how to build extension
    and what other modification in the code is required for the same.

    On Tue, May 1, 2012 at 11:22 PM, Richard Lavoie wrote:

    Well according to the SafariDriver page, the driver only supports Safari 5+

    If you are willing to make it compatible with Safari 4-, go ahead ;)

    Richard



    On 2012-05-01, at 12:01, Payal Gupta wrote:

    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.
    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.
    It just launches the browser, but doesn't perform any further execution.

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau <luke.semerau@gmail.com
    wrote:
    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke

    On May 1, 2012, at 3:50 AM, aakash attrey <aakash.attrey@gmail.com>
    wrote:
    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Mark Collin at May 2, 2012 at 9:27 am
    I would ask why you need to use Safari 4?



    Safari usage hovers around the 5% mark, seeing as Apple does a good job of
    nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.



    Using this as an example:



    http://www.w3counter.com/globalstats.php



    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% . Based
    upon this you are worrying about testing on a browser that only 0.84% of web
    users actually use, Konqueror probably has a similar market share.



    From: webdriver@googlegroups.com On
    Behalf Of Payal Gupta
    Sent: 01 May 2012 17:01
    To: webdriver@googlegroups.com
    Subject: Re: [webdriver] Mac safari integration



    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.

    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.

    It just launches the browser, but doesn't perform any further execution.

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau wrote:

    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke

    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com
    .
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    >

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com
    .
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.



    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Payal Gupta at May 2, 2012 at 9:32 am
    I don't have restriction to use Safari 4 or Safari 5 or any other upgraded
    versions . It is just that I could find some answers on how I can upgrade
    my test framework based on selenium webdriver to support safari 4 but there
    is no such method for Safari 5(except the newly mentioned safari extensions)

    On Wed, May 2, 2012 at 2:57 PM, Mark Collin wrote:

    I would ask why you need to use Safari 4?****

    ** **

    Safari usage hovers around the 5% mark, seeing as Apple does a good job of
    nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.****

    ** **

    Using this as an example:****

    ** **

    http://www.w3counter.com/globalstats.php****

    ** **

    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% .
    Based upon this you are worrying about testing on a browser that only 0.84%
    of web users actually use, Konqueror probably has a similar market share…*
    ***

    ** **

    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 01 May 2012 17:01
    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****

    ** **

    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.****

    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.
    ****

    It just launches the browser, but doesn't perform any further execution.**
    **

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau wrote:****

    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke****

    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    ** **

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Mark Collin at May 2, 2012 at 9:51 am
    Moving forward the extension is going to be the only way it will work, I
    would suggest using it.



    From: webdriver@googlegroups.com On
    Behalf Of Payal Gupta
    Sent: 02 May 2012 10:32
    To: webdriver@googlegroups.com
    Subject: Re: [webdriver] Mac safari integration



    I don't have restriction to use Safari 4 or Safari 5 or any other upgraded
    versions . It is just that I could find some answers on how I can upgrade my
    test framework based on selenium webdriver to support safari 4 but there is
    no such method for Safari 5(except the newly mentioned safari extensions)





    On Wed, May 2, 2012 at 2:57 PM, Mark Collin wrote:

    I would ask why you need to use Safari 4?



    Safari usage hovers around the 5% mark, seeing as Apple does a good job of
    nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.



    Using this as an example:



    http://www.w3counter.com/globalstats.php



    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% . Based
    upon this you are worrying about testing on a browser that only 0.84% of web
    users actually use, Konqueror probably has a similar market share.



    From: webdriver@googlegroups.com On
    Behalf Of Payal Gupta
    Sent: 01 May 2012 17:01
    To: webdriver@googlegroups.com
    Subject: Re: [webdriver] Mac safari integration



    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.

    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.

    It just launches the browser, but doesn't perform any further execution.

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau wrote:

    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke

    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com
    .
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    >

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com
    .
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.



    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com
    .
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.



    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Payal Gupta at May 2, 2012 at 9:54 am
    okay..I have already done the setup for this..
    I have installed the certificate, but am not sure on how to build extension
    and what other modification in the code is required for the same to be
    supported by selenium webdriver
    so I need some guidance for the steps required to integrate selenium driver
    with Safari extension.

    On Wed, May 2, 2012 at 3:20 PM, Mark Collin wrote:

    Moving forward the extension is going to be the only way it will work, I
    would suggest using it.****

    ** **

    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 02 May 2012 10:32

    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****

    ** **

    I don't have restriction to use Safari 4 or Safari 5 or any other upgraded
    versions . It is just that I could find some answers on how I can upgrade
    my test framework based on selenium webdriver to support safari 4 but there
    is no such method for Safari 5(except the newly mentioned safari extensions)
    ****

    ** **

    ** **

    On Wed, May 2, 2012 at 2:57 PM, Mark Collin wrote:****

    I would ask why you need to use Safari 4?****

    ****

    Safari usage hovers around the 5% mark, seeing as Apple does a good job of
    nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.****

    ****

    Using this as an example:****

    ****

    http://www.w3counter.com/globalstats.php****

    ****

    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% .
    Based upon this you are worrying about testing on a browser that only 0.84%
    of web users actually use, Konqueror probably has a similar market share…*
    ***

    ****

    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 01 May 2012 17:01
    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****

    ****

    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.****

    I have tried the execution with Safari 4 on windows with Selenium 2.19 jar.
    ****

    It just launches the browser, but doesn't perform any further execution.**
    **

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau wrote:****

    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke****

    On May 1, 2012, at 3:50 AM, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    ****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    ** **

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Payal Gupta at May 11, 2012 at 5:33 pm
    Hi All,

    I need to support execution on safari browser. I have done all the steps
    mentioned on wiki page to install the certificate and build the extension.

    I am using selenium webdriver with junit framework and selenium 2.19
    standalone jar.

    Can anyone guide on lines of code required to support safari execution.
    On Wed, May 2, 2012 at 3:24 PM, Payal Gupta wrote:

    okay..I have already done the setup for this..
    I have installed the certificate, but am not sure on how to build
    extension and what other modification in the code is required for the same
    to be supported by selenium webdriver
    so I need some guidance for the steps required to integrate selenium
    driver with Safari extension.

    On Wed, May 2, 2012 at 3:20 PM, Mark Collin wrote:

    Moving forward the extension is going to be the only way it will work, I
    would suggest using it.****

    ** **

    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 02 May 2012 10:32

    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****

    ** **

    I don't have restriction to use Safari 4 or Safari 5 or any other
    upgraded versions . It is just that I could find some answers on how I can
    upgrade my test framework based on selenium webdriver to support safari 4
    but there is no such method for Safari 5(except the newly mentioned
    safari extensions)****

    ** **

    ** **

    On Wed, May 2, 2012 at 2:57 PM, Mark Collin <mark.collin@lazeryattack.com>
    wrote:****

    I would ask why you need to use Safari 4?****

    ****

    Safari usage hovers around the 5% mark, seeing as Apple does a good job
    of nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.****

    ****

    Using this as an example:****

    ****

    http://www.w3counter.com/globalstats.php****

    ****

    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% .
    Based upon this you are worrying about testing on a browser that only 0.84%
    of web users actually use, Konqueror probably has a similar market share…
    ****

    ****

    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 01 May 2012 17:01
    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****

    ****

    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.****

    I have tried the execution with Safari 4 on windows with Selenium 2.19
    jar.****

    It just launches the browser, but doesn't perform any further execution.*
    ***

    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau <
    luke.semerau@gmail.com> wrote:****

    Well you need to install an extension for starters

    http://code.google.com/p/selenium/wiki/SafariDriver

    -Luke****


    On May 1, 2012, at 3:50 AM, aakash attrey <aakash.attrey@gmail.com>
    wrote:
    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?

    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    ****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    ** **

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • David at May 11, 2012 at 6:26 pm
    The wiki page has sample code for you to test with, since you mention
    Java. But you need to use selenium version 2.21 to use SafariDriver.

    If using with RemoteWebDriver, works the same as FF and IE, just use
    browser name as "safari". And you would then need to start the
    selenium server (v2.21) on the Safari machine for RemoteWebDriver to
    work.
    On May 11, 10:33 am, Payal Gupta wrote:
    Hi All,

    I need to support execution on safari browser. I have done all the steps
    mentioned on wiki page to install the certificate and build the extension.

    I am using selenium webdriver with junit framework and selenium 2.19
    standalone jar.

    Can anyone guide on lines of code required to support safari execution.






    On Wed, May 2, 2012 at 3:24 PM, Payal Gupta wrote:
    okay..I have already done the setup for this..
    I have installed the certificate, but am not sure on how to build
    extension and what other modification in the code is required for the same
    to be supported by selenium webdriver
    so I need some guidance for the steps required to integrate selenium
    driver with Safari extension.
    On Wed, May 2, 2012 at 3:20 PM, Mark Collin wrote:

    Moving forward the extension is going to be the only way it will work, I
    would suggest using it.****
    ** **
    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 02 May 2012 10:32
    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****
    ** **
    I don't have restriction to use Safari 4 or Safari 5 or any other
    upgraded versions . It is just that I could find some answers on how I can
    upgrade my test framework based on selenium webdriver to support safari 4
    but there is no such method for Safari 5(except the newly mentioned
    safari extensions)****
    ** **
    ** **
    On Wed, May 2, 2012 at 2:57 PM, Mark Collin <mark.col...@lazeryattack.com>
    wrote:****
    I would ask why you need to use Safari 4?****
    ****
    Safari usage hovers around the 5% mark, seeing as Apple does a good job
    of nagging you to upgrade (which is a one click process) I would expect the
    majority of people who regularly use Safari to be using Safari 5.****
    ****
    Using this as an example:****
    ****
    ****
    Safari has an overall percentage of 6.4% of which Safari 5 is 5.56% .
    Based upon this you are worrying about testing on a browser that only 0.84%
    of web users actually use, Konqueror probably has a similar market share…
    ****
    ****
    *From:* webdriver@googlegroups.com *On
    Behalf Of *Payal Gupta
    *Sent:* 01 May 2012 17:01
    *To:* webdriver@googlegroups.com
    *Subject:* Re: [webdriver] Mac safari integration****
    ****
    Is there a way to support Safari browser execution in Windows and Mac OS
    without using extensions.****
    I have tried the execution with Safari 4 on windows with Selenium 2.19
    jar.****
    It just launches the browser, but doesn't perform any further execution.*
    ***
    On Tue, May 1, 2012 at 7:41 PM, Luke Inman-Semerau <
    luke.seme...@gmail.com> wrote:****
    Well you need to install an extension for starters
    -Luke****
    On May 1, 2012, at 3:50 AM, aakash attrey <aakash.att...@gmail.com>
    wrote:
    Hi,
    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.
    Can you please suggest what changes are required for safari mac
    integration ?
    --
    You received this message because you are subscribed to the Google
    Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****
    ****
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****
    ** **
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.****
    --
    You received this message because you are subscribed to the Google Groups
    "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to
    webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/webdriver?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.
  • Web User at May 1, 2012 at 4:55 pm
    i tried to run it using the instruction at that page but its showing this
    error .

    Its opening a safari browser with this line SafariDriver requesting
    connection at ws://localhost:4132/wd
    and showing this error :
    Caused by: java.lang.
    IllegalStateException: Executor has not been started yet
    at
    com.google.common.base.Preconditions.checkState(Preconditions.java:145)
    at
    org.openqa.selenium.safari.SafariDriverCommandExecutor.execute(SafariDriverCommandExecutor.java:123)
    at
    org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:415)

    i am using Selenium-java version 2.21.0


    Any body please help

    On Tuesday, May 1, 2012 3:50:22 AM UTC-7, aakash attrey wrote:

    Hi,

    I have to integrate my Automation tool to support Safari browser on
    Mac OS.
    I have my selenium 2.0 code running on windows for Firefox and
    Internet Explorer.

    Can you please suggest what changes are required for safari mac
    integration ?
    --
    You received this message because you are subscribed to the Google Groups "webdriver" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/webdriver/-/wKDAFD_JhecJ.
    To post to this group, send email to webdriver@googlegroups.com.
    To unsubscribe from this group, send email to webdriver+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/webdriver?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupwebdriver @
categorieswatir
postedMay 1, '12 at 10:51a
activeMay 11, '12 at 6:26p
posts12
users7
websitewatir.com

People

Translate

site design / logo © 2018 Grokbase