FAQ

[storm-user] setNumWorkers above 1 doesn't work for a DRPC topology

Cristian Pirvu
Mar 29, 2013 at 12:21 pm
Hi everyone,

I'm facing an issue that I don't know how to fix: if I deploy the topology
with more than 1 worker in the config, on a storm cluster (with 1 or 2
supervisors is the same behaviour) i get an error from in the worker log:

2013-03-29 12:16:27 util [ERROR] Async loop died!
org.zeromq.ZMQException: Address already in use(0x62)
         at org.zeromq.ZMQ$Socket.bind(Native Method)
         at zilch.mq$bind.invoke(mq.clj:69)
         at backtype.storm.messaging.zmq.ZMQContext.bind(zmq.clj:58)
         at
backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__1631.invoke(loader.clj:26)
         at backtype.storm.util$async_loop$fn__465.invoke(util.clj:375)
         at clojure.lang.AFn.run(AFn.java:24)
         at java.lang.Thread.run(Thread.java:662)


Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
same.

If i don't use setNumWorkers() and leave it to the default value of 1,
everything is ok, no exceptions and the call gets through.

The topology is build using LinearDRPCTopologyBuilder, but the same happens
if i use Tridend.

The number of workers I set in Config is always lower than the ones
available in the supervisor.



Any idea why this happens? What do i need to change to make a DRPC topology
be able to have more workers.


Many Thanks!

--
You received this message because you are subscribed to the Google Groups "storm-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
reply

Search Discussions

10 responses

  • Xmdxcxz at Apr 1, 2013 at 6:00 am
    Have the supervisor.slots.ports: defined in your storm.yaml file has been
    used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the topology
    with more than 1 worker in the config, on a storm cluster (with 1 or 2
    supervisors is the same behaviour) i get an error from in the worker log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(Native Method)
    at zilch.mq$bind.invoke(mq.clj:69)
    at backtype.storm.messaging.zmq.ZMQContext.bind(zmq.clj:58)
    at
    backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__1631.invoke(loader.clj:26)
    at backtype.storm.util$async_loop$fn__465.invoke(util.clj:375)
    at clojure.lang.AFn.run(AFn.java:24)
    at java.lang.Thread.run(Thread.java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
    same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Cristian Pirvu at Apr 1, 2013 at 11:33 am
    I don't believe so. For example if i set the topology with 2 workers, i see
    2 ports used in netstat (7704, 7705), i've changed the default ones, trying
    to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm and
    it's the same for 1 or 2 workers, but it only gives an error with more than
    1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has been
    used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(Native Method)
    at zilch.mq$bind.invoke(mq.clj:69)
    at backtype.storm.messaging.zmq.ZMQContext.bind(zmq.clj:58)
    at
    backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__1631.invoke(loader.clj:26)
    at backtype.storm.util$async_loop$fn__465.invoke(util.clj:375)
    at clojure.lang.AFn.run(AFn.java:24)
    at java.lang.Thread.run(Thread.java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
    same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • 陈竞 at Apr 16, 2013 at 1:09 pm
    i met the same problem, do you solve it?


    2013/4/1 Cristian Pirvu <pcr...@...com>
    I don't believe so. For example if i set the topology with 2 workers, i
    see 2 ports used in netstat (7704, 7705), i've changed the default ones,
    trying to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm and
    it's the same for 1 or 2 workers, but it only gives an error with more than
    1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has been
    used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,**Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(**Native Method)
    at zilch.mq$bind.invoke(mq.clj:**69)
    at backtype.storm.messaging.zmq.**ZMQContext.bind(zmq.clj:58)
    at backtype.storm.messaging.**loader$launch_receive_thread_**
    BANG_$fn__1631.invoke(loader.**clj:26)
    at backtype.storm.util$async_**loop$fn__465.invoke(util.clj:**
    375)
    at clojure.lang.AFn.run(AFn.java:**24)
    at java.lang.Thread.run(Thread.**java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
    same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using **LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google Groups
    "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    陈竞,中科院计算技术研究所,高性能计算机中心
    Jing Chen HPCC.ICT.AC China

    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Cristian Pirvu at Apr 17, 2013 at 6:10 am
    Unfortunately no, and it's a shame too, because everything else about Storm
    seems to be so nice, but this bug is a stopper for us, we can't continue
    using it if we can't make use of parallel processing.

    On Tue, Apr 16, 2013 at 4:09 PM, 陈竞 wrote:

    i met the same problem, do you solve it?


    2013/4/1 Cristian Pirvu <pcr...@...com>
    I don't believe so. For example if i set the topology with 2 workers, i
    see 2 ports used in netstat (7704, 7705), i've changed the default ones,
    trying to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm and
    it's the same for 1 or 2 workers, but it only gives an error with more than
    1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has
    been used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,**Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(**Native Method)
    at zilch.mq$bind.invoke(mq.clj:**69)
    at backtype.storm.messaging.zmq.**ZMQContext.bind(zmq.clj:58)
    at backtype.storm.messaging.**loader$launch_receive_thread_**
    BANG_$fn__1631.invoke(loader.**clj:26)
    at backtype.storm.util$async_**loop$fn__465.invoke(util.clj:**
    375)
    at clojure.lang.AFn.run(AFn.java:**24)
    at java.lang.Thread.run(Thread.**java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
    same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using **LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google Groups
    "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to storm-user+unsubscribe@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.



    --
    陈竞,中科院计算技术研究所,高性能计算机中心
    Jing Chen HPCC.ICT.AC China

    --
    You received this message because you are subscribed to a topic in the
    Google Groups "storm-user" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/storm-user/iny-9QHIhDw/unsubscribe?hl=en
    .
    To unsubscribe from this group and all its topics, send an email to
    storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nathan Marz at Apr 17, 2013 at 10:47 pm
    Are you using zmq 2.1.7 or 2.1.4?

    On Tue, Apr 16, 2013 at 10:45 PM, Cristian Pirvu wrote:

    Unfortunately no, and it's a shame too, because everything else about
    Storm seems to be so nice, but this bug is a stopper for us, we can't
    continue using it if we can't make use of parallel processing.

    On Tue, Apr 16, 2013 at 4:09 PM, 陈竞 wrote:

    i met the same problem, do you solve it?


    2013/4/1 Cristian Pirvu <pcr...@...com>
    I don't believe so. For example if i set the topology with 2 workers, i
    see 2 ports used in netstat (7704, 7705), i've changed the default ones,
    trying to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm
    and it's the same for 1 or 2 workers, but it only gives an error with more
    than 1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has
    been used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,**Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(**Native Method)
    at zilch.mq$bind.invoke(mq.clj:**69)
    at backtype.storm.messaging.zmq.**ZMQContext.bind(zmq.clj:58)
    at backtype.storm.messaging.**loader$launch_receive_thread_**
    BANG_$fn__1631.invoke(loader.**clj:26)
    at backtype.storm.util$async_**loop$fn__465.invoke(util.clj:**
    375)
    at clojure.lang.AFn.run(AFn.java:**24)
    at java.lang.Thread.run(Thread.**java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is
    the same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using **LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google
    Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to storm-user+unsubscribe@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.



    --
    陈竞,中科院计算技术研究所,高性能计算机中心
    Jing Chen HPCC.ICT.AC China

    --
    You received this message because you are subscribed to a topic in the
    Google Groups "storm-user" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/storm-user/iny-9QHIhDw/unsubscribe?hl=en
    .
    To unsubscribe from this group and all its topics, send an email to
    storm-user+unsubscribe@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups
    "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Twitter: @nathanmarz
    http://nathanmarz.com

    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Cristian Pirvu at Apr 18, 2013 at 6:12 am
    Hi Nathan,

    I'm using zmq 2.1.7, should I try with 2.1.4? I know from the docs I've
    read that 2.1.7 is the recommended version for Storm 0.8.x.


    Thanks,
    Cristi
    On Thursday, April 18, 2013 1:40:10 AM UTC+3, Nathan Marz wrote:

    Are you using zmq 2.1.7 or 2.1.4?


    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nathan Marz at Apr 18, 2013 at 6:37 am
    Yea, try 2.1.4. Also, let us know your OS information.

    On Wed, Apr 17, 2013 at 11:12 PM, Cristian Pirvu wrote:

    Hi Nathan,

    I'm using zmq 2.1.7, should I try with 2.1.4? I know from the docs I've
    read that 2.1.7 is the recommended version for Storm 0.8.x.


    Thanks,
    Cristi

    On Thursday, April 18, 2013 1:40:10 AM UTC+3, Nathan Marz wrote:

    Are you using zmq 2.1.7 or 2.1.4?



    --
    Twitter: @nathanmarz
    http://nathanmarz.com

    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Cristian Pirvu at Apr 23, 2013 at 12:09 pm
    Thanks Nathan, that actually worked.

    I'm using CentOS 6.3 x64, kernel v2.6.32.



    The only problem that i can see right now is that i cannot make a DRPC call
    on a topology split among multiple servers in the cluster.
    If the topology runs on one supervisor only, everything is ok, if i add
    another supervisor, the DRPC call times out.


    Thanks,
    Cristi

    On Thursday, April 18, 2013 9:37:01 AM UTC+3, Nathan Marz wrote:

    Yea, try 2.1.4. Also, let us know your OS information.

    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • 丛梓存 at Jun 25, 2013 at 5:33 am
    Hi celix:
          I‘m a student from sun yat-sen university. I have the same problem
    too, so i wonder if you have solved the problem

    在 2013年4月16日星期二UTC+8下午9时09分51秒,celix写道:
    i met the same problem, do you solve it?


    2013/4/1 Cristian Pirvu <pcri...@gmail.com <javascript:>>
    I don't believe so. For example if i set the topology with 2 workers, i
    see 2 ports used in netstat (7704, 7705), i've changed the default ones,
    trying to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm and
    it's the same for 1 or 2 workers, but it only gives an error with more than
    1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has
    been used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,**Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(**Native Method)
    at zilch.mq$bind.invoke(mq.clj:**69)
    at backtype.storm.messaging.zmq.**ZMQContext.bind(zmq.clj:58)
    at backtype.storm.messaging.**loader$launch_receive_thread_**
    BANG_$fn__1631.invoke(loader.**clj:26)
    at backtype.storm.util$async_**loop$fn__465.invoke(util.clj:**
    375)
    at clojure.lang.AFn.run(AFn.java:**24)
    at java.lang.Thread.run(Thread.**java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is the
    same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using **LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google Groups
    "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to storm-user+...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    陈竞,中科院计算技术研究所,高性能计算机中心
    Jing Chen HPCC.ICT.AC China
    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Suchi Amalapurapu at Nov 18, 2013 at 7:16 pm
    Any resolution on this? We are seeing a similar issue. nimbus.log does
    indicate two workers but all the requests go to only one router.
    it kind of defeats the parallelism on the cluster.
    On Monday, June 24, 2013 2:50:06 PM UTC+5:30, 丛梓存 wrote:

    Hi celix:
    I‘m a student from sun yat-sen university. I have the same problem
    too, so i wonder if you have solved the problem

    在 2013年4月16日星期二UTC+8下午9时09分51秒,celix写道:
    i met the same problem, do you solve it?


    2013/4/1 Cristian Pirvu <pcri...@gmail.com>
    I don't believe so. For example if i set the topology with 2 workers, i
    see 2 ports used in netstat (7704, 7705), i've changed the default ones,
    trying to find solutions to the problem.

    These are both created by worker process of the supervisor. They are
    already on LISTENING before i call the topology from DRPC.
    The ports seem to be opened as soon as i deploy the topology to Storm
    and it's the same for 1 or 2 workers, but it only gives an error with more
    than 1 worker being used.

    Thanks!

    On Monday, April 1, 2013 9:00:48 AM UTC+3, xmdxcxz wrote:

    Have the supervisor.slots.ports: defined in your storm.yaml file has
    been used already by other processs?

    you can use the command "netstat" to check it.

    Thanks.

    在 2013年3月29日星期五UTC+8下午8时21分29秒,Cristian Pirvu写道:
    Hi everyone,

    I'm facing an issue that I don't know how to fix: if I deploy the
    topology with more than 1 worker in the config, on a storm cluster (with 1
    or 2 supervisors is the same behaviour) i get an error from in the worker
    log:

    2013-03-29 12:16:27 util [ERROR] Async loop died!
    org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(Native Method)
    at zilch.mq$bind.invoke(mq.clj:69)
    at backtype.storm.messaging.zmq.ZMQContext.bind(zmq.clj:58)
    at backtype.storm.messaging.loader$launch_receive_thread_
    BANG_$fn__1631.invoke(loader.clj:26)
    at backtype.storm.util$async_loop$fn__465.invoke(util.clj:375)
    at clojure.lang.AFn.run(AFn.java:24)
    at java.lang.Thread.run(Thread.java:662)


    Tried with versions 0.8.2, 0.8.3-wip3 and 0.9.0-wip16, the error is
    the same.

    If i don't use setNumWorkers() and leave it to the default value of 1,
    everything is ok, no exceptions and the call gets through.

    The topology is build using LinearDRPCTopologyBuilder, but the same
    happens if i use Tridend.

    The number of workers I set in Config is always lower than the ones
    available in the supervisor.



    Any idea why this happens? What do i need to change to make a DRPC
    topology be able to have more workers.


    Many Thanks!
    --
    You received this message because you are subscribed to the Google
    Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to storm-user+...@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    陈竞,中科院计算技术研究所,高性能计算机中心
    Jing Chen HPCC.ICT.AC China
    --
    You received this message because you are subscribed to the Google Groups "storm-user" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to storm-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions