FAQ

[nodejs] BeagleBone with node.js - getting started.

Paul_tanner
May 9, 2012 at 9:52 am
Hi,

Just got my beaglebone from farnell and hoping to start work with
nodejs on it.

It shipped with v0.4.12 and the Cloud9 IDE.

On running the standard hello world script it thows errors to the
effect that npm modules inotify and fibers were not installed.
Presumably these are required by the IDE.

So I tried npm install and found that npm was not present. Installed
that OK.

Then installed inotify ok

The attempt to install fibers failed as follows:

root@beaglebone:~# npm install fibers
fibers@0.5.1 install /home/root/node_modules/fibers
make clean all
make -C src clean
make[1]: Entering directory `/home/root/node_modules/fibers/src'
rm -f fibers.node libcoro.o coroutine.so
rm -f -r *.dSYM
make[1]: Leaving directory `/home/root/node_modules/fibers/src'
rm -f -r man
make -C src coroutine.so
make[1]: Entering directory `/home/root/node_modules/fibers/src'
cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
libcoro.o libcoro/coro.c
cc1: error: unrecognized command line option "-minline-all-stringops"
cc1: error: unrecognized command line option "-m32"
make[1]: *** [libcoro.o] Error 1
make[1]: Leaving directory `/home/root/node_modules/fibers/src'
make: *** [/home/root/node_modules/fibers/src/coroutine.so] Error 2
npm ERR! error installing fibers@0.5.1 Error: fibers@0.5.1 install:
`make clean all`
npm ERR! error installing fibers@0.5.1 `sh "-c" "make clean all"`
failed with 2
npm ERR! error installing fibers@0.5.1 at ChildProcess.<anonymous>
(/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing fibers@0.5.1 at ChildProcess.emit
(events.js:67:17)
npm ERR! error installing fibers@0.5.1 at ChildProcess.onexit
(child_process.js:192:12)
npm ERR! fibers@0.5.1 install: `make clean all`
npm ERR! `sh "-c" "make clean all"` failed with 2
npm ERR!
npm ERR! Failed at the fibers@0.5.1 install script.
npm ERR! This is most likely a problem with the fibers package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! make clean all
npm ERR! You can get their info via:
npm ERR! npm owner ls fibers
npm ERR! There is likely additional logging output above.
npm ERR!
npm ERR! System Linux 3.2.5+
npm ERR! command "node" "/usr/bin/npm" "install" "fibers"
npm ERR! cwd /home/root
npm ERR! node -v v0.4.12
npm ERR! npm -v 1.0.106
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/root/npm-debug.log
npm not ok
root@beaglebone:~# npm owner ls fibers
laverdet <marcel.npm@laverdet.com>

I guess I'll mail laverdet. Anyone seen this - or fixed it.

Paul

--
Job Board: http://jobs.nodejs.org/
Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
You received this message because you are subscribed to the Google
Groups "nodejs" group.
To post to this group, send email to nodejs@googlegroups.com
To unsubscribe from this group, send email to
nodejs+unsubscribe@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/nodejs?hl=en?hl=en
reply

Search Discussions

13 responses

  • Ben Noordhuis at May 9, 2012 at 1:29 pm

    On Wed, May 9, 2012 at 11:52 AM, paul_tanner wrote:
    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present.  Installed
    that OK.

    Then installed inotify  ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    cc  -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    make[1]: *** [libcoro.o] Error 1
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    make: *** [/home/root/node_modules/fibers/src/coroutine.so] Error 2
    npm ERR! error installing fibers@0.5.1 Error: fibers@0.5.1 install:
    `make clean all`
    npm ERR! error installing fibers@0.5.1 `sh "-c" "make clean all"`
    failed with 2
    npm ERR! error installing fibers@0.5.1     at ChildProcess.<anonymous>
    (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
    npm ERR! error installing fibers@0.5.1     at ChildProcess.emit
    (events.js:67:17)
    npm ERR! error installing fibers@0.5.1     at ChildProcess.onexit
    (child_process.js:192:12)
    npm ERR! fibers@0.5.1 install: `make clean all`
    npm ERR! `sh "-c" "make clean all"` failed with 2
    npm ERR!
    npm ERR! Failed at the fibers@0.5.1 install script.
    npm ERR! This is most likely a problem with the fibers package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     make clean all
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls fibers
    npm ERR! There is likely additional logging output above.
    npm ERR!
    npm ERR! System Linux 3.2.5+
    npm ERR! command "node" "/usr/bin/npm" "install" "fibers"
    npm ERR! cwd /home/root
    npm ERR! node -v v0.4.12
    npm ERR! npm -v 1.0.106
    npm ERR! code ELIFECYCLE
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/root/npm-debug.log
    npm not ok
    root@beaglebone:~# npm owner ls fibers
    laverdet <marcel.npm@laverdet.com>

    I guess I'll mail laverdet. Anyone seen this - or fixed it.

    Paul
    I work at Cloud9 (not involved in IDE development, though). To the
    best of my knowledge, Cloud9 IDE uses neither node-fibers nor any
    inotify modules and never has. Quick grepping through the source tree
    seems to confirm that.

    Is the hello world example you mention the one from the nodejs.org
    home page? That should work out of the box.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Paul Tanner at May 9, 2012 at 1:48 pm
    Hi Ben,

    Thx. Actually I get these errors with any node file I try to run.
    I can run simple stuff like hello world server from the bone's linux
    command line. The errors only happen when I try to run from cloud9.
    Additionally, I have now tried to load other node modules so I can do
    more significant stuff. So far I have found that several do not
    install (lots of build errors)
    Something is not right with this distrbution.

    Regards, Paul
    At 02:29 PM 5/9/2012, you wrote:
    On Wed, May 9, 2012 at 11:52 AM, paul_tanner wrote:
    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present. Installed
    that OK.

    Then installed inotify ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    make[1]: *** [libcoro.o] Error 1
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    make: *** [/home/root/node_modules/fibers/src/coroutine.so] Error 2
    npm ERR! error installing fibers@0.5.1 Error: fibers@0.5.1 install:
    `make clean all`
    npm ERR! error installing fibers@0.5.1 `sh "-c" "make clean all"`
    failed with 2
    npm ERR! error installing fibers@0.5.1 at ChildProcess.<anonymous>
    (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
    npm ERR! error installing fibers@0.5.1 at ChildProcess.emit
    (events.js:67:17)
    npm ERR! error installing fibers@0.5.1 at ChildProcess.onexit
    (child_process.js:192:12)
    npm ERR! fibers@0.5.1 install: `make clean all`
    npm ERR! `sh "-c" "make clean all"` failed with 2
    npm ERR!
    npm ERR! Failed at the fibers@0.5.1 install script.
    npm ERR! This is most likely a problem with the fibers package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! make clean all
    npm ERR! You can get their info via:
    npm ERR! npm owner ls fibers
    npm ERR! There is likely additional logging output above.
    npm ERR!
    npm ERR! System Linux 3.2.5+
    npm ERR! command "node" "/usr/bin/npm" "install" "fibers"
    npm ERR! cwd /home/root
    npm ERR! node -v v0.4.12
    npm ERR! npm -v 1.0.106
    npm ERR! code ELIFECYCLE
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/root/npm-debug.log
    npm not ok
    root@beaglebone:~# npm owner ls fibers
    laverdet <marcel.npm@laverdet.com>

    I guess I'll mail laverdet. Anyone seen this - or fixed it.

    Paul
    I work at Cloud9 (not involved in IDE development, though). To the
    best of my knowledge, Cloud9 IDE uses neither node-fibers nor any
    inotify modules and never has. Quick grepping through the source tree
    seems to confirm that.

    Is the hello world example you mention the one from the nodejs.org
    home page? That should work out of the box.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    Paul Tanner - Virtual Technologies - http://www.virtual-techno.com
    Tel: +44 1494 581979 Mob: +44 7973 223239 mailto:paul@virtual-techno.com

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Jorge at May 9, 2012 at 3:01 pm

    On May 9, 2012, at 11:52 AM, paul_tanner wrote:

    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present. Installed
    that OK.

    Then installed inotify ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    Neither -m32 nor -minline-all-stringops are valid gcc options for ARM (they're ok for i386 and x86-64), see http://gcc.gnu.org/onlinedocs/gcc-4.7.0/gcc.pdf page 15-17
    --
    Jorge.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Paul Tanner at May 9, 2012 at 4:28 pm
    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual
    way. There must be a separate version or switch option for
    installation on ARM.

    More searching needed. There are several working node modules (eg
    http) in the distribution. The question is how were they installed?

    Paul
    At 04:01 PM 5/9/2012, you wrote:
    On May 9, 2012, at 11:52 AM, paul_tanner wrote:

    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present. Installed
    that OK.

    Then installed inotify ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    Neither -m32 nor -minline-all-stringops are valid gcc options for
    ARM (they're ok for i386 and x86-64), see
    http://gcc.gnu.org/onlinedocs/gcc-4.7.0/gcc.pdf page 15-17
    --
    Jorge.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    Paul Tanner - Virtual Technologies - http://www.virtual-techno.com
    Tel: +44 1494 581979 Mob: +44 7973 223239 mailto:paul@virtual-techno.com

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Tim Caswell at May 9, 2012 at 4:37 pm
    The http module is baked into the node executable. Npm has nothing to do
    with that one. Also any module can be installed without npm if you put the
    right files in the right places. For most this means copying the source
    tree to a folder in node_modules.
    On Wed, May 9, 2012 at 10:35 AM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual way. There
    must be a separate version or switch option for installation on ARM.

    More searching needed. There are several working node modules (eg http)
    in the distribution. The question is how were they installed?

    Paul

    At 04:01 PM 5/9/2012, you wrote:
    On May 9, 2012, at 11:52 AM, paul_tanner wrote:

    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present. Installed
    that OK.

    Then installed inotify ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/**fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/**fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/**fibers/src'
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    Neither -m32 nor -minline-all-stringops are valid gcc options for ARM
    (they're ok for i386 and x86-64), see http://gcc.gnu.org/onlinedocs/**
    gcc-4.7.0/gcc.pdf <http://gcc.gnu.org/onlinedocs/gcc-4.7.0/gcc.pdf> page
    15-17
    --
    Jorge.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/**node/wiki/Mailing-List-**
    Posting-Guidelines<https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines>
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@**googlegroups.com<nodejs%2Bunsubscribe@googlegroups.com>
    For more options, visit this group at
    http://groups.google.com/**group/nodejs?hl=en?hl=en<http://groups.google.com/group/nodejs?hl=en?hl=en>
    Paul Tanner - Virtual Technologies - http://www.virtual-techno.com
    Tel: +44 1494 581979 Mob: +44 7973 223239 mailto:paul@virtual-techno.com
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/**node/wiki/Mailing-List-**
    Posting-Guidelines<https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines>
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@**googlegroups.com<nodejs%2Bunsubscribe@googlegroups.com>
    For more options, visit this group at
    http://groups.google.com/**group/nodejs?hl=en?hl=en<http://groups.google.com/group/nodejs?hl=en?hl=en>
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Jorge at May 9, 2012 at 5:57 pm

    On May 9, 2012, at 5:35 PM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual way. There must be a separate version or switch option for installation on ARM.

    More searching needed. There are several working node modules (eg http) in the distribution. The question is how were they installed?

    Paul
    Hi Paul,

    I think libcoro can't run on an ARM, but you should better ask Marcel Laverdet (https://github.com/laverdet/node-fibers), or perhaps Marc Lehmann (http://software.schmorp.de/pkg/libcoro.html)
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o libcoro.o libcoro/coro.c

    The built-in modules come prebuilt with node so there's no need to "make" them.

    Could you try to install threads_a_gogo <https://github.com/xk/node-threads-a-gogo/> and tell me how it goes ?

    npm install threads_a_gogo

    And what this gives:

    node ./node_modules/threads_a_gogo/test/test01_loop_as_fast_as_possible.js 1

    ?
    --
    Jorge.
    github.com/xk/
    @jorgechamorro

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Marcel Laverdet at May 9, 2012 at 7:18 pm
    libcoro runs fine on ARM, but you do need to use the pthread_cond_wait
    version by passing -DCORO_PTHREAD. There is a check for this in the
    Makefile (and new gyp file) but there hasn't been strong testing there.
    On Wed, May 9, 2012 at 12:57 PM, Jorge wrote:
    On May 9, 2012, at 5:35 PM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual way.
    There must be a separate version or switch option for installation on ARM.
    More searching needed. There are several working node modules (eg http)
    in the distribution. The question is how were they installed?
    Paul
    Hi Paul,

    I think libcoro can't run on an ARM, but you should better ask Marcel
    Laverdet (https://github.com/laverdet/node-fibers), or perhaps Marc
    Lehmann (http://software.schmorp.de/pkg/libcoro.html)
    cc -Wall -Wno-deprecated-declarations -I/usr/include
    -I/usr/include/node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT
    -fPIC -c -o libcoro.o libcoro/coro.c


    The built-in modules come prebuilt with node so there's no need to "make"
    them.

    Could you try to install threads_a_gogo <
    https://github.com/xk/node-threads-a-gogo/> and tell me how it goes ?

    npm install threads_a_gogo

    And what this gives:

    node ./node_modules/threads_a_gogo/test/test01_loop_as_fast_as_possible.js
    1

    ?
    --
    Jorge.
    github.com/xk/
    @jorgechamorro

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Jorge at May 9, 2012 at 7:29 pm
    @Marcel Cool! @Paul what does `cc -v` give you ?

    On May 9, 2012, at 9:18 PM, Marcel Laverdet wrote:

    libcoro runs fine on ARM, but you do need to use the pthread_cond_wait version by passing -DCORO_PTHREAD. There is a check for this in the Makefile (and new gyp file) but there hasn't been strong testing there.

    On Wed, May 9, 2012 at 12:57 PM, Jorge wrote:
    On May 9, 2012, at 5:35 PM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual way. There must be a separate version or switch option for installation on ARM.

    More searching needed. There are several working node modules (eg http) in the distribution. The question is how were they installed?

    Paul
    Hi Paul,

    I think libcoro can't run on an ARM, but you should better ask Marcel Laverdet (https://github.com/laverdet/node-fibers), or perhaps Marc Lehmann (http://software.schmorp.de/pkg/libcoro.html)
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o libcoro.o libcoro/coro.c

    The built-in modules come prebuilt with node so there's no need to "make" them.

    Could you try to install threads_a_gogo <https://github.com/xk/node-threads-a-gogo/> and tell me how it goes ?

    npm install threads_a_gogo

    And what this gives:

    node ./node_modules/threads_a_gogo/test/test01_loop_as_fast_as_possible.js 1

    ?
    --
    Jorge.
    github.com/xk/
    @jorgechamorro
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Marcel Laverdet at May 9, 2012 at 7:45 pm
    gcc version shouldn't matter. The pthread version of libcoro will run on
    anything with POSIX-pthreads, it's a very very robust implementation.

    That's not to say that node-fibers will run on everything.. the build
    process will need to accomodate that. I got access to a beaglebone and
    tried to get the latest version of node running on it but didn't get very
    far before moving on to other things.
    On Wed, May 9, 2012 at 2:29 PM, Jorge wrote:

    @Marcel Cool! @Paul what does `cc -v` give you ?

    On May 9, 2012, at 9:18 PM, Marcel Laverdet wrote:

    libcoro runs fine on ARM, but you do need to use the pthread_cond_wait
    version by passing -DCORO_PTHREAD. There is a check for this in the
    Makefile (and new gyp file) but there hasn't been strong testing there.
    On Wed, May 9, 2012 at 12:57 PM, Jorge wrote:
    On May 9, 2012, at 5:35 PM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual way.
    There must be a separate version or switch option for installation on ARM.
    More searching needed. There are several working node modules (eg
    http) in the distribution. The question is how were they installed?
    Paul
    Hi Paul,

    I think libcoro can't run on an ARM, but you should better ask Marcel
    Laverdet (https://github.com/laverdet/node-fibers), or perhaps Marc
    Lehmann (http://software.schmorp.de/pkg/libcoro.html)
    cc -Wall -Wno-deprecated-declarations -I/usr/include
    -I/usr/include/node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT
    -fPIC -c -o libcoro.o libcoro/coro.c

    The built-in modules come prebuilt with node so there's no need to
    "make" them.
    Could you try to install threads_a_gogo <
    https://github.com/xk/node-threads-a-gogo/> and tell me how it goes ?
    npm install threads_a_gogo

    And what this gives:

    node
    ./node_modules/threads_a_gogo/test/test01_loop_as_fast_as_possible.js 1
    ?
    --
    Jorge.
    github.com/xk/
    @jorgechamorro
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Jorge at May 9, 2012 at 8:27 pm

    On May 9, 2012, at 9:45 PM, Marcel Laverdet wrote:

    gcc version shouldn't matter. The pthread version of libcoro will run on anything with POSIX-pthreads, it's a very very robust implementation.

    That's not to say that node-fibers will run on everything.. the build process will need to accomodate that. I got access to a beaglebone and tried to get the latest version of node running on it but didn't get very far before moving on to other things.
    but isn't it complaining about the -m32 and the -minline-all-stringops GCC (i386) options ?

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Marcel Laverdet at May 9, 2012 at 10:56 pm
    Oh yeah, that's true. I remember when we got this working on a beaglebone
    we just left out -m32 altogether and did -march=arm.

    As for my beaglebone I'm crazy and installed Gentoo on it, so this is my cc
    -v output ;)

    bone ~ # cc -v
    Using built-in specs.
    COLLECT_GCC=/usr/armv7a-unknown-linux-gnueabi/gcc-bin/4.5.3/gcc
    COLLECT_LTO_WRAPPER=/usr/libexec/gcc/armv7a-unknown-linux-gnueabi/4.5.3/lto-wrapper
    Target: armv7a-unknown-linux-gnueabi
    Configured with:
    /var/tmp/portage/sys-devel/gcc-4.5.3-r2/work/gcc-4.5.3/configure
    --prefix=/usr --bindir=/usr/armv7a-unknown-linux-gnueabi/gcc-bin/4.5.3
    --includedir=/usr/lib/gcc/armv7a-unknown-linux-gnueabi/4.5.3/include
    --datadir=/usr/share/gcc-data/armv7a-unknown-linux-gnueabi/4.5.3
    --mandir=/usr/share/gcc-data/armv7a-unknown-linux-gnueabi/4.5.3/man
    --infodir=/usr/share/gcc-data/armv7a-unknown-linux-gnueabi/4.5.3/info
    --with-gxx-include-dir=/usr/lib/gcc/armv7a-unknown-linux-gnueabi/4.5.3/include/g++-v4
    --host=armv7a-unknown-linux-gnueabi --build=armv7a-unknown-linux-gnueabi
    --disable-altivec --disable-fixed-point --without-ppl --without-cloog
    --disable-lto --enable-nls --without-included-gettext --with-system-zlib
    --disable-werror --enable-secureplt --disable-multilib --enable-libmudflap
    --disable-libssp --enable-libgomp
    --with-python-dir=/share/gcc-data/armv7a-unknown-linux-gnueabi/4.5.3/python
    --enable-checking=release --disable-libgcj --with-arch=armv7-a
    --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix
    --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=
    http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.5.3-r2 p1.1, pie-0.4.7'
    Thread model: posix
    gcc version 4.5.3 (Gentoo 4.5.3-r2 p1.1, pie-0.4.7)
    On Wed, May 9, 2012 at 3:26 PM, Jorge wrote:
    On May 9, 2012, at 9:45 PM, Marcel Laverdet wrote:

    gcc version shouldn't matter. The pthread version of libcoro will run on
    anything with POSIX-pthreads, it's a very very robust implementation.
    That's not to say that node-fibers will run on everything.. the build
    process will need to accomodate that. I got access to a beaglebone and
    tried to get the latest version of node running on it but didn't get very
    far before moving on to other things.

    but isn't it complaining about the -m32 and the -minline-all-stringops GCC
    (i386) options ?

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Paul Tanner at May 10, 2012 at 8:11 am
    Thx Marcel

    The distro: Angstrom v2012.01-core - Kernel 3.2.5+

    cc -v
    root@beaglebone:~# cc -v
    Using built-in specs.
    COLLECT_GCC=cc
    COLLECT_LTO_WRAPPER=/usr/libexec/gcc/arm-angstrom-linux-gnueabi/4.5.4/lto-wrapper
    Target: arm-angstrom-linux-gnueabi
    Configured with:
    /OE/tentacle/build/tmp-angstrom_2010_x-eglibc/work-shared/gcc-4.5-r45+svnr181733/gcc-4_5-branch/configure
    --build=x86_64-linux --host=arm-angstrom-linux-gnueabi
    --target=arm-angstrom-linux-gnueabi --prefix=/usr --exec_prefix=/usr
    --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/libexec
    --datadir=/usr/share --sysconfdir=/etc --sharedstatedir=/com
    --localstatedir=/var --libdir=/usr/lib --includedir=/usr/include
    --oldincludedir=/usr/include --infodir=/usr/share/info
    --mandir=/usr/share/man --disable-silent-rules
    --disable-dependency-tracking
    --with-libtool-sysroot=/OE/tentacle/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard
    --with-gnu-ld --enable-shared --enable-languages=c,c++
    --enable-threads=posix --disable-multilib --enable-c99
    --enable-long-long --enable-symvers=gnu --enable-libstdcxx-pch
    --program-prefix=arm-angstrom-linux-gnueabi- --enable-target-optspace
    --enable-lto --enable-libssp --disable-bootstrap --disable-libgomp
    --disable-libmudflap --with-linker-hash-style=gnu --with-ppl=no
    --with-cloog=no --enable-cheaders=c_global
    --with-local-prefix=/OE/tentacle/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr
    --with-gxx-include-dir=/usr/include/c++/ --enable-nls --enable-__cxa_atexit
    Thread model: posix
    gcc version 4.5.4 20111126 (prerelease) (GCC)

    Paul
    At 08:29 PM 5/9/2012, you wrote:
    @Marcel Cool! @Paul what does `cc -v` give you ?

    On May 9, 2012, at 9:18 PM, Marcel Laverdet wrote:

    libcoro runs fine on ARM, but you do need to use the
    pthread_cond_wait version by passing -DCORO_PTHREAD. There is a
    check for this in the Makefile (and new gyp file) but there hasn't
    been strong testing there.
    On Wed, May 9, 2012 at 12:57 PM, Jorge wrote:
    On May 9, 2012, at 5:35 PM, Paul Tanner wrote:

    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual
    way. There must be a separate version or switch option for
    installation on ARM.
    More searching needed. There are several working node modules
    (eg http) in the distribution. The question is how were they installed?
    Paul
    Hi Paul,

    I think libcoro can't run on an ARM, but you should better ask
    Marcel Laverdet (https://github.com/laverdet/node-fibers), or
    perhaps Marc Lehmann (http://software.schmorp.de/pkg/libcoro.html)
    cc -Wall -Wno-deprecated-declarations -I/usr/include
    -I/usr/include/node -g -O3 -minline-all-stringops -m32
    -DCORO_UCONTEXT -fPIC -c -o libcoro.o libcoro/coro.c

    The built-in modules come prebuilt with node so there's no need
    to "make" them.
    Could you try to install threads_a_gogo
    <https://github.com/xk/node-threads-a-gogo/> and tell me how it goes ?
    npm install threads_a_gogo

    And what this gives:

    node
    ./node_modules/threads_a_gogo/test/test01_loop_as_fast_as_possible.js 1
    ?
    --
    Jorge.
    github.com/xk/
    @jorgechamorro
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    Paul Tanner - Virtual Technologies - http://www.virtual-techno.com
    Tel: +44 1494 581979 Mob: +44 7973 223239 mailto:paul@virtual-techno.com

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
  • Paul Tanner at May 9, 2012 at 6:26 pm
    Thx Jorge

    Evidently I was wrong to go ahead and install npm in the usual
    way. There must be a separate version or switch option for
    installation on ARM.

    ** or each module has been provided with an ARM version **

    More searching needed. There are several working node modules (eg
    http) in the distribution. The question is how were they installed?
    ** were they the generic versions? **



    Paul
    At 04:01 PM 5/9/2012, you wrote:
    On May 9, 2012, at 11:52 AM, paul_tanner wrote:

    Hi,

    Just got my beaglebone from farnell and hoping to start work with
    nodejs on it.

    It shipped with v0.4.12 and the Cloud9 IDE.

    On running the standard hello world script it thows errors to the
    effect that npm modules inotify and fibers were not installed.
    Presumably these are required by the IDE.

    So I tried npm install and found that npm was not present. Installed
    that OK.

    Then installed inotify ok

    The attempt to install fibers failed as follows:

    root@beaglebone:~# npm install fibers
    fibers@0.5.1 install /home/root/node_modules/fibers
    make clean all
    make -C src clean
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    rm -f fibers.node libcoro.o coroutine.so
    rm -f -r *.dSYM
    make[1]: Leaving directory `/home/root/node_modules/fibers/src'
    rm -f -r man
    make -C src coroutine.so
    make[1]: Entering directory `/home/root/node_modules/fibers/src'
    cc -Wall -Wno-deprecated-declarations -I/usr/include -I/usr/include/
    node -g -O3 -minline-all-stringops -m32 -DCORO_UCONTEXT -fPIC -c -o
    libcoro.o libcoro/coro.c
    cc1: error: unrecognized command line option "-minline-all-stringops"
    cc1: error: unrecognized command line option "-m32"
    Neither -m32 nor -minline-all-stringops are valid gcc options for
    ARM (they're ok for i386 and x86-64), see
    http://gcc.gnu.org/onlinedocs/gcc-4.7.0/gcc.pdf page 15-17
    --
    Jorge.

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines:
    https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en
    Paul Tanner - Virtual Technologies - http://www.virtual-techno.com
    Tel: +44 1494 581979 Mob: +44 7973 223239 mailto:paul@virtual-techno.com

    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en

Related Discussions

Discussion Navigation
viewthread | post