FAQ

[mongodb-user] fsync error on startup with v2.0.2

Victor Cassen
Feb 27, 2012 at 8:22 pm
Hi,

I'm in the process of upgrading from v1.8.2 to v2.0.2 on a Linux (Centos
6.2) machine, using a --dbpath to a mounted (ie, non-local) directory. I'm
getting an fsync error during startup.

Using this command:

mongod --dbpath /mnt/price1/vcassen/mongo_dbs

I'm getting the following error message on startup (note the error on the
last line):

Mon Feb 27 12:10:27 [initandlisten] MongoDB starting : pid=28791 port=27017
dbpath=/mnt/price1/vcassen/mongo_dbs 64-bit host=clutch.systemsbiology.net
Mon Feb 27 12:10:27 [initandlisten] db version v2.0.2, pdfile version 4.5
Mon Feb 27 12:10:27 [initandlisten] git version:
514b122d308928517f5841888ceaa4246a7f18e3
Mon Feb 27 12:10:27 [initandlisten] build info: Linux
bs-linux64.10gen.cc2.6.21.7-2.ec2.v1.2.fc8xen #1 SMP Fri Nov 20
17:48:28 EST 2009 x86_64
BOOST_LIB_VERSION=1_41
Mon Feb 27 12:10:27 [initandlisten] options: { dbpath:
"/mnt/price1/vcassen/mongo_dbs", nojournal: true }
Mon Feb 27 12:10:27 [initandlisten] Assertion: 13651:Couldn't fsync
directory '/mnt/price1/vcassen/mongo_dbs': errno:22 Invalid argument


The same command (with the same startup directory) worked under v1.8.2, and
the same command (using v2.0.2) works on a local (non-NFS mounted)
directory. Adding or omitting --nojournal does not seem to have any
effect. I've checked obvious things such as path correctness and
permissions.

I've read in this
thread<http://groups.google.com/group/mongodb-user/browse_thread/thread/18838e3346f5dfac/f6fae53020cb70cf?lnk=gst&q=fsync+invalid+argument#f6fae53020cb70cf>that
there may be issues with the CIFS/SAMBA client, but I don't have much
real ability to change that. I'm very curious though as to why v1.8.2 had
no problem starting up but v2.0.2 bails.

Any help or pointers to help would be greatly appreciated.

Thanks in Advance,
-Victor

--
-Victor Cassen
------------------------------------------------------------
Let's play motorcycle tag! CRASH! You're it!

--
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To post to this group, send email to mongodb-user@googlegroups.com.
To unsubscribe from this group, send email to mongodb-user+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/mongodb-user?hl=en.
reply

Search Discussions

1 response

  • Marc at Feb 28, 2012 at 12:17 am
    Unfortunately, the short answer is that Mongo never officially
    supported NFS.
    http://www.mongodb.org/display/DOCS/NFS
    MongoDB's compatibility with NFS was not taken into consideration for
    the 2.0 release, so it is difficult to say exactly what changed
    between versions to make it stop working in your application. There
    has been a Jira ticket opened to allow files to be stored on a NFS
    mount, but unfortunately it is not in our current feature roadmap:
    https://jira.mongodb.org/browse/SERVER-3034

    There are some recommendations for how to set up Mongo Optimally on a
    Linux system on our "Production Notes" page:
    http://www.mongodb.org/display/DOCS/Production+Notes#ProductionNotes-Linux

    I apologize for the inconvenience, and I wish I had a more
    satisfactory answer for you. The silver lining is that it looks as
    though there are some possible work-arounds in the other discussion
    that you linked to. The official recommendation is to switch to a
    different file system as per the Production Notes.

    --
    You received this message because you are subscribed to the Google Groups "mongodb-user" group.
    To post to this group, send email to mongodb-user@googlegroups.com.
    To unsubscribe from this group, send email to mongodb-user+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/mongodb-user?hl=en.

Related Discussions

Discussion Navigation
viewthread | post

2 users in discussion

Marc: 1 post Victor Cassen: 1 post