FAQ

[graylog2] Unable to resolve: Warnings Please Help and Suggest Warning! It seems like you have no active Graylog2 node running.

Priyaank Choubey
Aug 27, 2012 at 11:32 am
Hi,

I installed and configured graylog2-server and graylog-web-interface with
following configurations.

*Graylog2-Server Configuration*

*graylog2.conf*

is_master = true

syslog_listen_port = 514 (bind with syslog-ng)
syslog_protocol = udp

elasticsearch_url = http://localhost:9200/
elasticsearch_index_name = graylog2

mongodb_useauth = false
mongodb_user =
mongodb_password =
mongodb_host = localhost
mongodb_database = graylog2
mongodb_port = 27017

*Graylog2-web-interface Configurations *

*mongoid.yml*

production:
host: localhost
port: 27017
username:
password:
database: graylog2

development:
host: localhost
database: graylog2

test:
host: localhost
database: graylog2

*indexer.yml*

production:
url: http://localhost:9200/
index_name: graylog2

Properly Created Elastic Search cluster Graylog2 with index graylog2 and
graylog2_recent and created proper mapping for graylog2 index.
*
*
*Getting *
Error! : Syntax error in search query or empty index
Warning : It seems like you have no active Graylog2 node running.
Error in opening Dashboard page (as no data present in graylog2_recent)

I an running my graylog-web-interface on production env.

*Problem :*
*1) Please tell me if my logs and graph is updating then why this warning
messages are coming . Am i missing some configuration above ?*
*2) Since i haven't mentioned anything like graylog2_recent in my elastic
search settings then why dashboard require that and showing error even
after creating the index. *
*3) why I am unable to see any recent messages, to see messages and log i
need to go for all messages tab.*
*
*
*Thanks in Advance for your valuable suggestions.*
reply

Search Discussions

7 responses

  • Pric at Aug 27, 2012 at 12:43 pm
    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface with
    following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2 and
    graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this warning
    messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my elastic
    search settings then why dashboard require that and showing error even
    after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and log i
    need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*
  • Deepak at Aug 28, 2012 at 10:34 am
    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?
    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface with
    following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2 and
    graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and log
    i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*
  • Ankur agarwal at Aug 28, 2012 at 10:03 pm
    +1
    On Mon, Aug 27, 2012 at 11:50 PM, Deepak wrote:

    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?

    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface
    with following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2 and
    graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and log
    i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*

    --
    Cheers !!!
    Ankur Agarwal
  • Pric at Aug 29, 2012 at 6:45 am
    Hi Deepak,

    Firstly Check Your graylog2-web-interface Version
    Go to Settings -> Version - >
    Previously mine graylog2-web-interface version was ( Graylog2 version
    (0.9.7) ) that is unstable.
    So i downloaded Graylog2 version (0.9.6p1) specifically and done same
    configuration and it worked properly.

    Hopes this might help you out

    On Monday, August 27, 2012 11:50:59 PM UTC+5:30, Deepak wrote:

    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?
    e same configuration
    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface
    with following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2 and
    graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and log
    i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*
  • Sam Culley at Aug 29, 2012 at 3:34 pm
    Hi,

    Could you please post your configuration. I too am having the same problem?
    On 29 August 2012 07:45, pric wrote:

    Hi Deepak,

    Firstly Check Your graylog2-web-interface Version
    Go to Settings -> Version - >
    Previously mine graylog2-web-interface version was ( Graylog2 version
    (0.9.7) ) that is unstable.
    So i downloaded Graylog2 version (0.9.6p1) specifically and done same
    configuration and it worked properly.

    Hopes this might help you out

    On Monday, August 27, 2012 11:50:59 PM UTC+5:30, Deepak wrote:

    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?
    e same configuration
    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface
    with following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2
    and graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and
    log i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*
  • Pric at Aug 30, 2012 at 5:16 am
    Hi Sam,

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (I bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/ (default)
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Create Elastic Search cluster Graylog2 with index graylog2 and
    graylog2_recent and created proper mapping for graylog2 index.


    On Wednesday, August 29, 2012 9:04:52 PM UTC+5:30, Sam Culley wrote:

    Hi,

    Could you please post your configuration. I too am having the same problem?
    On 29 August 2012 07:45, pric <choubey...@gmail.com <javascript:>> wrote:

    Hi Deepak,

    Firstly Check Your graylog2-web-interface Version
    Go to Settings -> Version - >
    Previously mine graylog2-web-interface version was ( Graylog2 version
    (0.9.7) ) that is unstable.
    So i downloaded Graylog2 version (0.9.6p1) specifically and done same
    configuration and it worked properly.

    Hopes this might help you out

    On Monday, August 27, 2012 11:50:59 PM UTC+5:30, Deepak wrote:

    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?
    e same configuration
    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface
    with following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2
    and graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and
    log i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*
  • Deepak Jha at Aug 29, 2012 at 4:07 pm
    Hi Pric,
    Thanks for your reply. I was able to fix it.
    The issue was that I was running it in development mode and the mongodb
    pointer in indexer.yml and mongoid.yml were different. Now both of them are
    pointing to graylog2. Still I am not able to see the data, everything seems
    to be running fine. Not sure where is the issue.
    On Tue, Aug 28, 2012 at 11:45 PM, pric wrote:

    Hi Deepak,

    Firstly Check Your graylog2-web-interface Version
    Go to Settings -> Version - >
    Previously mine graylog2-web-interface version was ( Graylog2 version
    (0.9.7) ) that is unstable.
    So i downloaded Graylog2 version (0.9.6p1) specifically and done same
    configuration and it worked properly.

    Hopes this might help you out

    On Monday, August 27, 2012 11:50:59 PM UTC+5:30, Deepak wrote:

    Hi Pric,
    I am also facing this issue. May I know how did you fix it ?
    e same configuration
    On Monday, August 27, 2012 5:43:24 AM UTC-7, pric wrote:

    Sorry, for the trouble, I resolved this issues .. !!
    Thanks
    On Monday, August 27, 2012 5:01:01 PM UTC+5:30, pric wrote:

    Hi,

    I installed and configured graylog2-server and graylog-web-interface
    with following configurations.

    *Graylog2-Server Configuration*

    *graylog2.conf*

    is_master = true

    syslog_listen_port = 514 (bind with syslog-ng)
    syslog_protocol = udp

    elasticsearch_url = http://localhost:9200/
    elasticsearch_index_name = graylog2

    mongodb_useauth = false
    mongodb_user =
    mongodb_password =
    mongodb_host = localhost
    mongodb_database = graylog2
    mongodb_port = 27017

    *Graylog2-web-interface Configurations *

    *mongoid.yml*

    production:
    host: localhost
    port: 27017
    username:
    password:
    database: graylog2

    development:
    host: localhost
    database: graylog2

    test:
    host: localhost
    database: graylog2

    *indexer.yml*

    production:
    url: http://localhost:9200/
    index_name: graylog2

    Properly Created Elastic Search cluster Graylog2 with index graylog2
    and graylog2_recent and created proper mapping for graylog2 index.
    *
    *
    *Getting *
    Error! : Syntax error in search query or empty index
    Warning : It seems like you have no active Graylog2 node running.
    Error in opening Dashboard page (as no data present in graylog2_recent)

    I an running my graylog-web-interface on production env.

    *Problem :*
    *1) Please tell me if my logs and graph is updating then why this
    warning messages are coming . Am i missing some configuration above ?*
    *2) Since i haven't mentioned anything like graylog2_recent in my
    elastic search settings then why dashboard require that and showing error
    even after creating the index. *
    *3) why I am unable to see any recent messages, to see messages and
    log i need to go for all messages tab.*
    *
    *
    *Thanks in Advance for your valuable suggestions.*

Related Discussions

Discussion Navigation
viewthread | post