FAQ
Hi,

I'm new to google appengine, so I have a basic question. I have
successfully completed the Java tutorial on the google appengine site using
maven. I have been able to succesfully run:
  - mvn clean install
and then
  - mvn appengine:devserver

It all looks good and works on localhost, but when I come to deploy it to
my real google site with:
  - mvn appengine:update
I get the following error:
WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/create?app_id=planshopcook&version=1.9.21&
400 Bad Request
Error when loading application configuration:Unable to assign value
'1.9.21' to attribute 'version':Value '1.9.21' for version does not match
expression '^(?:^(?!-)[a-z\d\-]{0,62}[a-z\d]$)$'

I checked the my google appengine dashboard and it is running 1.9.22
Ah ha! Ok, so I edit the POM.xml file from 1.9.21 to 1.9.22 in the
dependency and plugin:
         <dependency>
             <groupId>com.google.appengine</groupId>
             <artifactId>appengine-api-1.0-sdk</artifactId>
             <version>1.9.22</version>
         </dependency>

Now maven can't find
[WARNING] The POM for com.google.appengine:appengine-api-1.0-sdk:jar:1.9.22
is missing, no dependency information available
What am I missing here.... :-(

Thanks
Tim
P.s.Whole POM attached.

--
You received this message because you are subscribed to the Google Groups "Google App Engine" group.
To unsubscribe from this group and stop receiving emails from it, send an email to google-appengine+unsubscribe@googlegroups.com.
To post to this group, send email to google-appengine@googlegroups.com.
Visit this group at http://groups.google.com/group/google-appengine.
To view this discussion on the web visit https://groups.google.com/d/msgid/google-appengine/03953769-2179-47bd-902e-86dcd41aee71%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Patrice (Cloud Platform Support) at Jun 9, 2015 at 8:56 pm
    hey Tim!

    So, this error is actually pretty simple to resolve, even if it wasn't easy
    to find.

    In your pom, change the three places where you have "appengine.version",
    and change it for "appengine.sdk.version". Also keep it to 1.9.21, this is
    the proper one for now.

    Lemme know if that fixes your issue.

    Cheers!
    On Tuesday, June 9, 2015 at 4:05:48 PM UTC-4, TimN wrote:

    Hi,

    I'm new to google appengine, so I have a basic question. I have
    successfully completed the Java tutorial on the google appengine site using
    maven. I have been able to succesfully run:
    - mvn clean install
    and then
    - mvn appengine:devserver

    It all looks good and works on localhost, but when I come to deploy it to
    my real google site with:
    - mvn appengine:update
    I get the following error:
    WARNING: Error posting to URL:
    https://appengine.google.com/api/appversion/create?app_id=planshopcook&version=1.9.21&
    400 Bad Request
    Error when loading application configuration:Unable to assign value
    '1.9.21' to attribute 'version':Value '1.9.21' for version does not match
    expression '^(?:^(?!-)[a-z\d\-]{0,62}[a-z\d]$)$'

    I checked the my google appengine dashboard and it is running 1.9.22
    Ah ha! Ok, so I edit the POM.xml file from 1.9.21 to 1.9.22 in the
    dependency and plugin:
    <dependency>
    <groupId>com.google.appengine</groupId>
    <artifactId>appengine-api-1.0-sdk</artifactId>
    <version>1.9.22</version>
    </dependency>

    Now maven can't find
    [WARNING] The POM for
    com.google.appengine:appengine-api-1.0-sdk:jar:1.9.22 is missing, no
    dependency information available
    What am I missing here.... :-(

    Thanks
    Tim
    P.s.Whole POM attached.
    --
    You received this message because you are subscribed to the Google Groups "Google App Engine" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to google-appengine+unsubscribe@googlegroups.com.
    To post to this group, send email to google-appengine@googlegroups.com.
    Visit this group at http://groups.google.com/group/google-appengine.
    To view this discussion on the web visit https://groups.google.com/d/msgid/google-appengine/6de6c4a2-c0ea-4ba2-9fc7-df1d8ec16297%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • TimN at Jun 9, 2015 at 9:17 pm
    YES!!!!

    Thank you!! I've been bashing my head all evening - at least I learnt
    something about POM files :-)

    Thanks again!!
    Tim

    On Tuesday, June 9, 2015 at 9:56:16 PM UTC+1, Patrice (Cloud Platform
    Support) wrote:
    hey Tim!

    So, this error is actually pretty simple to resolve, even if it wasn't
    easy to find.

    In your pom, change the three places where you have "appengine.version",
    and change it for "appengine.sdk.version". Also keep it to 1.9.21, this is
    the proper one for now.

    Lemme know if that fixes your issue.

    Cheers!
    On Tuesday, June 9, 2015 at 4:05:48 PM UTC-4, TimN wrote:

    Hi,

    I'm new to google appengine, so I have a basic question. I have
    successfully completed the Java tutorial on the google appengine site using
    maven. I have been able to succesfully run:
    - mvn clean install
    and then
    - mvn appengine:devserver

    It all looks good and works on localhost, but when I come to deploy it to
    my real google site with:
    - mvn appengine:update
    I get the following error:
    WARNING: Error posting to URL:
    https://appengine.google.com/api/appversion/create?app_id=planshopcook&version=1.9.21&
    400 Bad Request
    Error when loading application configuration:Unable to assign value
    '1.9.21' to attribute 'version':Value '1.9.21' for version does not match
    expression '^(?:^(?!-)[a-z\d\-]{0,62}[a-z\d]$)$'

    I checked the my google appengine dashboard and it is running 1.9.22
    Ah ha! Ok, so I edit the POM.xml file from 1.9.21 to 1.9.22 in the
    dependency and plugin:
    <dependency>
    <groupId>com.google.appengine</groupId>
    <artifactId>appengine-api-1.0-sdk</artifactId>
    <version>1.9.22</version>
    </dependency>

    Now maven can't find
    [WARNING] The POM for
    com.google.appengine:appengine-api-1.0-sdk:jar:1.9.22 is missing, no
    dependency information available
    What am I missing here.... :-(

    Thanks
    Tim
    P.s.Whole POM attached.
    --
    You received this message because you are subscribed to the Google Groups "Google App Engine" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to google-appengine+unsubscribe@googlegroups.com.
    To post to this group, send email to google-appengine@googlegroups.com.
    Visit this group at http://groups.google.com/group/google-appengine.
    To view this discussion on the web visit https://groups.google.com/d/msgid/google-appengine/d70f7c2a-7393-434e-a56f-aff5a9f4ccf8%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Patrice (Cloud Platform Support) at Jun 9, 2015 at 9:43 pm
    Very welcome Tim.

    I can't take that much credit for finding it though, this was reported to
    our Issue Tracker recently and that's where I found the fix :)

    Happy coding!
    Cheers
    On Tuesday, June 9, 2015 at 5:17:19 PM UTC-4, TimN wrote:

    YES!!!!

    Thank you!! I've been bashing my head all evening - at least I learnt
    something about POM files :-)

    Thanks again!!
    Tim

    On Tuesday, June 9, 2015 at 9:56:16 PM UTC+1, Patrice (Cloud Platform
    Support) wrote:
    hey Tim!

    So, this error is actually pretty simple to resolve, even if it wasn't
    easy to find.

    In your pom, change the three places where you have "appengine.version",
    and change it for "appengine.sdk.version". Also keep it to 1.9.21, this is
    the proper one for now.

    Lemme know if that fixes your issue.

    Cheers!
    On Tuesday, June 9, 2015 at 4:05:48 PM UTC-4, TimN wrote:

    Hi,

    I'm new to google appengine, so I have a basic question. I have
    successfully completed the Java tutorial on the google appengine site using
    maven. I have been able to succesfully run:
    - mvn clean install
    and then
    - mvn appengine:devserver

    It all looks good and works on localhost, but when I come to deploy it
    to my real google site with:
    - mvn appengine:update
    I get the following error:
    WARNING: Error posting to URL:
    https://appengine.google.com/api/appversion/create?app_id=planshopcook&version=1.9.21&
    400 Bad Request
    Error when loading application configuration:Unable to assign value
    '1.9.21' to attribute 'version':Value '1.9.21' for version does not match
    expression '^(?:^(?!-)[a-z\d\-]{0,62}[a-z\d]$)$'

    I checked the my google appengine dashboard and it is running 1.9.22
    Ah ha! Ok, so I edit the POM.xml file from 1.9.21 to 1.9.22 in the
    dependency and plugin:
    <dependency>
    <groupId>com.google.appengine</groupId>
    <artifactId>appengine-api-1.0-sdk</artifactId>
    <version>1.9.22</version>
    </dependency>

    Now maven can't find
    [WARNING] The POM for
    com.google.appengine:appengine-api-1.0-sdk:jar:1.9.22 is missing, no
    dependency information available
    What am I missing here.... :-(

    Thanks
    Tim
    P.s.Whole POM attached.
    --
    You received this message because you are subscribed to the Google Groups "Google App Engine" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to google-appengine+unsubscribe@googlegroups.com.
    To post to this group, send email to google-appengine@googlegroups.com.
    Visit this group at http://groups.google.com/group/google-appengine.
    To view this discussion on the web visit https://groups.google.com/d/msgid/google-appengine/8a9e1fa4-d90a-490d-9a6c-a9b09c566cf3%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgoogle-appengine @
postedJun 9, '15 at 8:05p
activeJun 9, '15 at 9:43p
posts4
users2

People

Translate

site design / logo © 2017 Grokbase