FAQ

[ccw-users] Installing and running the labrepl environment for learning Clojure

Adam Getchell
Oct 18, 2011 at 7:56 am
From: http://dev.clojure.org/display/doc/Getting+Started+with+Eclipse+and+Counterclockwise

I'm at setting up labrepl. If I try to install Maven/m2e, I get:

Cannot complete the install because of a conflicting dependency.
Software being installed: Maven Integration for Eclipse (Required)
0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group
0.12.1.20110112-1712)
Software currently installed: Eclipse IDE for Java Developers
1.4.1.20110909-1818 (epp.package.java 1.4.1.20110909-1818)
Only one of the following can be installed at once:
Maven Integration for Eclipse 0.12.1.20110112-1712
(org.maven.ide.eclipse 0.12.1.20110112-1712)
Maven Integration for Eclipse 0.12.0.20101115-1102
(org.maven.ide.eclipse 0.12.0.20101115-1102)
This version of m2eclipse cannot be installed on top of the
already installed m2eclipse. Uninstall the previous version of
m2eclipse and try the install again. 1.0.0.20110607-2117
(org.maven.ide.eclipse 1.0.0.20110607-2117)
Maven Integration for Eclipse 0.10.2.20100623-1649
(org.maven.ide.eclipse 0.10.2.20100623-1649)
Maven Integration for Eclipse 0.10.0.20100209-0800
(org.maven.ide.eclipse 0.10.0.20100209-0800)
This version of m2eclipse cannot be installed on top of the
already installed m2eclipse. Uninstall the previous version of
m2eclipse and try the install again. 1.0.100.20110804-1717
(org.maven.ide.eclipse 1.0.100.20110804-1717)
Cannot satisfy dependency:
From: Eclipse IDE for Java Developers 1.4.1.20110909-1818
(epp.package.java 1.4.1.20110909-1818)
To: org.eclipse.epp.package.java.feature.feature.group
[1.4.1.20110909-1818]
Cannot satisfy dependency:
From: EPP Java Package 1.4.1.20110909-1818
(org.eclipse.epp.package.java.feature.feature.group
1.4.1.20110909-1818)
To: org.eclipse.m2e.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse 1.0.0.20110607-2117
(org.eclipse.m2e.feature.feature.group 1.0.0.20110607-2117)
To: bundle org.maven.ide.eclipse [1.0.0.20110607-2117]
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse 1.0.100.20110804-1717
(org.eclipse.m2e.feature.feature.group 1.0.100.20110804-1717)
To: bundle org.maven.ide.eclipse [1.0.100.20110804-1717]
Cannot satisfy dependency:
From: Maven Integration for Eclipse (Required)
0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group
0.12.1.20110112-1712)
To: org.maven.ide.eclipse [0.12.1.20110112-1712]

This is a brand new Eclipse install, I have the following packages:

Counterclockwise (Clojure plugin for Eclipse) 0.4.0.STABLE002
ccw.feature.feature.group Counterclockwise team
Eclipse EGit 1.1.0.201109151100-r org.eclipse.egit.feature.group
Eclipse EGit
Eclipse EGit - Source 1.1.0.201109151100-r
org.eclipse.egit.source.feature.group Eclipse EGit
Eclipse IDE for Java Developers 1.4.1.20110909-1818 epp.package.java
null
EGit Mylyn 1.1.0.201109151100-r org.eclipse.egit.mylyn.feature.group
Eclipse EGit
EGit Project Set Support 1.1.0.201109151100-r
org.eclipse.egit.psf.feature.group Eclipse EGit

Suggestions?

Thanks,

Adam Getchell

--
You received this message because you are subscribed to the Google Groups "counterclockwise-users" group.
To post to this group, send email to clojuredev-users@googlegroups.com.
To unsubscribe from this group, send email to clojuredev-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/clojuredev-users?hl=en.
reply

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post

1 user in discussion

Adam Getchell: 1 post