FAQ
Hello everyone;

I am getting timed out exception while trying to access Remote actors from
local machine.

My application.conf file for remote actors is

RemoteSys {
     akka {
         actor {
             provider = "akka.remote.RemoteActorRefProvider"
         }
         remote {
             transport = "akka.remote.netty.NettyRemoteTransport"
             netty {
                 hostname = "125.153.76.235"
                 port = 2552
             }
         }
     }
}

after deploying an application in remote machine i ran bootable class using
akka scripts,while doing so i dont get any error but it doesnt show that
remoteactor has been started.
Please help me in figuring out why actor system is not started in remote
machine.

Thanks;
raju


--
---
You received this message because you are subscribed to the Google Groups "Akka User List" group.
To post to this group, send email to akka-user@googlegroups.com.
To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
Visit this group at http://groups.google.com/group/akka-user?hl=en.

Search Discussions

  • √iktor Ҡlang at Dec 24, 2012 at 1:27 pm
    Hi Raju,

    Akka doesn't magically create Actorsystems on other machines.

    Please read the docs <http://akka.io/docs/> and FAQ <http://akka.io/faq/>

    Cheers,


    On Mon, Dec 24, 2012 at 1:40 PM, Raju Bishnoi wrote:

    Hello everyone;

    I am getting timed out exception while trying to access Remote actors from
    local machine.

    My application.conf file for remote actors is

    RemoteSys {
    akka {
    actor {
    provider = "akka.remote.RemoteActorRefProvider"
    }
    remote {
    transport = "akka.remote.netty.NettyRemoteTransport"
    netty {
    hostname = "125.153.76.235"
    port = 2552
    }
    }
    }
    }

    after deploying an application in remote machine i ran bootable class
    using akka scripts,while doing so i dont get any error but it doesnt show
    that remoteactor has been started.
    Please help me in figuring out why actor system is not started in remote
    machine.

    Thanks;
    raju


    --
    ---
    You received this message because you are subscribed to the Google Groups
    "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to
    akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.



    --
    Viktor Klang

    Director of Engineering
    Typesafe <http://www.typesafe.com/> - The software stack for applications
    that scale

    Twitter: @viktorklang

    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.
  • Raju Bishnoi at Dec 26, 2012 at 6:48 am
    Hi Viktor,

    Thanks for your response

    I deployed the Remote node jar file on server and seems working fine.

    Starting Akka...
    Running Akka 2.0.4
    Deploying file:/home/kutenda/Downloads/akka-2.0.4/deploy/RemoteNodeApp.jar
    Starting up org.akka.essentials.remotenode.RemoteNodeApplication
    Successfully started Akka

    But getting the error while running the local node file.

    [ERROR] [12/26/2012 12:10:09.544]
    [LocalNodeApp-akka.actor.default-dispatcher-2]
    [akka://LocalNodeApp/user/$a] sending to terminated ref breaks promises
    akka.pattern.AskTimeoutException: sending to terminated ref breaks promises
         at akka.pattern.AskSupport$class.ask(AskSupport.scala:76)
         at akka.pattern.package$.ask(package.scala:43)
         at akka.pattern.Patterns$.ask(Patterns.scala:41)
         at akka.pattern.Patterns.ask(Patterns.scala)
         at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:28)
         at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
         at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
         at akka.actor.Actor$class.apply(Actor.scala:318)
         at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
         at akka.actor.ActorCell.invoke(ActorCell.scala:626)
         at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
         at akka.dispatch.Mailbox.run(Mailbox.scala:179)
         at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
         at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
         at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
         at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
         at akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)

    Please tell me what is wrong with me. Reply me ASAP.

    Thanks
    Raju



    On Monday, 24 December 2012 18:57:18 UTC+5:30, √ wrote:

    Hi Raju,

    Akka doesn't magically create Actorsystems on other machines.

    Please read the docs <http://akka.io/docs/> and FAQ <http://akka.io/faq/>

    Cheers,



    On Mon, Dec 24, 2012 at 1:40 PM, Raju Bishnoi <rajubi...@gmail.com<javascript:>
    wrote:
    Hello everyone;

    I am getting timed out exception while trying to access Remote actors
    from local machine.

    My application.conf file for remote actors is

    RemoteSys {
    akka {
    actor {
    provider = "akka.remote.RemoteActorRefProvider"
    }
    remote {
    transport = "akka.remote.netty.NettyRemoteTransport"
    netty {
    hostname = "125.153.76.235"
    port = 2552
    }
    }
    }
    }

    after deploying an application in remote machine i ran bootable class
    using akka scripts,while doing so i dont get any error but it doesnt show
    that remoteactor has been started.
    Please help me in figuring out why actor system is not started in remote
    machine.

    Thanks;
    raju


    --
    ---
    You received this message because you are subscribed to the Google Groups
    "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    akka-user+...@googlegroups.com <javascript:>.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.



    --
    Viktor Klang

    Director of Engineering
    Typesafe <http://www.typesafe.com/> - The software stack for applications
    that scale

    Twitter: @viktorklang
    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.
  • Henrik Engström at Dec 26, 2012 at 10:06 am
    Hello Raju,
    Compare your code with this example to figure out what you are
    missing/doing incorrectly:
    https://github.com/akka/akka/tree/v2.1.0/akka-samples/akka-sample-remote
    HTH
    //Henrik

    On Wed, Dec 26, 2012 at 7:45 AM, Raju Bishnoi wrote:

    Hi Viktor,

    Thanks for your response

    I deployed the Remote node jar file on server and seems working fine.

    Starting Akka...
    Running Akka 2.0.4
    Deploying file:/home/kutenda/Downloads/akka-2.0.4/deploy/RemoteNodeApp.jar
    Starting up org.akka.essentials.remotenode.RemoteNodeApplication
    Successfully started Akka

    But getting the error while running the local node file.

    [ERROR] [12/26/2012 12:10:09.544]
    [LocalNodeApp-akka.actor.default-dispatcher-2]
    [akka://LocalNodeApp/user/$a] sending to terminated ref breaks promises
    akka.pattern.AskTimeoutException: sending to terminated ref breaks promises
    at akka.pattern.AskSupport$class.ask(AskSupport.scala:76)
    at akka.pattern.package$.ask(package.scala:43)
    at akka.pattern.Patterns$.ask(Patterns.scala:41)
    at akka.pattern.Patterns.ask(Patterns.scala)
    at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:28)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
    at akka.actor.Actor$class.apply(Actor.scala:318)
    at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
    at akka.actor.ActorCell.invoke(ActorCell.scala:626)
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
    at akka.dispatch.Mailbox.run(Mailbox.scala:179)
    at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
    at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
    at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
    at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
    at akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)

    Please tell me what is wrong with me. Reply me ASAP.

    Thanks
    Raju




    On Monday, 24 December 2012 18:57:18 UTC+5:30, √ wrote:

    Hi Raju,

    Akka doesn't magically create Actorsystems on other machines.

    Please read the docs <http://akka.io/docs/> and FAQ <http://akka.io/faq/>

    Cheers,


    On Mon, Dec 24, 2012 at 1:40 PM, Raju Bishnoi wrote:

    Hello everyone;

    I am getting timed out exception while trying to access Remote actors
    from local machine.

    My application.conf file for remote actors is

    RemoteSys {
    akka {
    actor {
    provider = "akka.remote.**RemoteActorRefProvider"
    }
    remote {
    transport = "akka.remote.netty.**NettyRemoteTransport"
    netty {
    hostname = "125.153.76.235"
    port = 2552
    }
    }
    }
    }

    after deploying an application in remote machine i ran bootable class
    using akka scripts,while doing so i dont get any error but it doesnt show
    that remoteactor has been started.
    Please help me in figuring out why actor system is not started in remote
    machine.

    Thanks;
    raju



    --
    Read the docs: http://akka.io/docs/
    Check the FAQ: http://akka.io/faq/
    Search the archives: https://groups.google.com/**
    group/akka-user <https://groups.google.com/group/akka-user>
    ---
    You received this message because you are subscribed to the Google
    Groups "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+...@**
    googlegroups.com.

    Visit this group at http://groups.google.com/**group/akka-user?hl=en<http://groups.google.com/group/akka-user?hl=en>
    .



    --
    Viktor Klang

    Director of Engineering
    Typesafe <http://www.typesafe.com/> - The software stack for
    applications that scale

    Twitter: @viktorklang

    --
    ---
    You received this message because you are subscribed to the Google Groups
    "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to
    akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.

    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.
  • Raju Bishnoi at Dec 26, 2012 at 10:51 am
    Hi,

    I am checking with AkkaEssential "AkkaRemotingExample" code.

    I am getting below error while run the jar on server

    Starting Akka...
    Running Akka 2.1.0
    Deploying file:/usr/share/akka-2.1.0/deploy/RemoteNodeApp.jar
    Exception in thread "main" com.typesafe.config.ConfigException$Missing: No
    configuration setting found for key 'RemoteSys'
         at com.typesafe.config.impl.SimpleConfig.findKey(SimpleConfig.java:115)
         at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:136)
         at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:150)
         at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:155)
         at
    com.typesafe.config.impl.SimpleConfig.getObject(SimpleConfig.java:209)
         at
    com.typesafe.config.impl.SimpleConfig.getConfig(SimpleConfig.java:215)
         at com.typesafe.config.impl.SimpleConfig.getConfig(SimpleConfig.java:33)
         at
    org.akka.essentials.remotenode.RemoteNodeApplication.(Native Method)
         at
    sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
         at
    sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
         at java.lang.Class.newInstance0(Class.java:372)
         at java.lang.Class.newInstance(Class.java:325)
         at akka.kernel.Main$$anonfun$1.apply(Main.scala:81)
         at akka.kernel.Main$$anonfun$1.apply(Main.scala:81)
         at
    scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:244)
         at
    scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:244)
         at
    scala.collection.IndexedSeqOptimized$class.foreach(IndexedSeqOptimized.scala:33)
         at scala.collection.mutable.WrappedArray.foreach(WrappedArray.scala:34)
         at scala.collection.TraversableLike$class.map(TraversableLike.scala:244)
         at scala.collection.AbstractTraversable.map(Traversable.scala:105)
         at akka.kernel.Main$.main(Main.scala:81)
         at akka.kernel.Main.main(Main.scala)


    In local host Remote node server running fine but when i run Local node
    server that time getting TimeOut error

    [ERROR] [12/26/2012 15:59:06.343]
    [LocalNodeApp-akka.actor.default-dispatcher-1]
    [akka://LocalNodeApp/user/$a] Timed out
    akka.pattern.AskTimeoutException: Timed out
         at akka.dispatch.DefaultPromise.result(Future.scala:875)
         at akka.dispatch.Await$.result(Future.scala:74)
         at akka.dispatch.Await.result(Future.scala)
         at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:30)
         at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
         at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
         at akka.actor.Actor$class.apply(Actor.scala:318)
         at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
         at akka.actor.ActorCell.invoke(ActorCell.scala:626)
         at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
         at akka.dispatch.Mailbox.run(Mailbox.scala:179)
         at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
         at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
         at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
         at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
         at akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)
    Caused by: akka.pattern.AskTimeoutException: Timed out
         at
    akka.pattern.PromiseActorRef$$anonfun$1.apply$mcV$sp(AskSupport.scala:274)
         at akka.actor.DefaultScheduler$$anon$6$$anon$7.run(Scheduler.scala:183)
         at akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:94)
         at
    akka.jsr166y.ForkJoinTask$AdaptedRunnableAction.exec(ForkJoinTask.java:1381)
         ... 4 more
    On Wednesday, 26 December 2012 15:36:02 UTC+5:30, h3nk3 wrote:

    Hello Raju,
    Compare your code with this example to figure out what you are
    missing/doing incorrectly:
    https://github.com/akka/akka/tree/v2.1.0/akka-samples/akka-sample-remote
    HTH
    //Henrik


    On Wed, Dec 26, 2012 at 7:45 AM, Raju Bishnoi <rajubi...@gmail.com<javascript:>
    wrote:
    Hi Viktor,

    Thanks for your response

    I deployed the Remote node jar file on server and seems working fine.

    Starting Akka...
    Running Akka 2.0.4
    Deploying file:/home/kutenda/Downloads/akka-2.0.4/deploy/RemoteNodeApp.jar
    Starting up org.akka.essentials.remotenode.RemoteNodeApplication
    Successfully started Akka

    But getting the error while running the local node file.

    [ERROR] [12/26/2012 12:10:09.544]
    [LocalNodeApp-akka.actor.default-dispatcher-2]
    [akka://LocalNodeApp/user/$a] sending to terminated ref breaks promises
    akka.pattern.AskTimeoutException: sending to terminated ref breaks
    promises
    at akka.pattern.AskSupport$class.ask(AskSupport.scala:76)
    at akka.pattern.package$.ask(package.scala:43)
    at akka.pattern.Patterns$.ask(Patterns.scala:41)
    at akka.pattern.Patterns.ask(Patterns.scala)
    at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:28)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
    at akka.actor.Actor$class.apply(Actor.scala:318)
    at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
    at akka.actor.ActorCell.invoke(ActorCell.scala:626)
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
    at akka.dispatch.Mailbox.run(Mailbox.scala:179)
    at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
    at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
    at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
    at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
    at
    akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)

    Please tell me what is wrong with me. Reply me ASAP.

    Thanks
    Raju




    On Monday, 24 December 2012 18:57:18 UTC+5:30, √ wrote:

    Hi Raju,

    Akka doesn't magically create Actorsystems on other machines.

    Please read the docs <http://akka.io/docs/> and FAQ<http://akka.io/faq/>

    Cheers,


    On Mon, Dec 24, 2012 at 1:40 PM, Raju Bishnoi wrote:

    Hello everyone;

    I am getting timed out exception while trying to access Remote actors
    from local machine.

    My application.conf file for remote actors is

    RemoteSys {
    akka {
    actor {
    provider = "akka.remote.**RemoteActorRefProvider"
    }
    remote {
    transport = "akka.remote.netty.**NettyRemoteTransport"
    netty {
    hostname = "125.153.76.235"
    port = 2552
    }
    }
    }
    }

    after deploying an application in remote machine i ran bootable class
    using akka scripts,while doing so i dont get any error but it doesnt show
    that remoteactor has been started.
    Please help me in figuring out why actor system is not started in
    remote machine.

    Thanks;
    raju



    --
    Read the docs: http://akka.io/docs/
    Check the FAQ: http://akka.io/faq/
    Search the archives: https://groups.google.com/**
    group/akka-user <https://groups.google.com/group/akka-user>
    ---
    You received this message because you are subscribed to the Google
    Groups "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+...@**
    googlegroups.com.

    Visit this group at http://groups.google.com/**group/akka-user?hl=en<http://groups.google.com/group/akka-user?hl=en>
    .



    --
    Viktor Klang

    Director of Engineering
    Typesafe <http://www.typesafe.com/> - The software stack for
    applications that scale

    Twitter: @viktorklang

    --
    ---
    You received this message because you are subscribed to the Google Groups
    "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    akka-user+...@googlegroups.com <javascript:>.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.

    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.
  • Henrik Engström at Dec 26, 2012 at 11:50 am
    "No configuration setting found for key 'RemoteSys'" means that there's no
    configuration setting for that key available.
    I would start digging in that end.

    The timeout exception you get indicates that the node you're trying to call
    is not available.
    Are you sure that it is up and running? Are you using the right address
    when you try to call it?

    I have not read Akka Essentials so I cannot comment on the examples in that
    book.
    However, I know that our docs are up to date and that the examples provided
    run as intended.
    Should you run into more problems I suggest that you either contact the
    author of the book or try with the provided examples.

    Thanks
    //Henrik

    On Wed, Dec 26, 2012 at 11:40 AM, Raju Bishnoi wrote:

    No configuration setting found for key 'RemoteSys'
    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To post to this group, send email to akka-user@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.
  • Anton Vesselov at Jun 16, 2013 at 4:39 pm
    Hello,
    I had the same problem, and it got fixed renaming resource folder to
    resources :)

    среда, 26 декабря 2012 г., 12:40:56 UTC+2 пользователь Raju Bishnoi написал:
    Hi,

    I am checking with AkkaEssential "AkkaRemotingExample" code.

    I am getting below error while run the jar on server

    Starting Akka...
    Running Akka 2.1.0
    Deploying file:/usr/share/akka-2.1.0/deploy/RemoteNodeApp.jar
    Exception in thread "main" com.typesafe.config.ConfigException$Missing: No
    configuration setting found for key 'RemoteSys'
    at com.typesafe.config.impl.SimpleConfig.findKey(SimpleConfig.java:115)
    at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:136)
    at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:150)
    at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:155)
    at
    com.typesafe.config.impl.SimpleConfig.getObject(SimpleConfig.java:209)
    at
    com.typesafe.config.impl.SimpleConfig.getConfig(SimpleConfig.java:215)
    at
    com.typesafe.config.impl.SimpleConfig.getConfig(SimpleConfig.java:33)
    at
    org.akka.essentials.remotenode.RemoteNodeApplication.<init>(RemoteNodeApplication.java:11)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
    Method)
    at
    sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    at
    sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
    at java.lang.Class.newInstance0(Class.java:372)
    at java.lang.Class.newInstance(Class.java:325)
    at akka.kernel.Main$$anonfun$1.apply(Main.scala:81)
    at akka.kernel.Main$$anonfun$1.apply(Main.scala:81)
    at
    scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:244)
    at
    scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:244)
    at
    scala.collection.IndexedSeqOptimized$class.foreach(IndexedSeqOptimized.scala:33)
    at scala.collection.mutable.WrappedArray.foreach(WrappedArray.scala:34)
    at
    scala.collection.TraversableLike$class.map(TraversableLike.scala:244)
    at scala.collection.AbstractTraversable.map(Traversable.scala:105)
    at akka.kernel.Main$.main(Main.scala:81)
    at akka.kernel.Main.main(Main.scala)


    In local host Remote node server running fine but when i run Local node
    server that time getting TimeOut error

    [ERROR] [12/26/2012 15:59:06.343]
    [LocalNodeApp-akka.actor.default-dispatcher-1]
    [akka://LocalNodeApp/user/$a] Timed out
    akka.pattern.AskTimeoutException: Timed out
    at akka.dispatch.DefaultPromise.result(Future.scala:875)
    at akka.dispatch.Await$.result(Future.scala:74)
    at akka.dispatch.Await.result(Future.scala)
    at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:30)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
    at akka.actor.Actor$class.apply(Actor.scala:318)
    at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
    at akka.actor.ActorCell.invoke(ActorCell.scala:626)
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
    at akka.dispatch.Mailbox.run(Mailbox.scala:179)
    at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
    at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
    at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
    at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
    at akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)
    Caused by: akka.pattern.AskTimeoutException: Timed out
    at
    akka.pattern.PromiseActorRef$$anonfun$1.apply$mcV$sp(AskSupport.scala:274)
    at akka.actor.DefaultScheduler$$anon$6$$anon$7.run(Scheduler.scala:183)
    at akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:94)
    at
    akka.jsr166y.ForkJoinTask$AdaptedRunnableAction.exec(ForkJoinTask.java:1381)
    ... 4 more
    On Wednesday, 26 December 2012 15:36:02 UTC+5:30, h3nk3 wrote:

    Hello Raju,
    Compare your code with this example to figure out what you are
    missing/doing incorrectly:
    https://github.com/akka/akka/tree/v2.1.0/akka-samples/akka-sample-remote
    HTH
    //Henrik

    On Wed, Dec 26, 2012 at 7:45 AM, Raju Bishnoi wrote:

    Hi Viktor,

    Thanks for your response

    I deployed the Remote node jar file on server and seems working fine.

    Starting Akka...
    Running Akka 2.0.4
    Deploying
    file:/home/kutenda/Downloads/akka-2.0.4/deploy/RemoteNodeApp.jar
    Starting up org.akka.essentials.remotenode.RemoteNodeApplication
    Successfully started Akka

    But getting the error while running the local node file.

    [ERROR] [12/26/2012 12:10:09.544]
    [LocalNodeApp-akka.actor.default-dispatcher-2]
    [akka://LocalNodeApp/user/$a] sending to terminated ref breaks promises
    akka.pattern.AskTimeoutException: sending to terminated ref breaks
    promises
    at akka.pattern.AskSupport$class.ask(AskSupport.scala:76)
    at akka.pattern.package$.ask(package.scala:43)
    at akka.pattern.Patterns$.ask(Patterns.scala:41)
    at akka.pattern.Patterns.ask(Patterns.scala)
    at
    org.akka.essentials.localnode.LocalActor.onReceive(LocalActor.java:28)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:154)
    at
    akka.actor.UntypedActor$$anonfun$receive$1.apply(UntypedActor.scala:153)
    at akka.actor.Actor$class.apply(Actor.scala:318)
    at akka.actor.UntypedActor.apply(UntypedActor.scala:93)
    at akka.actor.ActorCell.invoke(ActorCell.scala:626)
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:197)
    at akka.dispatch.Mailbox.run(Mailbox.scala:179)
    at
    akka.dispatch.ForkJoinExecutorConfigurator$MailboxExecutionTask.exec(AbstractDispatcher.scala:516)
    at akka.jsr166y.ForkJoinTask.doExec(ForkJoinTask.java:259)
    at akka.jsr166y.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:975)
    at akka.jsr166y.ForkJoinPool.runWorker(ForkJoinPool.java:1479)
    at
    akka.jsr166y.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:104)

    Please tell me what is wrong with me. Reply me ASAP.

    Thanks
    Raju




    On Monday, 24 December 2012 18:57:18 UTC+5:30, √ wrote:

    Hi Raju,

    Akka doesn't magically create Actorsystems on other machines.

    Please read the docs <http://akka.io/docs/> and FAQ<http://akka.io/faq/>

    Cheers,


    On Mon, Dec 24, 2012 at 1:40 PM, Raju Bishnoi wrote:

    Hello everyone;

    I am getting timed out exception while trying to access Remote actors
    from local machine.

    My application.conf file for remote actors is

    RemoteSys {
    akka {
    actor {
    provider = "akka.remote.**RemoteActorRefProvider"
    }
    remote {
    transport = "akka.remote.netty.**NettyRemoteTransport"
    netty {
    hostname = "125.153.76.235"
    port = 2552
    }
    }
    }
    }

    after deploying an application in remote machine i ran bootable class
    using akka scripts,while doing so i dont get any error but it doesnt show
    that remoteactor has been started.
    Please help me in figuring out why actor system is not started in
    remote machine.

    Thanks;
    raju



    --
    Read the docs: http://akka.io/docs/
    Check the FAQ: http://akka.io/faq/
    Search the archives: https://groups.google.com/**
    group/akka-user <https://groups.google.com/group/akka-user>
    ---
    You received this message because you are subscribed to the Google
    Groups "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com.
    To unsubscribe from this group, send email to akka-user+...@**
    googlegroups.com.

    Visit this group at http://groups.google.com/**group/akka-user?hl=en<http://groups.google.com/group/akka-user?hl=en>
    .



    --
    Viktor Klang

    Director of Engineering
    Typesafe <http://www.typesafe.com/> - The software stack for
    applications that scale

    Twitter: @viktorklang

    --
    Read the docs: http://akka.io/docs/
    Check the FAQ: http://akka.io/faq/
    Search the archives:
    https://groups.google.com/group/akka-user
    ---
    You received this message because you are subscribed to the Google
    Groups "Akka User List" group.
    To post to this group, send email to akka...@googlegroups.com.
    To unsubscribe from this group, send email to
    akka-user+...@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user?hl=en.

    --
    ---
    You received this message because you are subscribed to the Google Groups "Akka User List" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to akka-user+unsubscribe@googlegroups.com.
    To post to this group, send email to akka-user@googlegroups.com.
    Visit this group at http://groups.google.com/group/akka-user.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupakka-user @
categoriesscala
postedDec 24, '12 at 12:43p
activeJun 16, '13 at 4:39p
posts7
users4
websiteakka.io
irc#akka

People

Translate

site design / logo © 2017 Grokbase