FAQ

[CentOS] Problem deleting an active route

Dale
Sep 22, 2006 at 6:13 am
Hi all,

Some how I have an extra active route setup in my CentOS 4.4 system
(that unfortunately at a data center a ways away from me). I have tried
using /sbin/route del -net xxx.xxx.xxx.xxx but get an error.

I also have Webmin installed and I can delete the route from there, but
on applying the network config, the route comes back. I have no idea
where it is coming from. It is preventing me from getting out of the box
to any other services.

Any suggestions greatfully accepted!

Thanks

Dale
reply

Search Discussions

12 responses

  • Nathan at Sep 22, 2006 at 6:42 am
    what is the route? and what is the error?
    maybee give some more information about what kind of distro it is and what you
    are actually trying to delete..

    thanks


    Quoting Dale <lists@ehome.net>:
    Hi all,

    Some how I have an extra active route setup in my CentOS 4.4 system
    (that unfortunately at a data center a ways away from me). I have tried
    using /sbin/route del -net xxx.xxx.xxx.xxx but get an error.

    I also have Webmin installed and I can delete the route from there, but
    on applying the network config, the route comes back. I have no idea
    where it is coming from. It is preventing me from getting out of the box
    to any other services.

    Any suggestions greatfully accepted!

    Thanks

    Dale
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos



    Thanks

    - Nathan
    - http://www.linuxcare.ca
  • Dale at Sep 22, 2006 at 7:01 am
    Hello,

    Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    running on this box as it was just setup a couple of weeks ago.

    As root, I type:
    ./route del -net 169.254.0.0

    which returns an error of:

    SIOCDELRT: Invalid argument

    This route shows up in Webmin as well as when I type: ./route

    This is not configured as a network interface anyplace I can see. eth0
    has a legitimate, public IP assigned to it

    Dale

    Nathan wrote:
    what is the route? and what is the error?
    maybee give some more information about what kind of distro it is and what you
    are actually trying to delete..

    thanks


    Quoting Dale <lists@ehome.net>:

    Hi all,

    Some how I have an extra active route setup in my CentOS 4.4 system
    (that unfortunately at a data center a ways away from me). I have tried
    using /sbin/route del -net xxx.xxx.xxx.xxx but get an error.

    I also have Webmin installed and I can delete the route from there, but
    on applying the network config, the route comes back. I have no idea
    where it is coming from. It is preventing me from getting out of the box
    to any other services.

    Any suggestions greatfully accepted!

    Thanks

    Dale
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos



    Thanks

    - Nathan
    - http://www.linuxcare.ca
  • Email Lists at Sep 22, 2006 at 7:50 am
    -> -----Original Message-----
    -> From: centos-bounces@centos.org On
    -> Behalf Of Dale
    -> Sent: Friday, September 22, 2006 12:01 AM
    -> To: CentOS mailing list
    -> Subject: Re: [CentOS] Problem deleting an active route
    ->
    -> Hello,
    ->
    -> Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    -> running on this box as it was just setup a couple of weeks ago.
    ->
    -> As root, I type:
    -> ./route del -net 169.254.0.0
    ->
    -> which returns an error of:
    ->
    -> SIOCDELRT: Invalid argument
    ->
    -> This route shows up in Webmin as well as when I type: ./route
    ->
    -> This is not configured as a network interface anyplace I can see. eth0
    -> has a legitimate, public IP assigned to it
    ->
    -> Dale

    Im pretty sure if you want to delete a route that you need to use a more
    verbose syntax with netmask and gw and etc.

    When I do a route on one of my boxes it comes up

    [root@srv ~]# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    10.0.0.0 * 255.255.255.0 U 0 0 0 eth1
    200.55.44.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default br1.abbacomm.ne 0.0.0.0 UG 0 0 0 eth0

    eth0 is active and up. Eth1 is not active and not plugged into anything.

    I show the route as well only because I have an inactive interface meaning
    it is not admin up and so there really is no route because the interface
    isn't talking to another external interface.

    There is no reason to delete it that I can think of.

    If it is not on your active interface, down the other one as long as you can
    get back in the machine and forget about it???

    What does your routing table say?

    What does ifconfig say?

    - rh

    --
    Robert - Abba Communications
    Computer & Internet Services
    (509) 624-7159 - www.abbacomm.net
  • Dale at Sep 22, 2006 at 2:41 pm
    Hello,

    Thanks for the reply, I have pasted my complete routing table below.

    Email Lists wrote:
    -> -----Original Message-----
    -> From: centos-bounces@centos.org On
    -> Behalf Of Dale
    -> Sent: Friday, September 22, 2006 12:01 AM
    -> To: CentOS mailing list
    -> Subject: Re: [CentOS] Problem deleting an active route
    ->
    -> Hello,
    ->
    -> Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    -> running on this box as it was just setup a couple of weeks ago.
    ->
    -> As root, I type:
    -> ./route del -net 169.254.0.0
    ->
    -> which returns an error of:
    ->
    -> SIOCDELRT: Invalid argument
    ->
    -> This route shows up in Webmin as well as when I type: ./route
    ->
    -> This is not configured as a network interface anyplace I can see. eth0
    -> has a legitimate, public IP assigned to it
    ->
    -> Dale

    Im pretty sure if you want to delete a route that you need to use a more
    verbose syntax with netmask and gw and etc.

    When I do a route on one of my boxes it comes up

    [root@srv ~]# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    10.0.0.0 * 255.255.255.0 U 0 0 0 eth1
    200.55.44.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default br1.abbacomm.ne 0.0.0.0 UG 0 0 0 eth0

    eth0 is active and up. Eth1 is not active and not plugged into anything.
    Here is my complete route table:
    ./route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    69.13.211.0 * 255.255.255.192 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
    default 69.13.211.1 0.0.0.0 UG 0 0 0 eth0

    The big difference between mine and yours is that the 169.254.0.0 route
    is showing up on eth0 - which is the only port connected. I can get into
    the box, but the box can not get out to anyplace. I could be looking in
    the wrong place for the solution, I figured that this looks wrong to
    have this apparent self-assigned IP on my only active ethernet port.
    I show the route as well only because I have an inactive interface meaning
    it is not admin up and so there really is no route because the interface
    isn't talking to another external interface.

    There is no reason to delete it that I can think of.

    If it is not on your active interface, down the other one as long as you can
    get back in the machine and forget about it???
    This is my only active port. If I shut it down, the machine goes away.
    What does your routing table say? see above
    What does ifconfig say?
    ./ifconfig
    eth0 Link encap:Ethernet HWaddr 00:30:48:89:09:EC
    inet addr:69.13.211.30 Bcast:69.13.211.63 Mask:255.255.255.192
    inet6 addr: fe80::230:48ff:fe89:9ec/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:301425 errors:0 dropped:0 overruns:0 frame:0
    TX packets:39974 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:21343464 (20.3 MiB) TX bytes:8486082 (8.0 MiB)
    Base address:0x2000 Memory:c8200000-c8220000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2627 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2627 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3340381 (3.1 MiB) TX bytes:3340381 (3.1 MiB)
    - rh

    --
    Robert - Abba Communications
    Computer & Internet Services
    (509) 624-7159 - www.abbacomm.net
    Dale
  • Cian Cullinan at Sep 22, 2006 at 2:50 pm
    While the route man page can be a little confusing, there are plenty
    of examples on how to delete a route via google:

    route del -net 169.254.0.0 netmask 255.255.0.0

    worksforme
  • Email Lists at Sep 22, 2006 at 2:51 pm
    Almost sounds like a dhcp issue for some reason huh... kinda like how
    winblah deals with not getting a network huh?

    Yet, changing the zeroconf network to "no" should take care of it

    And most importantly, check to see if you have a default gateway ip address.

    That realistically is why you cannot get out, the machine works on local net
    yet doesn't know where to send packets to other than local net

    - rh

    --
    Robert - Abba Communications
    Computer & Internet Services
    (509) 624-7159 - www.abbacomm.net
  • Ralph Angenendt at Sep 22, 2006 at 8:16 am

    Dale wrote:
    As root, I type:
    ./route del -net 169.254.0.0
    That is link local and nothing to worry about. For details see RFC 3330
    and RFC 3927.

    RFC 3330:

    169.254.0.0/16 - This is the "link local" block. It is allocated for
    communication between hosts on a single link. Hosts obtain these
    addresses by auto-configuration, such as when a DHCP server may not
    be found.

    These addresses shouldn't get routed anyway.

    Regards,

    Ralph
    --
    Ralph Angenendt......ra@br-online.de | .."Text processing has made it possible
    Bayerischer Rundfunk...80300 M?nchen | ....to right-justify any idea, even one
    Programmbereich.Bayern 3, Jugend und | .which cannot be justified on any other
    Multimedia.........Tl:089.5900.16023 | ..........grounds." -- J. Finnegan, USC
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20060922/5cce91d0/attachment.bin
  • Dale at Sep 22, 2006 at 3:22 pm
    Hello Ralph and Johnny,

    Thanks for the information and suggestions.

    Ralph Angenendt wrote:
    Dale wrote:
    As root, I type:
    ./route del -net 169.254.0.0
    That is link local and nothing to worry about. For details see RFC 3330
    and RFC 3927.

    RFC 3330:

    169.254.0.0/16 - This is the "link local" block. It is allocated for
    communication between hosts on a single link. Hosts obtain these
    addresses by auto-configuration, such as when a DHCP server may not
    be found.

    These addresses shouldn't get routed anyway.

    Regards,

    Ralph

    ------------------------------------------------------------------------

    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Johnny Hughes at Sep 22, 2006 at 8:23 am

    On Fri, 2006-09-22 at 02:01 -0500, Dale wrote:
    Hello,

    Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    running on this box as it was just setup a couple of weeks ago.

    As root, I type:
    ./route del -net 169.254.0.0
    This is called the Zeroconf network ... it happens automatically in many
    OSes (Windows since win98, Mac, many Linuxes) and is designed to make
    the machine reachable on a network even with a botched network setup.

    You can make it go away with this entry in /etc/sysconfig/network:

    NOZEROCONF=yes

    Then restart the network service ... "service network restart" (or
    reboot the machine)

    However, this does remove some functionality. For more info about
    zeroconf and what it can do see:

    http://files.zeroconf.org/draft-ietf-zeroconf-ipv4-linklocal.txt

    and

    http://www.linux.com/article.pl?sid/06/15/2012219

    -------------

    If your network is properly configured, you should be able to turn off
    Zeroconf with no problems.

    <snip>

    Thanks,
    Johnny Hughes
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20060922/db07bb45/attachment.bin
  • Nathan at Sep 22, 2006 at 3:05 pm
    do you have multiple interfaces on this machine by chance?


    Quoting Dale <lists@ehome.net>:
    Hello,

    Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    running on this box as it was just setup a couple of weeks ago.

    As root, I type:
    ./route del -net 169.254.0.0

    which returns an error of:

    SIOCDELRT: Invalid argument

    This route shows up in Webmin as well as when I type: ./route

    This is not configured as a network interface anyplace I can see. eth0
    has a legitimate, public IP assigned to it

    Dale

    Nathan wrote:
    what is the route? and what is the error?
    maybee give some more information about what kind of distro it is and what you
    are actually trying to delete..

    thanks


    Quoting Dale <lists@ehome.net>:

    Hi all,

    Some how I have an extra active route setup in my CentOS 4.4 system
    (that unfortunately at a data center a ways away from me). I have tried
    using /sbin/route del -net xxx.xxx.xxx.xxx but get an error.

    I also have Webmin installed and I can delete the route from there, but
    on applying the network config, the route comes back. I have no idea
    where it is coming from. It is preventing me from getting out of the box
    to any other services.

    Any suggestions greatfully accepted!

    Thanks

    Dale
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos



    Thanks

    - Nathan
    - http://www.linuxcare.ca
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos



    Thanks

    - Nathan
    - http://www.linuxcare.ca
  • Dale at Sep 22, 2006 at 3:05 pm
    Hello,

    Nathan wrote:
    do you have multiple interfaces on this machine by chance?
    Yes, there are multiple interfaces, but only 1 connected.

    Quoting Dale <lists@ehome.net>:

    Hello,

    Distro is a standard CentOS 4.4. Nothing unusual is installed or is
    running on this box as it was just setup a couple of weeks ago.

    As root, I type:
    ./route del -net 169.254.0.0

    which returns an error of:

    SIOCDELRT: Invalid argument

    This route shows up in Webmin as well as when I type: ./route

    This is not configured as a network interface anyplace I can see. eth0
    has a legitimate, public IP assigned to it

    Dale

    Nathan wrote:
    what is the route? and what is the error?
    maybee give some more information about what kind of distro it is and what you
    are actually trying to delete..

    thanks


    Quoting Dale <lists@ehome.net>:


    Hi all,

    Some how I have an extra active route setup in my CentOS 4.4 system
    (that unfortunately at a data center a ways away from me). I have tried
    using /sbin/route del -net xxx.xxx.xxx.xxx but get an error.

    I also have Webmin installed and I can delete the route from there, but
    on applying the network config, the route comes back. I have no idea
    where it is coming from. It is preventing me from getting out of the box
    to any other services.

    Any suggestions greatfully accepted!

    Thanks

    Dale
  • Alex Palenschat at Sep 22, 2006 at 2:48 pm

    The big difference between mine and yours is that the
    169.254.0.0 route
    is showing up on eth0 - which is the only port connected. I
    can get into
    the box, but the box can not get out to anyplace. I could be
    looking in
    the wrong place for the solution, I figured that this looks wrong to
    have this apparent self-assigned IP on my only active ethernet port.
    What do you mean the box cannot get out to anyplace? What apps etc. Are
    you certain it is not a firewall or DNS issue?
    What are you trying and are there any errors? Simple stuff but sometimes
    overlooked.


    alex

Related Discussions