Piotr Jasiukajtis wrote:
Hi,

Does anyone have a problem with building libc lately?
I get this from nightly:

Warning: closed binaries not properly unpacked.
Missing libc_i18n.a
*** Error code 1
The following command caused the error:
if [ ! -f /local_code/onnv-gate/proto/root_i386/lib/libc_i18n.a -o \
! -f /local_code/onnv-gate/proto/root_i386/lib/amd64/libc_i18n.a ];
then \
if [ "$CLOSED_IS_PRESENT" = no ]; then \
echo "Warning: closed binaries not" \
"properly unpacked." >&2;\
echo "Missing libc_i18n.a" >&2; \
exit 1; \
else \
echo "Warning: libc_i18n.a must be built" \
"before libc can be built." >&2; \
exit 1; \
fi \
fi

I use the latest closed bins and I created 3 times my build environment
with the same effect.
I also can't find any bugs related to "libc_i18n.a".
I'm pretty sure you'll get this if export closed bins and not being
present and don't have access to swan.

I'm pretty sure your opensolaris.sh should have this..
ON_CLOSED_BINS="$CODEMGR_WS/closed"; export ON_CLOSED_BINS

If you are attempting to build w/o the closed bins the easiest way to
work around this is to mkdir -p $CODEMGR_WS/closed

From there it will build until you actually need the libc_i18n.a

From there there's two paths to go to try to get around this.. If
you're interested I'll detail/document both.. (You may already know)

./C

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 4 | next ›
Discussion Overview
grouposunix-dev @
categoriesopensolaris
postedDec 11, '08 at 5:11p
activeDec 11, '08 at 11:04p
posts4
users3
websiteopensolaris.org

People

Translate

site design / logo © 2017 Grokbase