FAQ

On 11 September 2015 at 13:18, Andrew Barnert wrote:
Personally, I think we're done with that change. Deprecation of the names random.Random, random.random(), etc. is sufficient to prevent people from making mistakes without realizing it.

Implementing dice rolling or number guessing for a game as "from
random import randint" is *not* a mistake, and I'm adamantly opposed
to any proposal that makes it one - the cost imposed on educational
use cases would be far too high.


Regards,
Nick.


--
Nick Coghlan | ncoghlan at gmail.com | Brisbane, Australia

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

People

Translate

site design / logo © 2017 Grokbase