FAQ

[PEAR-BUG] Bug #19172 [Opn->Asn]: upgrade PHPUnit require statements & other fixes (for PEAR QA Team)

Mj
Dec 31, 2011 at 1:57 pm
Edit report at https://pear.php.net/bugs/bug.php?id=19172&edit=1

ID: 19172
Updated by: mj@php.net
Reported By: danielc at analysisandsolutions dot com
Summary: upgrade PHPUnit require statements & other fixes (for
PEAR QA Team)
-Status: Open
+Status: Assigned
Type: Bug
Package: Text_Password
Package Version: SVN
PHP Version: 5_4 SVN-2011-12-30
-Assigned To:
+Assigned To: mj
Roadmap Versions:
New Comment:

-Status: Open
+Status: Assigned
-Assigned To:
+Assigned To: mj
I will work on this next week, but if you want to go ahead with your
changes feel free
to do so.


Previous Comments:
------------------------------------------------------------------------

[2011-12-30 01:40:10] danielc

Description:
------------
Hi Martin and Olivier:

Current versions of PHPUnit have a different layout, so calls to require
PHPUnit/Framework.php fail. Newer versions also have an autoloader.
The require statements need to be adjusted so both older and newer
versions to work.

In addition, other tweaks were necessary to get the tests running.

Getting PEAR's continuous integration testing system running is an
urgent priority. The changes involve moving some files, so it's easier
for me to do the commit rather than making and applying a patch. I have
karma and the changes on hand so can easily commit them if you like.

------------------------------------------------------------------------
reply

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›

2 users in discussion

Danielc: 1 post Mj: 1 post