Grokbase Groups Perl qa May 2011
FAQ

On Tue, May 24, 2011 at 12:14 PM, David E. Wheeler wrote:
On May 24, 2011, at 3:04 AM, David Golden wrote:

Or, if Net::Ping on the system is already 2.36
it will refuse to proceed?
I think the current CPAN clients will all refuse to proceed.  This is
what I meant when I said that version ranges don't accomplish the goal
because the computer can't know what the right thing to do is
Ah, but sometime this summer the clients (and therefor the computer) will?
I doubt it. I have plans for an "application installer" that will
pre-compute dependencies and reliably set up per-application lib
directories. Different applications could have different versions of
a module, but a single application will only have one version
available to it.

This is not something that the CPAN clients are really designed to do
(though they can be made to do the right things with INSTALLBASE and
so on).

A better specification and design for application dependencies and
installation will avoid the need to create N custom CPAN views as a
hack to make CPAN clients try to be application deployment tools.

-- David

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 16 of 40 | next ›
Discussion Overview
groupqa @
categoriesperl
postedMay 20, '11 at 7:51a
activeJun 2, '11 at 9:39a
posts40
users12
websiteqa.perl.org

People

Translate

site design / logo © 2017 Grokbase