Grokbase Groups Perl qa May 2011
FAQ

On May 24, 2011, at 9:18 AM, David Golden wrote:

I doubt it. I have plans for an "application installer" that will
pre-compute dependencies and reliably set up per-application lib
directories. Different applications could have different versions of
a module, but a single application will only have one version
available to it.

This is not something that the CPAN clients are really designed to do
(though they can be made to do the right things with INSTALLBASE and
so on).
Well, are you using the same version ranges spec for the META.json file? Seems to me that this might result in a stand-alone library that, given prereqs, could determine what should be installed. Then the existing clients could use it too, eh?
A better specification and design for application dependencies and
installation will avoid the need to create N custom CPAN views as a
hack to make CPAN clients try to be application deployment tools.
Yeah, that'll be nice.

Best,

David

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 17 of 40 | next ›
Discussion Overview
groupqa @
categoriesperl
postedMay 20, '11 at 7:51a
activeJun 2, '11 at 9:39a
posts40
users12
websiteqa.perl.org

People

Translate

site design / logo © 2017 Grokbase