Grokbase Groups Perl qa May 2011
FAQ

On Monday, May 23, 2011, David Golden wrote:
The problem is that there is no way for a single application to use multiple versions of a module.  So it's easy to imagine that very specific module prereqs could be in conflict and require manual override. That's not the right answer.

What we need is application level dependencies that are specific and non conflicting and then to make it easy to install into app specific lib directories.
That's what im
The SEND button should be harder to press by accident...

That's what I'm working on in June - trying to tie all the various
lessons from other toolchain and meta tools into something that can be
for Perl apps what cpan(p|m) is for Perl modules.

I think people are trying to make cpan solve the application level
problem and that's why "custom CPAN mirror" seems like the answer.

David

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 11 of 40 | next ›
Discussion Overview
groupqa @
categoriesperl
postedMay 20, '11 at 7:51a
activeJun 2, '11 at 9:39a
posts40
users12
websiteqa.perl.org

People

Translate

site design / logo © 2017 Grokbase