Grokbase Groups Ant user June 2009
FAQ

[Ant-user] ant 1.7.1 bug in <record> with antcall !?

Gilbert Rebhan
Jun 10, 2009 at 8:07 pm
Hi Markus,


Grimm, Markus schrieb:
Hi Gilbert,

at that time I found a workaround for my problem at
http://marc.info/?l=ant-user&m=123900769210029&w=2

If we look at the same sample script, so you have to open the log-file in the first target, that is
executed and close it in the last target: [...]
Now it works!
Hope that helps...
thanks for your response, the workmate changed his scripts like that :

before with ant 1.6.5 =
<record .... action=start append=true"/>
<antcall>
<copy> of the log to ../logs/someotherfilename.log
<antcall>
<copy> of the log to ../logs/someotherfilename.log
... etc.

so he never called <record action="stop"/> to have the output from
<copy> also into the logfile

now after the problems when upgrading to ant 1.7.1, he tried :
<record .... action=start append=true">
<antcall>
<record ... action=stop append=true/>
<copy> of the log to ../logs/someotherfilename.log
<antcall>
<record ... action=stop append=true/>
<copy> of the log to ../logs/someotherfilename.log
... etc.

and now it works for him, but only if he uses <record action=stop
with append=true> , means <record action=stop> doesn't work and gives
an empty logilfe.


Regards, Gilbert

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org
reply

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 4 | next ›

2 users in discussion

Grimm, Markus: 2 posts Gilbert Rebhan: 2 posts