FAQ

Search Discussions

39 discussions - 88 posts

  • Hi, As wagon-users@ receives very little traffic, the list will soon be shutdown. We also intend to merge wagon-dev@ into the main dev@maven.apache.org list and wagon-commits@ into the main ...
    Brett PorterBrett Porter
    May 26, 2011 at 6:10 am
    May 26, 2011 at 6:10 am
  • *I am hoping I am getting to the right people here... Anyway, here's the situation: Attempting to set up Maven to be able to deploy a site to a mercurial repository on Google Code, which from what I ...
    Cliff HillCliff Hill
    Nov 29, 2010 at 11:17 pm
    Nov 30, 2010 at 10:45 pm
  • I'm struggling with the infinite rebuild loop in Eclipse, which might be caused by an old Wagon bug. The bug is described here https://issues.sonatype.org/browse/MNGECLIPSE-1885 and ...
    David ShueDavid Shue
    Oct 19, 2010 at 7:18 pm
    Oct 19, 2010 at 7:18 pm
  • Hey, I've been asked to use SFTP to upload artifacts to our webservers using Maven2. I've gotten this to work like this: <profile <id copyDppuwebo01</id <build <plugins <plugin <groupId ...
    FhomaspFhomasp
    Sep 9, 2010 at 8:37 am
    Sep 9, 2010 at 3:19 pm
  • And if so, what versions? I'm working on a plugin, so I'm including a bunch of plexus and other stuff. Is that important? I have the following in my POM: <extensions <extension <groupId ...
    Kathryn HuxtableKathryn Huxtable
    Mar 29, 2010 at 2:30 am
    Mar 31, 2010 at 11:40 am
  • Hi, I am trying to deploy maven artifacts from a Windows machine using pscp. The protocol specified in the pom is scp, while pscp is configured in settings.xml. The deployment fails with the ...
    Florin CiubotaruFlorin Ciubotaru
    Mar 22, 2010 at 4:10 pm
    Mar 22, 2010 at 4:10 pm
  • Hi All, I am creating an application using plexus container and in need of adding proxy information to wagon manager,Right now I am adding proxy this way : NOTE : pc is plexus container ...
    Amaresh mouryaAmaresh mourya
    Jan 11, 2010 at 5:58 am
    Jan 11, 2010 at 2:12 pm
  • Hi, all: I'm using jahmm open source downloaded form http://jahmm.googlecode.com/svn/repo/be/ac/ulg/montefiore/run/jahmm/jahmm/0.6.2/ As you can see, this is a maven version . However, when I port ...
    JIA PeiJIA Pei
    Nov 17, 2009 at 11:24 pm
    Nov 17, 2009 at 11:24 pm
  • I'm on Windows XP, and I'm trying to make Maven deployment use my private key which is stored in PuTTY's Pageant ssh agent. I found an old recipe on the net that says I should use the following ...
    Daniel SerodioDaniel Serodio
    Sep 9, 2009 at 8:10 pm
    Sep 10, 2009 at 3:31 pm
  • When running "mvn deploy" I end up with error below (sorry for the long stacktrace). Just to mention - I had the same 409 error when using wagon-svn from http://is.gd/2yton. Any suggestions? I have ...
    Droidin.netDroidin.net
    Aug 25, 2009 at 10:20 pm
    Sep 7, 2009 at 7:38 am
  • I need to disable host key checking for wagon-ssh provider....how I can disable it ?? I notice that the provider get the value (ask, yes or no) from method AbstractKnownHostsProvider# ...
    Claudio Di VitaClaudio Di Vita
    Jun 25, 2009 at 4:23 pm
    Jun 25, 2009 at 4:23 pm
  • Hi There, Using Maven 2.1, I found that some fishy is going on in LightweightHttpWagon.java. I carefully traced the setting and resetting of the http.proxy system properties from within the method ...
    Henrik SorensenHenrik Sorensen
    May 15, 2009 at 1:33 pm
    May 16, 2009 at 1:49 am
  • I have run into a situation with the wagon-ssh-external version 1.0-beta-5 and maven 2.1.0. Before I attempt to fix the problem myself I wanted to ask here if there is another solution. I'm currently ...
    Tim RileyTim Riley
    Apr 14, 2009 at 4:29 pm
    Apr 15, 2009 at 12:14 am
  • Hello, according to WAGON-82, it is possible to use webdav behind a proxy starting with the fix version 1.0-beta-3. I tried to use maven-2.1.0 (which uses wagon 1.0-beta-5) and got an exception ...
    Clovis SeragiottoClovis Seragiotto
    Apr 3, 2009 at 2:50 pm
    Apr 3, 2009 at 2:50 pm
  • Hello, I am using maven 2.1.0 and the following configuration in my pom: <extension <groupId org.apache.maven.wagon</groupId <artifactId wagon-scm</artifactId <version 1.0-beta-5</version </extension ...
    Clovis SeragiottoClovis Seragiotto
    Apr 3, 2009 at 2:13 pm
    Apr 3, 2009 at 2:13 pm
  • Hello, the fix version for WAGON-221 is 1.0-beta-5, which, according to this user list, requires maven 1.0.x. But in the case I do need maven-2.0.9, is there a workaround? Thanks -- clovis Diese ...
    Clovis SeragiottoClovis Seragiotto
    Apr 3, 2009 at 1:56 pm
    Apr 3, 2009 at 2:38 pm
  • I am not able to transfer files over SCP from a user/machine setup that is using host based authentication (note I am not talking about the host authentication can't be verified yes/no known_hosts ...
    Charlie CollinsCharlie Collins
    Apr 1, 2009 at 3:28 pm
    Apr 15, 2009 at 8:10 pm
  • Hi there, I was wondering what the status of wagon-scm is with regard to Maven 2.0.10. I've read the usage page but the versions appear to be out of date ...
    Mark HobsonMark Hobson
    Mar 12, 2009 at 11:31 am
    Mar 12, 2009 at 2:50 pm
  • Hi, I am using maven 2.0.9-bin version I am trying to deploy project site on tomcat server but getting a error strange error Any help will be highly appreciated. My configuration error is given below ...
    Kumar, RavendraKumar, Ravendra
    Feb 17, 2009 at 9:30 pm
    Feb 17, 2009 at 9:30 pm
  • Hi there, I'm trying for some time now to get Maven to work with a Repository accessed by SSH / SCP. I work with a Windows box and have the putty programs (putty, plink, pscp, ...) installed and ...
    Peter GoetzPeter Goetz
    Oct 22, 2008 at 10:10 am
    Mar 9, 2010 at 6:08 pm
  • Hi, I'm getting an error java.lang.AbstractMethodError: org/apache/maven/wagon/StreamWagon.openConnection()V. My settings.xml has the entry:. <server <id csdpFtpRepository</id <username ...
    Enrique GaonaEnrique Gaona
    Aug 22, 2008 at 3:19 pm
    Aug 25, 2008 at 6:53 am
  • Hi, I'm a complete maven and wagon newbie. Wagon-s3 looks like its ideal for my requirements. Is it complete and part of 1.0-beta-3? How do I go about using this? I'm amazed that there is no simple ...
    AndyukAndyuk
    Jun 25, 2008 at 7:43 am
    Jun 25, 2008 at 7:43 am
  • Hello, I've been playing around with HTTP Wagon a bit, mainly to handle recursive file downloads from remote servers. When I tried the latest version (beta-3) I came across few issues: * Empty file ...
    Antti VirtanenAntti Virtanen
    Jun 16, 2008 at 2:34 pm
    Jun 16, 2008 at 3:05 pm
  • Can someone help me out on this? I am trying to deploy my artifacts to a remote repository but this fails because removeCheckoutDirectory of ScmWagon throws an NPE. [INFO] [deploy:deploy] ...
    ArnoldArnold
    Jun 16, 2008 at 9:13 am
    Jun 16, 2008 at 9:13 am
  • Hi I'm trying to use maven2 site deployment. One issue is that i can't use ssh for infra-structure, and i would like to use ftp for that. I get the error ...
    Emerson cargninEmerson cargnin
    Dec 10, 2007 at 12:24 pm
    Dec 11, 2007 at 4:20 pm
  • Hi, I have been trying to get WAGON-WEBDAV working with an Apache WebDAV provider and can only see that BASIC authentication is attempted. Am I missing something in the following configuration ...
    Boyle, PJBoyle, PJ
    Dec 5, 2007 at 5:53 pm
    Dec 5, 2007 at 5:53 pm
  • When I deploy to my WebDav repository (Proximity), I keep getting this INFO statement: INFO: Redirect requested but followRedirects is disabled This leads me to believe that the HttpURL object used ...
    Roshan A. PunnooseRoshan A. Punnoose
    Oct 9, 2007 at 3:33 pm
    Oct 9, 2007 at 3:33 pm
  • Hi, I'm a new maven user, I need to setup a maven remote repository into subversion using http: Could you help me to define my pom.xml or my settings.xml file? Do I need to define aditional ...
    Mar MavenMar Maven
    Jul 4, 2007 at 4:59 pm
    Jul 4, 2007 at 4:59 pm
  • In the source for ScpExternalWagon.java [1], I see that it has the capability to change the group and mode after putting files/directories, but I don't see how I set this stuff in my pom.xml or ...
    Greg ThompsonGreg Thompson
    Jun 15, 2007 at 4:57 pm
    Jun 15, 2007 at 4:57 pm
  • Hi, (crossposting to and maven-wagon-users) as Brett Porter suggested ("Storing your Maven Repository in CVS/Subversion", ...
    Alexander SchwartzAlexander Schwartz
    Jan 19, 2007 at 1:28 pm
    Jan 19, 2007 at 9:48 pm
  • On a windows machine, authenticated on an NT domain, the proxy username and password appear to be sufficient for getting the lightweight http wagon to download artifacts. On a linux machine, which is ...
    Mykel AlvisMykel Alvis
    Dec 12, 2006 at 10:07 pm
    Dec 13, 2006 at 11:00 pm
  • Two questions: Is the webdav wagon still under developement? The web site for wagon in general seems sketchy, with a lot of broken links and possibly erroneous information. I'm working on a patch to ...
    Mykel AlvisMykel Alvis
    Sep 14, 2006 at 8:31 pm
    Sep 14, 2006 at 8:31 pm
  • 1. How can I disable the file transfer progress message? (the 1k/100k...) it makes the output in text file too big and slow down the whole process. 2. How can I run deploy without redo the compile, ...
    Andrew2007Andrew2007
    Jul 3, 2006 at 5:10 am
    Jul 3, 2006 at 5:10 am
  • Reposting on Wagon user list, although it's not that active... Attempting to use an Apache 2.2 webdav server to distribute artifacts (see below details). *Require username/password authentication ...
    Darren HartfordDarren Hartford
    Jun 7, 2006 at 6:27 pm
    Jun 7, 2006 at 6:27 pm
  • If the wagon-users list is still functional and active, this archive is broken (from the pom files): http://nagoya.apache.org/eyebrowse/SummarizeList?listName=wagon-users@ma ven.apache.org -D
    Darren HartfordDarren Hartford
    Jan 4, 2006 at 2:20 pm
    Jan 4, 2006 at 8:30 pm
  • Hey all, I'm trying to setup to install jars to a remote SVN repository. Everything seems to be fine except for three issues which may be specific to Windows OS: *${user.home} never seems to ...
    Darren HartfordDarren Hartford
    Jan 3, 2006 at 9:05 pm
    Jan 3, 2006 at 9:05 pm
  • hi, is there a javadoc published somewhere for the wagon project? there is none attached in the website and i cant generate one unless i am willing to download each source by hand since i am ...
    Anuerin DiazAnuerin Diaz
    Nov 24, 2005 at 12:45 pm
    Nov 24, 2005 at 11:58 pm
  • hi all, i have tdk 2.2 on my machine ( windows 2000 ). i had earlier tried to shift to tdk2.3 but i did some changes in my environment variables and after that neither tdk2.2 nor 2.3 were working ...
    Project memberProject member
    Oct 13, 2004 at 4:39 am
    Oct 13, 2004 at 4:39 am
  • just wrote this mail to say hello to you all. just subsribed to your list. trying to learn what are mailing lists, trying to learn what is TDK, Maven, turbine and those things. i hope to get guidance ...
    Project memberProject member
    Oct 9, 2004 at 5:06 am
    Oct 9, 2004 at 5:06 am
Group Navigation
period‹ prev | Latest | first ›
Group Overview
groupwagon-users @
categoriesmaven
discussions39
posts88
users41
websitemaven.apache.org
irc#maven

Top users

Brett Porter: 16 posts CharlieCollins: 6 posts Kathryn Huxtable: 5 posts Brett Porter: 4 posts Clovis Seragiotto: 4 posts Fhomasp: 3 posts Mykel Alvis: 3 posts Droidin.net: 3 posts Dan Tran: 3 posts Darren Hartford: 3 posts Cliff Hill: 2 posts Antti Virtanen: 2 posts Daniel Serodio: 2 posts Mark Hobson: 2 posts Project member: 2 posts Emerson cargnin: 2 posts Amaresh mourya: 2 posts Andrew2007: 1 post Enrique Gaona: 1 post Henrik Sorensen: 1 post
show more